Bug 139134 - Can't connect to exchange server
Can't connect to exchange server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 141419 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-12 22:03 EST by James M. Susanka
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 17:06:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix domain handling of evolution-connector (1.09 KB, patch)
2004-11-16 12:44 EST, Jon DeSena
no flags Details | Diff

  None (edit)
Description James M. Susanka 2004-11-12 22:03:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I cannot connect to exchange server once all information is setup in
evolution.

It keeps asking for my password - I have the domain\login format for
the userid but still asks me for my password. 



Version-Release number of selected component (if applicable):
2.0.2

How reproducible:
Always

Steps to Reproduce:
1.Start evolution
2.asks for password to exchange server 
3. keeps asking for password even though it is correct and I can
connect through the imap protocol. connector is not functional with
the 2.0.2 release with fedora core 3.

    

Actual Results:  keeps asking for password

Expected Results:  should be able to see the mail account in exchange

Additional info:
Comment 1 Jon DeSena 2004-11-15 10:53:28 EST
Same symtoms for me. I have similar exchange logon format. Also note
that /usr/bin/ximian-connector-setup-2.0 properly authenticates.
Evolution, however, continually fails authentication.

Evolution 1.4.7 used to have a similar authentication problem, but
someone posted a patch which I applied (with recompile) and never had
problem since. If I get a chance I will look into this.
Comment 2 Dave Malcolm 2004-11-15 16:31:01 EST
Are you able to access the account using Outlook Web Access?  Try
browsing to http://your-server-here/exchange
Comment 3 Jon DeSena 2004-11-16 10:00:11 EST
Yes. I can access the account through the OWA web interface. No
problems. In fact, this is how I am getting my email for now. Cannot
wait to get back to a real client though.

Note that the owa interface uses forms and requires domain/username
(or domain\username) to logon.
Comment 4 Jon DeSena 2004-11-16 12:44:25 EST
Created attachment 106825 [details]
Fix domain handling of evolution-connector

I found the problem and have created a patch which remedies it. The problem is
that anything up to a / or \ in the username field is immediately stripped off
when creating the exchange account structure. 

This is done by e2k_uri_new (e2k_uri.c:104), and the domain part is stored in
uri->domain. This is unfortunate, because e2k_autoconfig_new expects the domain
to be part of the username string. Ironically, it is stripped off again and
stored in ac->nt_domain, only later to be pieced back together in
e2k_context_set_auth (e2k_context.c:331).

The patch simply puts the domain part back into the username string in the
account structure (exchange_account_new:exchange_account.c:1515)

Also, note that the rpm spec file should include gnutls-devel and
libgcrypt-devel as BuildRequires.

Hope that helps, and that an official fix can come out soon.
Comment 5 James M. Susanka 2004-11-17 14:58:28 EST
Okay - thanks - the patch did work 
but now when I try to add another person's calendar in the exchange
section it just locks up - no message or anything and I have to xkill it. 

Thanks,

James M. Susanka
Comment 6 Jon DeSena 2004-11-17 16:24:01 EST
How are you adding another persons calendar? When I try to "subscribe"
to another user's Calendar folder it does not work (comes back with a
"general error"), but evolution does not lock up. Is this what you
mean about adding another person's calendar?
Comment 7 James M. Susanka 2004-11-17 20:23:10 EST
I just go to the exchange button on the lower left and then on tools I
select subscribe to another users calendar/folder and then it comes up
with a dialog of who to put - so I click the user button to go
browse/choose a user and it locks up - like I can't do anything with
evolution. 

but if I go to compose a mail and click to and then I can choose the
global address list from exchange and I can choose whoever is in the
list so the address list seems to work okay for just composing an email. 

hope this helps - thanks James M. Susanka
Comment 8 Dave Malcolm 2004-11-19 12:49:51 EST
This looks very similar to this upstream bug:
http://bugzilla.ximian.com/show_bug.cgi?id=66926

In particular, that bug has an "official" upstream patch which adds a
windows_domain field to ExchangeAccountPrivate; the patch has been
applied to CVS (though AFAIK is not available in tarball form yet);
see this link for the patch I'm referring to:
http://bugzilla.ximian.com/showattachment.cgi?attach_id=13145

Seeing as you've already tried patching your packages, does this patch
provide a better solution for you?
Comment 9 Jon DeSena 2004-11-19 14:47:48 EST
This patch works fine for me. Do not see any difference in results
beweeen it and my patch. This new patch may be the way to go, as it is
"official." Either way, there seems to be a lot of kruft left in the
domain handling code :(, but at least it works.

Note that the other problem about subscibing to other users folders is
unaffected by either patch, but that should really be a separate bug
report. Note that the evolution app does not lock up, just the user
selection dialog. If you cancel from the _initial_ dialog, you can get
back without force quitting.
Comment 10 Jon DeSena 2004-11-22 14:14:19 EST
I need to retract my previous post. The ximian patch seemed to work
last week, but does NOT today. My patch, however, still DOES work. I
have double & triple checked that this is the case.

I think I forgot to do a evolution --force-shutdown before testing the
new patched evolution the first time, which might explain the discrepancy.

The ximian patch seems to address the issue, but something is not
right. I have not had a chance to track it down, though.

Sorry for the confusion.
Comment 11 Dave Malcolm 2004-11-30 21:36:42 EST
See also bug #141419
Comment 12 Daniel L. Rall 2004-11-30 22:18:24 EST
Bug #141419 is a duplicate of this bug -- didn't find it in with my
query before filing bug #141419.  A newer and much better patch from
the Ximian Novell folks which fixes this problem has been committed to
GNOME CVS for the Evolution Exchange Connector:

http://cvs.gnome.org/viewcvs/evolution-exchange/storage/exchange-account.c?r1=1.19&r2=1.20
Comment 13 Daniel L. Rall 2004-11-30 22:21:05 EST
*** Bug 141419 has been marked as a duplicate of this bug. ***
Comment 14 Dave Malcolm 2004-11-30 22:31:57 EST
I've built a new version of the package: evolution-connector-2.0.2-2
into Rawhide; it contains the fix that was committed to GNOME CVS
(which isn't yet available in a tarball).

Please can you try installing this package and see if it fixes this
problem.  Thanks!
Comment 15 Jon DeSena 2004-12-01 13:41:16 EST
Yes, this package does the trick now. I forced an evolution shutdown
this time and all appears well. Looks like the old patch from ximian
did not use the right username string, but this one does.

Thanks.
Comment 16 Daniel L. Rall 2004-12-01 16:29:53 EST
Dave, your new evolution-connector-2.0.2-2 RPM fixes this problem for
me.  Thank you!

You can close this issue as FIXED now (or VERIFIED if mine and Jon's
feedback count for your process).
Comment 17 Dave Malcolm 2004-12-01 17:06:51 EST
Excellent; thanks for the feedback.  Resolving as fixed in RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.