Bug 139205 - xmodmap crashes with segmentation fault
Summary: xmodmap crashes with segmentation fault
Status: CLOSED DUPLICATE of bug 138458
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-14 00:11 UTC by Jan Martinek
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Martinek 2004-11-14 00:11:13 UTC
Description of problem:

xmodmap crashes with segmentation fault when parsing a certain strings
like

xmodmap -e ' keycode  85  =   6 '

In my case, xmodmap is a part of xorg-x11-6.8.1-12.

How reproducible:

always

Steps to Reproduce:
1. run
xmodmap -e ' keycode  85  =   6 '
  
Actual results:
The result is segmentation fault

Expected results:
Flawless behaviour.

Additional info:
If space in the parsed string is ommited or added, the segmentation
fault does not occur. For example
xmodmap -e ' keycode  85   =   6 '
works fine.

Comment 1 Glen 2004-11-14 23:50:12 UTC
This is a duplicate of bug 138743.

Comment 2 Mike A. Harris 2004-11-18 02:26:34 UTC

*** This bug has been marked as a duplicate of 138458 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:07:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.