Bug 13922 - mail corrupts the header
mail corrupts the header
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mailx (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-13 18:14 EDT by crozierm
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 05:35:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description crozierm 2000-07-13 18:14:51 EDT
Hello,

This problem is present in mailx-8.1.1-8 to mailx-8.1.1-10, which kindof
leads me to believe its my fault.  However, even will all configuration
files removed/defaulted, it still occurs, so without further ado.....

when 'mail' is run and it rewrites the messages in the spool directory, it
inserts a blank line into the header of the message. This new blank
indicates "hey, the message body starts here!" and other mail readers (I
tested with pine and via imap) are deprived of the rest of the header
information.

Here is my little example:

This is my spool file after I received a message
-------------------------------------------------------------------

[crozierm@consumption crozierm]$ cat /var/spool/mail/crozierm 
From crozierm@sight-n-sound.com Thu Jul 13 15:08:33 2000
>From crozierm  Thu Jul 13 15:08:33 2000
Received: from www.sight-n-sound.com ([198.107.30.99])
        by consumption.net with esmtp (Exim 3.15 #16)
        id 13Cr9k-0003Uv-00
        for crozierm@consumption.net; Thu, 13 Jul 2000 15:08:32 -0700
Received: by www.sight-n-sound.com (Postfix, from userid 179)
        id 8E55529BB5; Thu, 13 Jul 2000 15:05:50 -0700 (PDT)
To: crozierm@consumption.net
Subject: I can't get no
Content-Length: 13
Message-Id: <20000713220550.8E55529BB5@www.sight-n-sound.com>
Date: Thu, 13 Jul 2000 15:05:50 -0700 (PDT)
From: crozierm@sight-n-sound.com (Michael Crozier)

satisfaction

[crozierm@consumption crozierm]$ 
----------------------------------------------------------------
So the header is fully intact when I first receive the message.  Now, lets
invoke the mail command
----------------------------------------------------
[crozierm@consumption crozierm]$ mail
Mail version 8.1 6/6/93.  Type ? for help.
"/var/spool/mail/crozierm": 1 message 1 new
>N  1 crozierm@sight-n-sou  Thu Jul 13 15:08  17/644   "I can't get no"
& q
Held 1 message in /var/spool/mail/crozierm
[crozierm@consumption crozierm]$ 
------------------------------------------------------------------------
Now that mail has touched it, lets see what it looks like:
-------------------------------------------------------------------------
[crozierm@consumption crozierm]$ cat /var/spool/mail/crozierm 
From crozierm@sight-n-sound.com Thu Jul 13 15:08:33 2000
Status: O

>From crozierm  Thu Jul 13 15:08:33 2000
Received: from www.sight-n-sound.com ([198.107.30.99])
        by consumption.net with esmtp (Exim 3.15 #16)
        id 13Cr9k-0003Uv-00
        for crozierm@consumption.net; Thu, 13 Jul 2000 15:08:32 -0700
Received: by www.sight-n-sound.com (Postfix, from userid 179)
        id 8E55529BB5; Thu, 13 Jul 2000 15:05:50 -0700 (PDT)
To: crozierm@consumption.net
Subject: I can't get no
Content-Length: 13
Message-Id: <20000713220550.8E55529BB5@www.sight-n-sound.com>
Date: Thu, 13 Jul 2000 15:05:50 -0700 (PDT)
From: crozierm@sight-n-sound.com (Michael Crozier)

satisfaction

[crozierm@consumption crozierm]$ 
-------------------------------------------------------------------------
Uh oh!  Now there is a space between the  "Status" line and the ">From"
line.  Lets see what Pine thinks about that
-------------------------------------------------------------------------
+    69 Jul 13 bugzilla@redhat.co    (787) Your Bugzilla
password.              
  N  70                             
(603)                                      
                          [No more messages in folder]
? Help       < FldrList   P PrevMsg       - PrevPage D Delete     R
Reply       
O OTHER CMDS > [ViewMsg]  N NextMsg     Spc NextPage U Undelete   F
Forward    
--------------------------------------------------------------------------
Notice how the last message has no sender or subject?  What do you suppose
that is?  Well, everything makes sense when we look at the body and find
out that this information is there (ie after the blank line) rather than in
the header
---------------------------------------------------------------------------
  PINE 4.21   MESSAGE TEXT             Folder: INBOX  Message 70 of 70 ALL
NEW  


>From crozierm  Thu Jul 13 15:08:33 2000
Received: from www.sight-n-sound.com ([198.107.30.99])
        by consumption.net with esmtp (Exim 3.15 #16)
        id 13Cr9k-0003Uv-00
        for crozierm@consumption.net; Thu, 13 Jul 2000 15:08:32 -0700
Received: by www.sight-n-sound.com (Postfix, from userid 179)
        id 8E55529BB5; Thu, 13 Jul 2000 15:05:50 -0700 (PDT)
To: crozierm@consumption.net
Subject: I can't get no
Content-Length: 13
Message-Id: <20000713220550.8E55529BB5@www.sight-n-sound.com>
Date: Thu, 13 Jul 2000 15:05:50 -0700 (PDT)
From: crozierm@sight-n-sound.com (Michael Crozier)

satisfaction




? Help       < MsgIndex   P PrevMsg       - PrevPage D Delete     R
Reply       
O OTHER CMDS > ViewAttch  N NextMsg     Spc NextPage U Undelete   F
Forward
Comment 1 Alan Cox 2000-07-14 19:44:00 EDT
>From blah is not a valid header field. mail was given wrong input. Now a better
question
is how did it get there and what wrote it in the first place. What mailers and
MTA do
you use and what triggered this originally. I think you need to work out how it
got there
and add a bug to the cause not the effect., although mailx shouldnt be so picky.


Comment 2 Derek Tattersall 2000-08-04 11:34:20 EDT
I can't reproduce this with mailx-8.1.1-14, using the plain vanilla
installation.
Comment 3 Hugh Bragg 2000-08-10 05:34:59 EDT
I'm not sure if this is related but AFAIK applies to only the
mailx-8.1.1-16.i386.rpm package. on RH 6.2
After upgrading my mailx program from mailx-8.1.1-10, when I use mail to read my
mail it core dumps while attempting to save mail to mbox. 
I had to downgrade before it would work properly.
All other security updates have been applied and no error are apparent.
Comment 4 Jeff Johnson 2000-08-11 14:39:14 EDT
This report seems to describe a symptom of a MTA problem rather than a mailx
problem
(please open bugs for other problems like the segfault separately, although I
believe
you are seeing bug #15728 in action).

Note You need to log in before you can comment on or make changes to this bug.