Bug 139231 - nautilus cd burning fails regularly
nautilus cd burning fails regularly
Status: CLOSED DUPLICATE of bug 160191
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 05:31 EST by Markus Bertheau
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 06:02:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus Bertheau 2004-11-14 05:31:26 EST
When I burn CDs with nautilus-cd-burner not everything is burned to
the cd (i.e. only 400 of 650 MB), the resulting cd is corrupted and I
can throw it away. This happens regularly. On FC2 it helped when I
increased the priority of the cd burning process to -10. I can burn ok
with Windows XP.

I had the same problem in FC2.

This renders CD burning unusable for me.
Comment 1 James Ettle 2005-04-08 12:08:15 EDT
I've noticed this too: all the file entries are there, but only about 60%-70% of
the actual data is written. I seem to be able to use cdrecord OK, though. This
is with kernel 2.6.10-1.770_FC3smp on my HP zx5030EA notebook with an 
HL-DT-STCD-RW/DVD GCC-4241N combined DVD reader/CD-R(W) writer.
Comment 2 Alan Shutko 2005-07-19 18:33:33 EDT
I'm seeing this problem with FC4 and nautilus-cd-burner-2.10.0-2

There is no error message, and nautilus claims that the CD was burned
successfully.  cdrecord works perfectly fine.
Comment 3 Stephen Walton 2005-07-27 13:41:05 EDT
I have some input on this bug.  I just installed k3b on my FC3 system (a Dell
Precision 350), and it burns CD's with no difficulty.  The disks passed md5sum
checking with the usual "dd if=/dev/hdc | md5sum", for example (contrary to
http://www.redhat.com/archives/fedora-test-list/2004-November/msg00875.html
which says that one has to use ide-scsi for this on 2.6 kernels).  This same
computer consistently fails to produce usable burned CD's with nautilus-cd-burner.

I used ps to find out what commands k3b and nautilus-cd-burner was using to do
the actual burn.  For k3b it was

/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=8 -dao driveropts=burnfree
-eject -data /mnt/t/swalton/rhelws4/RHEL4-U1-i386-WS-disc4.iso

while for nautilus-cd-burner it was

cdrecord dev=/dev/hdc -eject -v -data -nopad
/mnt/t/swalton/rhelws4/RHEL4-U1-i386-WS-disc4.iso

Running the second command above at a shell prompt shows that cdrecord's
defaults on my machine are: -tao, no burnfree, and 32x write speed.
Comment 4 Stephen Walton 2005-07-27 14:04:37 EDT
Just one more followup:  I found that simply adding -dao to the list of options
used for cdrecord by nautilus-cd-burner seems to fix the problem.  As of this
writing, I've burned two CD's this way and both pass md5sum checking.

This is beginning to look more like a cdrecord bug than a nautilus-cd-burner
bug, per se.  I tried to open a new report against cdrecord, but it doesn't
appear in the list of fc3 components on the bugzilla report page.
Comment 5 Tom Lane 2005-11-19 13:47:27 EST
See also bug #160191, which suggests that the -nopad option might be the issue.
Comment 6 Alexander Larsson 2005-12-16 06:02:24 EST

*** This bug has been marked as a duplicate of 160191 ***

Note You need to log in before you can comment on or make changes to this bug.