Bug 160191 - Should use -pad or else anaconda mediacheck fails
Should use -pad or else anaconda mediacheck fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 139231 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-13 05:10 EDT by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 06:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-06-13 05:10:06 EDT
Description of problem:
When writing a Fedora Core ISO image to CD, cdrecord is invoked with the -nopad
option.  This seems to universally break the anaconda mediacheck option.

As a result, the written CD cannot be checked.

I am not sure whether this is a bug with

a) nautilus-cd-burner,
b) the way Fedora Core ISO images are MD5SUM-embedded
c) the way anaconda checks the images against the sum

Version-Release number of selected component (if applicable):
nautilus-cd-burner-2.10.0-2

How reproducible:
100%

Steps to Reproduce:
1. Write a Fedora Core 4 disc1 CD using nautilus-cd-burner
2. Boot the CD with 'linux mediacheck nocddma'
  
Actual results:
FAIL

Expected results:
PASS
Comment 1 Tim Waugh 2005-06-13 05:12:40 EDT
I should mention that there is no method of checking CDs written in this way. 
MD5SUMs of ISO images before writing do not match MD5SUMs of CDs unless they are
written with -pad.
Comment 2 Tom Lane 2005-11-19 13:32:12 EST
I think I've just run into this same problem: I burned a set of FC4 CDs using
nautilus (right click on ISO file, choose write to cd), and they were all bad.
I tested with

dd if=/dev/cdrom bs=512 | cmp - FC-xxx.iso

and in all cases the dd came up with "Input/output error" a bit before the end
of the CD (anywhere from 2K to several hundred K before the end).  The cmp
didn't show any differences before that, so I don't think this is the CD
burner's fault.

What's even more disturbing is that anaconda's media check facility claimed that
two of the five CDs were good, when the dd test proves they aren't.  Perhaps I
should file that as a separate bug?

This was with FC4 tip, ie
nautilus-cd-burner-2.10.0-2
cdrecord-2.01.1-9.0.FC4.1
and whatever version of anaconda is on the FC4 release CDs.  The hardware is a
Dell 470n that just arrived yesterday ...
Comment 3 Alexander Larsson 2005-12-16 06:01:49 EST
Seems to be fixed upstream now:
http://bugzilla.gnome.org/show_bug.cgi?id=315068
Closing rawhide, since this will be in fc5.
Comment 4 Alexander Larsson 2005-12-16 06:02:47 EST
*** Bug 139231 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.