Bug 139274 - Anaconda crashes when trying to do a clean install of FC3 release version
Anaconda crashes when trying to do a clean install of FC3 release version
Status: CLOSED DUPLICATE of bug 137846
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-14 14:53 EST by Joe Nicholls
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Nicholls 2004-11-14 14:53:03 EST
Description of problem:Anaconda reports the following:  "An unhandled 
exception hass occurred.  This is most likely a bug.  Please copy the 
full text of this exception or save the crash dump to a floppy then 
file a detailed bug report against anaconda at ....

The last few lines of the text are:

File "/usr/lib/anaconda/isys.py", line 594, in readJFSLabel
label=readJFSLabel_int("/tmp/disk")

File "/usr/lib/anaconda/isys.py", line 582, in readJFSLabel_int
os.lseek(fd, 32768, 0)

OSError:[Errno 22] Invalid argument

=============
Went back and tried FC3 Test2 CDs and the probem does not occure.  
Sorry, I did not keep a copy of FC3 Test3 CDs to try them.
=============


Version-Release number of selected component (if applicable):
Fedora Core 3 release from iso CDs

How reproducible:
Run an installation and specify to remove all particians on hda, 
leaving the rest of the disk drives untouched.  Crash occures after 
formating the root file system and the /boot file system.  
Reproducable whether a swap partician is asked to be created or not.  
Also reproducable whether hda is allowed to be in the default volume 
group 00 or if all that is gotten rid of and the 3 particians are 
specified directly on hda (that is /, /boot, and swap).

Steps to Reproduce:
1.Boot from FC3 CD 1
2.Select a new install
3.Select to remove all particians on hda
  
Actual results:
"an unhandled exception has occurred."

Expected results:


Additional info:
Comment 1 Joe Nicholls 2004-11-14 19:42:14 EST
The problem seems to be with MD disk arrays.  I had created 2 md raid 
0 (striped arrays) (not LVM) when I installed FC3 Test2.  I 
deselected these from being reformated when I was trying to clean 
install of the FC3 release version.  I physically disconnected the 
drives involved in the arrays (one was a pair of SCSI disks, and the 
other a pair of ata133 disks), and the installation went fine.  Of 
course I will have to go back and manually add the disk arrays.  
Thus, I think the problem has something to do with the pre-existing 
md raid 0 devices.
Comment 2 Jeremy Katz 2004-11-15 10:26:31 EST

*** This bug has been marked as a duplicate of 137846 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.