Bug 137846 - Installer crashes after formating partitions
Installer crashes after formating partitions
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 139274 141957 142610 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-01 22:29 EST by brian naasz
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 18:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Dump file (696.37 KB, text/plain)
2004-11-01 22:32 EST, brian naasz
no flags Details
Anaconda exception dump (text mode) (680.51 KB, text/plain)
2004-12-28 13:37 EST, Josh Hoff
no flags Details

  None (edit)
Description brian naasz 2004-11-01 22:29:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20041004

Description of problem:
Installer always crashes at the exact same point.  It does not matter
if I use CDs, NFS or hard drive image.

I am trying to install on an empty /dev/hda drive.  I have a redhat 9
 setup already on a software RAID on /dev/hde and /dev/hdg that I do
not want to disturb.

Here is the error (I will attach the dump file also):

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1165, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/text.py",
line 507, in run
    dispatch.gotoNext()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 171, in gotoNext
    self.moveStep()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/dispatch.py",
line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/packages.py",
line 557, in turnOnFilesystems
    thefsset.makeFilesystems (instPath)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line
1479, in makeFilesystems
    self.labelEntry(entry, chroot)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line
1369, in labelEntry
    entry.fsystem.labelDevice(entry, chroot)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line
517, in labelDevice
    label = labelFactory.createLabel(entry.mountpoint, self.maxLabelChars)
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/fsset.py", line
112, in createLabel
    labels = diskset.getLabels()
  File
"/usr/src/build/475969-i386/install//usr/lib/anaconda/partedUtils.py",
line 568, in getLabels
    label = isys.readFSLabel(dev)
  File "/usr/lib/anaconda/isys.py", line 639, in readFSLabel
    label = readJFSLabel(device, makeDevNode)
  File "/usr/lib/anaconda/isys.py", line 594, in readJFSLabel
    label = readJFSLabel_int("/tmp/disk")
  File "/usr/lib/anaconda/isys.py", line 582, in readJFSLabel_int
    os.lseek(fd,32768,0)
OSError: [Errno 22] Invalid argument
 
Local variables in innermost frame:
device: /tmp/disk
jfslabel: None
fd: 43
 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install from CD images.
2.Format partitions as ext3/LVM... does not matter
3.Choose any or all packages ... does not matter
4.Accept defaults until it crashes.
    

Actual Results:  Crashes every time at the exact same place with the
same error dump.

Expected Results:  Successful install

Additional info:

I have downloaded the install image 3 times.  Each time the MD5SUMs
have matched. I ran the media check on the CDs and they were good. 
The NFS and harddrive installs gave the exact same results as the CDs.

Package selection and partition type do not make a difference.
Comment 1 brian naasz 2004-11-01 22:32:30 EST
Created attachment 106057 [details]
Anaconda Dump file

This is as default as I could make the install with 'everything' selected for
packages.
Comment 2 brian naasz 2004-11-02 09:10:48 EST
If I add 'hde=none hdg=none' to the kernel options it installs.

Something in Anaconda must be trying to mount and use the /dev/md*
arrays even though I have not selected them for installation.

Comment 3 Jeremy Katz 2004-11-02 09:30:32 EST
Even though you're not using them for installation, we have to try to
look at the filesystem label on there to avoid duplicate labels.

I've added some code to do better error handling on the reads, but I'm
curious as to why it's failing.  Is there anything odd about the md
arrays?
Comment 4 brian naasz 2004-11-02 11:21:18 EST
Maybe its because there are no labels?  I use fixed devices instead of
labels so I do not run into problems on dual booting linux installs. 
Well not until recently.

Here is what I have:

# cat /proc/mdstat
Personalities : [linear] [raid1]
read_ahead 1024 sectors
md6 : active raid1 hde9[0] hdg9[1]
      16659136 blocks [2/2] [UU]

md5 : active raid1 hde7[0] hdg7[1]
      2000256 blocks [2/2] [UU]

md4 : active raid1 hde6[0] hdg6[1]
      30000512 blocks [2/2] [UU]

md3 : active raid1 hde5[0] hdg5[1]
      25000320 blocks [2/2] [UU]

md2 : active raid1 hde3[0] hdg3[1]
      1000320 blocks [2/2] [UU]

md1 : active linear hde2[0] hdg2[1]
      2000640 blocks 32k rounding

md0 : active raid1 hde1[0] hdg1[1]
      488768 blocks [2/2] [UU]

unused devices: <none>
# for i in 0 1 2 3 4 5 6 ; do echo /dev/md${i}: \"`e2label dev/md$i`\"
; done
/dev/md0: ""
/dev/md1: ""
/dev/md2: ""
/dev/md3: ""
/dev/md4: ""
/dev/md5: ""
/dev/md6: ""

Comment 5 Jeremy Katz 2004-11-02 11:53:22 EST
Hmm, maybe.  Although it still shouldn't traceback on the reads.  Oh
well, should be fixed in CVS.
Comment 6 Jeremy Katz 2004-11-15 10:26:45 EST
*** Bug 139274 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2004-12-06 11:07:47 EST
*** Bug 141957 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2004-12-10 17:00:36 EST
*** Bug 142610 has been marked as a duplicate of this bug. ***
Comment 9 Josh Hoff 2004-12-28 13:37:25 EST
Created attachment 109155 [details]
Anaconda exception dump (text mode)

Trying to install Fedora Core 3 onto i686 system with SCSI hard disks. 
Software RAID-0 used as root "/" across seven SCSI hard disks (34GB total
capacity).  Note: "/boot" partition is on 170MB IDE hard disk; Boot Loader
installed to MBR of same IDE hard disk.)  No Operating Systems exist on any
hard disk in the system.  Looks like anaconda is trying to create the Software
RAID device /dev/md0 when exception is thrown.	Using Adaptec AHA-2940U/2940UW
PCI SCSI controller.

Note You need to log in before you can comment on or make changes to this bug.