Bug 1392918 - Ansible rebuild fails as tagged as noarch but has BuildRequires that is arch specific
Summary: Ansible rebuild fails as tagged as noarch but has BuildRequires that is arch ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ansible
Version: epel7
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1393147 (view as bug list)
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2016-11-08 13:32 UTC by Fabian Arrotin
Modified: 2016-11-28 06:18 UTC (History)
8 users (show)

Fixed In Version: ansible-2.2.0.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-28 06:18:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Fabian Arrotin 2016-11-08 13:32:24 UTC
Description of problem:

rebuilding Ansible as a noarch fails if caught by a non x86_64 builder due to BuildRequires: docker (so arch specific)


Version-Release number of selected component (if applicable):


How reproducible:

Try to rebuild ansible on another arch (ppc64 as an example)
See https://cbs.centos.org/koji/taskinfo?taskID=129504

For epel, it seems the job in koji was caught by an x86_64 builder so that build issue wasn't caught : 

https://kojipkgs.fedoraproject.org//packages/ansible/2.2.0.0/3.el7/data/logs/noarch/

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Kevin Fenzi 2016-11-08 14:54:55 UTC
(In reply to Fabian Arrotin from comment #0)
> Description of problem:
> 
> rebuilding Ansible as a noarch fails if caught by a non x86_64 builder due
> to BuildRequires: docker (so arch specific)
> 
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> Try to rebuild ansible on another arch (ppc64 as an example)
> See https://cbs.centos.org/koji/taskinfo?taskID=129504
> 
> For epel, it seems the job in koji was caught by an x86_64 builder so that
> build issue wasn't caught : 
> 
> https://kojipkgs.fedoraproject.org//packages/ansible/2.2.0.0/3.el7/data/logs/
> noarch/

No, I am well aware of the issue. ;) 

Just there was no other better choice. docker is only used for the tests/check section of the build. It's not used at runtime at all. So the choices were: 

1. Make ansible an arch package. But that doesn't make sense because it really is noarch, it only uses docker for tests. 

2. Disable docker tests, but then we don't get full unit test coverage. 

3. Add docker BR but keep things noarch. yes, this does mean you have to shop around for builders sometimes, but alas, thats the way it goes. 

I'm open to any other ideas here, but I don't see any better options. 
Unless you do, I am inclined to close this NOTABUG. :)

Comment 2 Yaakov Selkowitz 2016-11-09 03:17:44 UTC
*** Bug 1393147 has been marked as a duplicate of this bug. ***

Comment 3 Kevin Fenzi 2016-11-09 21:11:58 UTC
ok. Talked with upstream here and they adjusted the tests so it skips those tests if docker is not available. 

I'm going to push a fixed one into rawhide in a min here... but we do we need to push this to all the other fedora/epel branches too? or ?

Comment 4 D. Marlin 2016-11-09 22:22:44 UTC
I encountered this issue on EPEL7 for AArch64, so pushing it to EPEL7 would be appreciated.

Comment 5 Fedora Update System 2016-11-11 14:42:37 UTC
ansible-2.2.0.0-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3861229669

Comment 6 Fedora Update System 2016-11-12 06:18:22 UTC
ansible-2.2.0.0-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3861229669

Comment 7 Fedora Update System 2016-11-28 06:18:19 UTC
ansible-2.2.0.0-4.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.