Bug 1393147 - ansible no longer builds for aarch64 epel7
Summary: ansible no longer builds for aarch64 epel7
Keywords:
Status: CLOSED DUPLICATE of bug 1392918
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ansible
Version: epel7
Hardware: aarch64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: epel7aarch64
TreeView+ depends on / blocked
 
Reported: 2016-11-09 01:23 UTC by D. Marlin
Modified: 2016-11-09 03:17 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-09 03:17:44 UTC
Type: Bug


Attachments (Terms of Use)

Description D. Marlin 2016-11-09 01:23:53 UTC
Description of problem:

ansible no longer builds from source for Fedora EPEL7 on RHELSA-7.2.


Version-Release number of selected component (if applicable):

  ansible-2.2.0.0-3.el7


How reproducible:

  consistently


Steps to Reproduce:
1.  On a RHELSA-7.2 host:
    mock rebuild ansible-2.2.0.0-3.el7.src.rpm
2.
3.


Actual results:

Error: No Package found for docker


Expected results:

builds without errors.


Additional info:

ansible-2.1.2.0-1.el7 successfully built for EPEL7 on RHELSA-7.2, but docker was added as a build requirement for ansible-2.2.0.0.  Docker is not available for RHELSA-7.2, so the build fails.

Comment 1 Kevin Fenzi 2016-11-09 01:27:03 UTC
Yes, please see https://bugzilla.redhat.com/show_bug.cgi?id=1392918#c1

I guess we can try and disable the tests that use docker, but what a PITA.

Comment 2 Yaakov Selkowitz 2016-11-09 03:17:44 UTC

*** This bug has been marked as a duplicate of bug 1392918 ***


Note You need to log in before you can comment on or make changes to this bug.