Bug 1393006 - Obsoletes fonts-%{name} wrongly
Summary: Obsoletes fonts-%{name} wrongly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1396849 (view as bug list)
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2016-11-08 16:44 UTC by Nils Philippsen
Modified: 2016-11-24 02:29 UTC (History)
10 users (show)

Fixed In Version: blender-2.78a-2.fc24 blender-2.78a-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-19 17:24:50 UTC


Attachments (Terms of Use)

Description Nils Philippsen 2016-11-08 16:44:33 UTC
Description of problem:
When trying to update my Rawhide VM, blender fails to be updated  if fonts-blender is installed in E-V-R 1:2.78-2%{?dist} (which is "higher" than 2.78-2 for RPM). Looking at bodhi, this probably affects all Fedora versions.

Version of the affected component:
blender-2.78a-1.fc25
blender-fonts-2.78a-1.fc25

The line should rather be this:

Obsoletes:  fonts-%{name} < 1:2.78-3

I.e., mention the epoch and use less than the next greater release rather than less-or-equal to the current release (without dist tag).

Comment 1 Nils Philippsen 2016-11-08 16:45:42 UTC
NB: Also noticed this when trying to update from F-25 Beta to current.

Comment 2 Luya Tshimbalanga 2016-11-08 19:34:19 UTC
Thank you for the report. The fix is on the way. I noticed the Rawhide version failed to build on PPC64le architecture for some odd reasons.
http://koji.fedoraproject.org/koji/taskinfo?taskID=16356078

Attempting to rebuild as I type:
http://koji.fedoraproject.org/koji/taskinfo?taskID=16356920

Comment 3 Theodore Lee 2016-11-10 07:13:28 UTC
FWIW, I believe this also currently prevents upgrading from F23 to F24 via the DNF system upgrade plugin.

Comment 4 Fedora Update System 2016-11-10 07:43:34 UTC
blender-2.78a-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-73d62463bd

Comment 5 Fedora Update System 2016-11-10 07:43:46 UTC
blender-2.78a-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-74c94c7019

Comment 6 Luya Tshimbalanga 2016-11-10 07:49:00 UTC
I will leave this bug open for the time being. The build on Rawhide is blocked by ppc64le architecture preventing to apply the fix. However, the build is successful on other release in detriment of breaking version on Rawhide.

Comment 7 Fedora Update System 2016-11-10 19:27:10 UTC
blender-2.78a-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-73d62463bd

Comment 8 Fedora Update System 2016-11-11 05:02:05 UTC
blender-2.78a-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-74c94c7019

Comment 9 Fedora Update System 2016-11-19 17:24:50 UTC
blender-2.78a-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2016-11-19 21:15:39 UTC
blender-2.78a-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Luya Tshimbalanga 2016-11-24 02:29:45 UTC
*** Bug 1396849 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.