Bug 139325 - Illegal instruction when starting evolution
Illegal instruction when starting evolution
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 02:28 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-16 12:15:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace until it is gone (515.64 KB, text/plain)
2004-11-15 02:30 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2004-11-15 02:28:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Versions:
evolution-2.0.2-3
evolution-data-server-1.0.2-3
evolution-connector-2.0.2-1
evolution-webcal-1.0.10-1
evolution-devel-2.0.2-3
evolution-data-server-devel-1.0.2-3

Upgraded from fc2 to fc3, started evolution, converted files
everything seemed ok.

Yesterday added more fc3 rpms. started evolution today, still asked
whether to delete or keep files, said delete and it didn�t start.
Started on the commandline:

[bobo@darkstar ~]$ evolution
Illegal instruction




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start evolution...
2.
3.
    

Additional info:

Here is the bt from the core:
(gdb) bt
#0  0x0093c7ba in ?? () from
/usr/lib/evolution/2.0/libevolution-importer.so.0
#1  0x075d5a20 in e_tree_get_type () from /usr/lib/libgal-2.2.so.1
#2  0x0030c27f in g_type_free_instance () from
/usr/lib/libgobject-2.0.so.0
#3  0x0030d9b1 in g_type_class_ref () from /usr/lib/libgobject-2.0.so.0
#4  0x002f5878 in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#5  0x002f5c4e in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#6  0x002f50d6 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#7  0x075cae79 in e_tree_scrolled_get_type () from
/usr/lib/libgal-2.2.so.1
#8  0x0030b45f in g_type_create_instance () from
/usr/lib/libgobject-2.0.so.0
#9  0x002f5c7f in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#10 0x002f540e in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#11 0x002f5ac0 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#12 0x002f50d6 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#13 0xf6cd5ae7 in message_list_new ()
   from /usr/lib/evolution/2.0/components/libevolution-mail.so
#14 0xf6c962b4 in em_folder_view_open_selected ()
   from /usr/lib/evolution/2.0/components/libevolution-mail.so
#15 0x0030b45f in g_type_create_instance () from
/usr/lib/libgobject-2.0.so.0
#16 0x002f5c7f in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x002f540e in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#18 0x002f5c4e in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#19 0x002f50d6 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#20 0xf6c96f7f in em_folder_browser_new ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/evolution/2.0/components/libevolution-mail.so
#21 0xf6cbf6e3 in mail_component_load_store_by_uri ()
   from /usr/lib/evolution/2.0/components/libevolution-mail.so
#22 0x0024cb37 in
_ORBIT_skel_small_GNOME_Evolution_Component_createControls ()
   from /usr/lib/evolution/2.0/libeshell.so.0
#23 0x00abd46d in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#24 0x0024df27 in GNOME_Evolution_Component_createControls ()
   from /usr/lib/evolution/2.0/libeshell.so.0
#25 0x0805dda9 in e_shell_window_commands_setup ()
#26 0x0030699e in g_cclosure_marshal_VOID () from
/usr/lib/libgobject-2.0.so.0
#27 0x002f2160 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#28 0x00306165 in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
#29 0x00305127 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#30 0x00305424 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#31 0x08062a14 in e_sidebar_select_button ()
#32 0x0805ebc2 in e_shell_window_switch_to_component ()
#33 0x0805f766 in e_shell_window_new ()
#34 0x08061f33 in e_shell_create_window ()
#35 0x08063679 in e_sidebar_new ()
#36 0x001a35a3 in g_child_watch_add () from /usr/lib/libglib-2.0.so.0
#37 0x001a01e2 in g_main_depth () from /usr/lib/libglib-2.0.so.0
#38 0x001a12d8 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#39 0x001a1610 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#40 0x001a1c53 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#41 0x0723bdd5 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#42 0x08063af9 in main ()
(gdb)
Comment 1 Need Real Name 2004-11-15 02:30:08 EST
Created attachment 106697 [details]
strace until it is gone
Comment 2 Dave Malcolm 2004-11-15 16:56:02 EST
What version of libgal2?  What kind of CPU?  Please can you ensure
libgal2-debuginfo is installed, and give another bt.  Thanks!
Comment 3 Need Real Name 2004-11-16 02:09:20 EST
Regarding the versions:
libgal2-devel-2.2.3-3
libgal2-debuginfo-2.2.3-3
libgal23-0.24-4
libgal2-2.2.3-3

but a very strange thing happended. Up2date updated gaim and installed
libsilc, I installed libgal2-debuginfo and evolution-debuginfo and
then it didn't happen anymore (meaning evolution came up fine).

Afterwards I uninstalled those 4 packages and it still worked (even
after reboot).

I have the feeling that one of the other packages (I don't remember
which ones) I installed from fc3 after the upgrade must have messed
things up a little and that the postinstall from gaim or libsilc
cleaned things up a little? It can't be ldconfig because I did that
one manually too...

Anyway it works now and I can't reproduce the problem anymore.

On a side note I noticed that I am still running the glib2 from FC2
because it has a higher version number than the one that comes with FC3:
glib2-devel-2.4.7-1.1
glib2-2.4.7-1.1

The CPU is an AMD Athlon(tm) XP 2500+ by the way.

Sorry for the trouble... I leave you to close this bug...
Comment 4 Dave Malcolm 2004-11-16 12:15:26 EST
Closing as WORKSFORME; to be reopened if it recurs.  Thanks.
Comment 5 Brett Porter 2004-11-25 18:31:58 EST
I'm experiencing this just one day after installing FC3.
Reinstalling the evolution RPM worked.
Comment 6 Dave Malcolm 2004-11-29 16:35:59 EST
So it's working for everyone now?

My current belief is that this is a duplicate of bug #140081

Comment 7 Brett Porter 2004-11-29 16:58:54 EST
only worked by reinstalling evolution. I've actually switched to
Thunderbird, so I don't know if it will recur.

it could be related as I am also experiencing that bug - but that bug
still occurs after reinstalling evolution.

HTH

Note You need to log in before you can comment on or make changes to this bug.