Bug 1393886 - Backport bind dyndb API introduced in bind 9.11
Backport bind dyndb API introduced in bind 9.11
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Menšík
Petr Sklenar
Aneta Šteflová Petrová
:
Depends On:
Blocks: 1399979 1380362 1393869 1393889 1411886
  Show dependency treegraph
 
Reported: 2016-11-10 09:34 EST by Petr Vobornik
Modified: 2017-08-01 16:40 EDT (History)
4 users (show)

See Also:
Fixed In Version: bind-9.9.4-44.el7
Doc Type: Enhancement
Doc Text:
DynDB API from the upstream version 9.11.0 of BIND added to Red Hat Enterprise Linux This update backports the API for the *dyndb* system plug-in, which was introduced in the _bind_ package version 9.11.0 in upstream. As a result, the *bind-dyndb-ldap* plug-in in Red Hat Enterprise Linux now uses the new API. The downstream feature *dynamic_db*, which was used in previous releases of Red Hat Enterprise Linux, is no longer supported. Because the upstream *dyndb* uses a different configuration syntax than the downstream *dynamic_db*, the syntax also changes with this update. However, you do not need to make any manual configuration changes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 16:40:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1767 normal SHIPPED_LIVE bind bug fix update 2017-08-01 14:30:50 EDT

  None (edit)
Description Petr Vobornik 2016-11-10 09:34:27 EST
Bind 9.11.O introduced dyndb API https://lists.isc.org/pipermail/bind-announce/2016-October/001007.html

New versions of bind-dyndb-ldap(used by IdM) in current Fedoras use this API. 

This is a request to backport this API support to RHEL so that bind-dyndb-ldap in RHEL can use it. It will then allow rebase of bind-dyndb-ldap and therefore lower maintance cost - possibility of backporting patches without reimplementing them in a future.
Comment 1 Tomáš Hozza 2016-11-10 11:54:54 EST
We will replace the existing downstream patch adding DynDB API with the upstream one.
Comment 13 errata-xmlrpc 2017-08-01 16:40:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1767

Note You need to log in before you can comment on or make changes to this bug.