Bug 1393889 - Rebase to bind-dyndb-ldap 11+
Rebase to bind-dyndb-ldap 11+
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
7.4
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Tomas Krizek
Namita Soman
Aneta Šteflová Petrová
: Rebase
Depends On: 1393886
Blocks: 1399979 1413805
  Show dependency treegraph
 
Reported: 2016-11-10 09:42 EST by Petr Vobornik
Modified: 2017-08-01 15:27 EDT (History)
6 users (show)

See Also:
Fixed In Version: bind-dyndb-ldap-11.1-2.el7
Doc Type: Release Note
Doc Text:
_bind-dyndb-ldap_ rebased to version 11.1 The _bind-dyndb-ldap_ package has been upgraded to upstream version 11.1, which provides a number of bug fixes and enhancements over the previous version. Notably, the `/etc/named.conf` file now uses the new DynDB API. Updating the _bind-dyndb-ldap_ package automatically converts the file to the new API style.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 15:27:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2120 normal SHIPPED_LIVE bind-dyndb-ldap bug fix update 2017-08-01 14:15:06 EDT

  None (edit)
Description Petr Vobornik 2016-11-10 09:42:53 EST
bind-dyndb-ldap 10.1+ uses dynbd API introduced in bind 9.11, It should be rebased to enable future bugfixes and RFEs. Without rebase a substantial rewrite of patches developed upstream/Fedora would be needed.
Comment 1 Petr Spacek 2016-11-11 03:37:44 EST
Correct version is >= 11.
Comment 7 Namita Soman 2017-05-17 07:14:57 EDT
# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 Beta (Maipo)

# rpm -qi bind-dyndb-ldap
Name        : bind-dyndb-ldap
Version     : 11.1
Release     : 3.el7
Architecture: x86_64
Install Date: Fri 12 May 2017 10:49:10 AM EDT
Group       : System Environment/Libraries
Size        : 319368
License     : GPLv2+
Signature   : RSA/SHA256, Fri 28 Apr 2017 08:52:25 AM EDT, Key ID 199e2f91fd431d51
Source RPM  : bind-dyndb-ldap-11.1-3.el7.src.rpm
Build Date  : Fri 28 Apr 2017 08:34:10 AM EDT
Build Host  : x86-038.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : https://releases.pagure.org/bind-dyndb-ldap
Summary     : LDAP back-end plug-in for BIND
Description :
This package provides an LDAP back-end plug-in for BIND. It features
support for dynamic updates and internal caching, to lift the load
off of your LDAP server.
Comment 8 errata-xmlrpc 2017-08-01 15:27:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2120

Note You need to log in before you can comment on or make changes to this bug.