Bug 1393950 - Apps keep loading for ages under Wayland
Summary: Apps keep loading for ages under Wayland
Keywords:
Status: CLOSED DUPLICATE of bug 1376471
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-10 17:07 UTC by Axel Matías
Modified: 2016-11-10 17:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-10 17:20:06 UTC
Type: Bug


Attachments (Terms of Use)
Opening Nautilus under Wayland (2.24 MB, image/png)
2016-11-10 17:07 UTC, Axel Matías
no flags Details

Description Axel Matías 2016-11-10 17:07:38 UTC
Created attachment 1219462 [details]
Opening Nautilus under Wayland

Description of problem:

   When opening an app from the app drawer under Wayland the app opens normally but the the hour glass cursor keeps there for ages (as well as the loafing icon in top bar). This happens only with certain apps (nautilus or gnome-photos or gedit i.e.).
As a curiosity, if you run the command directly from ter terminal this doesn't happen. The ''loading icon'' also appears when you close the app, which should not happen neither.

Version-Release number of selected component (if applicable):
Gnome 3.22

How reproducible:
Open apps from app drawer in Gnome Shell under Wayland session. Happens with some apps (as Nautilus, Gedit or Gnome-photos) but not with all (Calculator is not affected). Also close the app to see it appears again.

Steps to Reproduce:
1. Login into Gnome Shell session under Wayland
2. Open the app drawer
3. Open an app and see the icon not disappearing.
4. Close the app and see the loading icon appearing for ages again.

Actual results: The system thinks the app is still loading when it already has. It means there is an annoying hourglass icon in your cursor nd a loading icon in top bar for too much time.


Expected results: The cursor goes back to normal when the app has been loaded. Same to the top bar.


Additional info:

Comment 1 Axel Matías 2016-11-10 17:16:09 UTC
*How reproducible: 100%*
Just a misunderstanding sorry.

Comment 2 Florian Müllner 2016-11-10 17:20:06 UTC

*** This bug has been marked as a duplicate of bug 1376471 ***


Note You need to log in before you can comment on or make changes to this bug.