Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1394191 - backport rc.debug to rhel7
backport rc.debug to rhel7
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Kaspar [Dee'Kej]
Leos Pol
Filip Hanzelka
: EasyFix, Patch
Depends On: 1392766
Blocks: 1393867 1400961
  Show dependency treegraph
 
Reported: 2016-11-11 06:23 EST by Lukáš Nykrýn
Modified: 2017-08-02 03:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: initscripts-9.49.38-1.el7
Doc Type: Release Note
Doc Text:
"rc.debug" kernel allows easier debugging of `initscripts` This enhancement introduces the "rc.debug" option for the kernel command line. Adding the "rc.debug" option to the kernel command line prior to booting produces a log of all the activity of the `initscripts` files during the boot and termination processes. The log appears as part of the `/var/log/dmesg` log file. As a result, adding the "rc.debug" option to the kernel command line enables easier debugging of `initscripts` if needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 03:29:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2286 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2017-08-01 07:26:43 EDT

  None (edit)
Description Lukáš Nykrýn 2016-11-11 06:23:56 EST
https://github.com/fedora-sysv/initscripts/commit/8447253e512d98316c5ab9cbcfe335720163349b

This comes quite handy, when we are debugging initscripts and network-scripts.
Comment 4 Leos Pol 2017-04-26 08:47:51 EDT
Working with initscripts-9.49.38-1.el7.
Comment 12 errata-xmlrpc 2017-08-01 03:29:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2286

Note You need to log in before you can comment on or make changes to this bug.