Bug 1394495 - Removing Mon with CLI - Error message getting displayed though cluster is not disrupted
Summary: Removing Mon with CLI - Error message getting displayed though cluster is not...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 2.1
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 2.2
Assignee: Kefu Chai
QA Contact: shylesh
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks: 1383917 1412948
TreeView+ depends on / blocked
 
Reported: 2016-11-12 17:03 UTC by Vasishta
Modified: 2017-07-30 15:15 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-10.2.5-7.el7cp Ubuntu: ceph_10.2.5-3redhat1xenial
Doc Type: Bug Fix
Doc Text:
.Removing a Ceph Monitor no longer returns an error When removing a Ceph Monitor by using the `ceph mon remove` command, the Monitor was successfully removed, but an error message similar to the following was returned: ---- Error EINVAL: removing mon.magna072 at 10.8.128.72:6789/0, there will be 3 monitors ---- The underlying source code has been fixed, and the error is no longer returned when removing Ceph Monitors.
Clone Of:
Environment:
Last Closed: 2017-03-14 15:46:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC
Ceph Project Bug Tracker 17725 None None None 2016-11-14 06:46:34 UTC

Description Vasishta 2016-11-12 17:03:04 UTC
Description of problem:
Error message is getting displayed when a Mon is removed though cluster was not disrupted.


Version-Release number of selected component (if applicable):
ceph version 10.2.3-13.el7cp

How reproducible:
always

Steps to Reproduce:

1. Stop Monitor service of a Monitor node

sudo systemctl stop ceph-mon@<monitor_hostname>


2. Remove the monitor from the cluster:

sudo ceph mon remove <mon_id>



Actual results:

$sudo  ceph mon remove magna072 --cluster master
Error EINVAL: removing mon.magna072 at 10.8.128.72:6789/0, there will be 3 monitors


Additional info:

Election process after removing mon seems to be running normal

2016-11-12 16:22:24.326599 7fd960177700  0 mon.magna030@0(leader) e4 handle_command mon_command({"prefix": "mon remove", "name": "magna072"} v 0) v1
2016-11-12 16:22:24.326627 7fd960177700  0 log_channel(audit) log [INF] : from='client.? 10.8.128.30:0/673982027' entity='client.admin' cmd=[{"prefix": "mon remove", "name": "magna072"}]: dispatch
2016-11-12 16:22:24.395750 7fd95de70700  0 -- 10.8.128.30:6789/0 >> 10.8.128.111:6789/0 pipe(0x7fd974160800 sd=13 :33906 s=2 pgs=7 cs=1 l=0 c=0x7fd973d3aa00).fault, initiating reconnect
2016-11-12 16:22:24.396399 7fd95df71700  0 -- 10.8.128.30:6789/0 >> 10.8.128.111:6789/0 pipe(0x7fd9746b9400 sd=13 :6789 s=0 pgs=0 cs=0 l=0 c=0x7fd9742cb080).accept connect_seq 0 vs existing 2 state connecting
2016-11-12 16:22:24.396414 7fd95df71700  0 -- 10.8.128.30:6789/0 >> 10.8.128.111:6789/0 pipe(0x7fd9746b9400 sd=13 :6789 s=0 pgs=0 cs=0 l=0 c=0x7fd9742cb080).accept peer reset, then tried to connect to us, replacing
2016-11-12 16:22:24.412214 7fd960177700  0 log_channel(cluster) log [INF] : mon.magna030 calling new monitor election
2016-11-12 16:22:24.412264 7fd960177700  1 mon.magna030@0(electing).elector(34) init, last seen epoch 34
2016-11-12 16:22:24.435800 7fd960177700  0 log_channel(cluster) log [INF] : mon.magna030@0 won leader election with quorum 0,1,2

Comment 2 Kefu Chai 2016-11-14 06:46:35 UTC
it's a known issue, and is pending on backport in upstream. see http://tracker.ceph.com/issues/17725

Comment 5 Samuel Just 2016-11-30 21:53:02 UTC
https://github.com/ceph/ceph/pull/11999

Comment 15 errata-xmlrpc 2017-03-14 15:46:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.