Bug 1394559 - Missing rootwrap configuration files in glance
Summary: Missing rootwrap configuration files in glance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glance-store
Version: 10.0 (Newton)
Hardware: All
OS: Unspecified
medium
high
Target Milestone: Upstream M3
: 12.0 (Pike)
Assignee: Cyril Roelandt
QA Contact: Mike Abrams
URL:
Whiteboard:
Depends On:
Blocks: 1293435 1646932
TreeView+ depends on / blocked
 
Reported: 2016-11-13 14:45 UTC by Avi Avraham
Modified: 2018-11-06 10:40 UTC (History)
14 users (show)

Fixed In Version: python-glance-store-0.20.1-0.20170614011609.309162a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 20:49:23 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 458201 0 None None None 2017-05-04 16:21:36 UTC
OpenStack gerrit 485244 0 None None None 2017-07-26 14:14:51 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Avi Avraham 2016-11-13 14:45:57 UTC
Description of problem:
Setup of Cinder backend to Glance according to RFE  
https://bugzilla.redhat.com/show_bug.cgi?id=1293435 fails because of missing configuration to rootwrap 

Version-Release number of selected component (if applicable):
python-glance-13.0.0-1.el7ost.noarch
openstack-glance-13.0.0-1.el7ost.noarch
python-glance-store-0.18.1-0.20161003180701.4e144bb.el7ost.noarch
puppet-glance-9.4.0-1.el7ost.noarch
python-glanceclient-2.5.0-1.el7ost.noarch


How reproducible:


Steps to Reproduce:
1. Login to controller server of the overcloud environment 
2. cd /etc/glance
3. ls -l rootwrap.*

Actual results:
ls: cannot access rootwarp.*: No such file or directory

Expected results:
-rwxr-xr-x. 1 root glance 973 Nov 10 14:34 rootwrap.conf

rootwrap.d:
total 4
-rwxr-xr-x. 1 root glance 1265 Nov 10 14:24 glance_cinder_store.filters


Additional info:

Comment 1 Eric Harney 2016-11-17 17:22:02 UTC
https://review.rdoproject.org/r/#/c/3794/

Comment 2 Elise Gafford 2016-11-30 14:16:32 UTC
Moving to ON_DEV as patch is posted.

Comment 3 Eric Harney 2017-03-17 15:21:10 UTC
(In reply to Eric Harney from comment #1)
> https://review.rdoproject.org/r/#/c/3794/

Mostly reverted at https://review.rdoproject.org/r/#/c/5658/ .

Comment 4 Cyril Roelandt 2017-03-21 16:10:56 UTC
As stated by Eric, we'll try to fix this for OSP12.

Comment 5 Paul Grist 2017-03-23 13:54:56 UTC
Moving to OSP12

Comment 12 Tzach Shefi 2017-08-08 08:55:09 UTC
Before I verify on:
python-glance-store-0.21.0-0.20170720000947.599b9b8.el7ost.noarch

()[glance@controller-0 /etc/glance]$ ls -l rootwrap.* 
total 0
lrwxrwxrwx. 1 root root 45 Aug  2 20:33 os-brick.filters -> /usr/share/os-brick/rootwrap/os-brick.filters


Cyril, is this sufficient to verify? 

As I don't see exact files which we at least thought would show up according to Avi's initial bug report.  

Expected results:
-rwxr-xr-x. 1 root glance 973 Nov 10 14:34 rootwrap.conf -> in our case we only have rootwrap.d (folder not a file) 

rootwrap.d:
total 4
-rwxr-xr-x. 1 root glance 1265 Nov 10 14:24 glance_cinder_store.filters

Again in our case rather than a file by this ^ name, we have a symlink called: os-brick.filters


I am almost sure its fine, just want to verify with you before officially verifying.

Comment 13 Cyril Roelandt 2017-08-08 13:50:10 UTC
@Tzach: No, we need the "rootwrap.conf" file added by this patch: https://review.openstack.org/#/c/485244

Comment 14 Tzach Shefi 2017-08-09 07:49:03 UTC
Cyril, 
As mentioned above we must also have that missing rootwrap.conf file,
noticed upstream code got merged, great. 
But now I'm even more confused, what am I missing here? 

If code landed downstream, assume it did as we have a fixed-in/ON_QA state, right? 

I should fail verification, as code didn't produce missing file
reset bug status to assigned?  

Or should I keep it ON_QA till we get a new downstream/fixed-in version?
Which would hopefully create the missing rootwrap.conf file?

Comment 15 Cyril Roelandt 2017-08-09 12:07:32 UTC
I'm not sure whether the rootwrap.conf file (merged upstream) is already available downstream, because I have no idea how the whole upstream -> RDO -> OSP12 thing works.

If the rootwrap.conf file is not there, this won't work.

Comment 19 errata-xmlrpc 2017-12-13 20:49:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.