Bug 1293435 - [RFE][glance] Cinder backend for Glance: Support download from and upload to Cinder volumes [NEEDINFO]
Summary: [RFE][glance] Cinder backend for Glance: Support download from and upload to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-glance-store
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Cyril Roelandt
QA Contact: Mike Abrams
Don Domingo
URL: https://specs.openstack.org/openstack...
Whiteboard: upstream_milestone_none upstream_defi...
: 1154203 (view as bug list)
Depends On: 1394557 1394559 1395240 1396067 1475378
Blocks: 1389435 1442136 1342845 1394745 1394885 1417347 1447779 1459148 1474484 1646932
TreeView+ depends on / blocked
 
Reported: 2015-12-21 18:42 UTC by Sean Cohen
Modified: 2019-05-03 16:23 UTC (History)
33 users (show)

Fixed In Version: openstack-glance-15.0.0-3.el7ost openstack-tripleo-heat-templates-7.0.3-0.20171024200824.el7ost puppet-tripleo-7.4.3-0.20171025110207.el7ost python-glance-store-0.18.1-0.20160901174534.26f9c9f.el7ost
Doc Type: Enhancement
Doc Text:
Uploading to and downloading from Cinder volumes with Glance is now supported with the Cinder backend driver. Note: This update does not include support for Ceph RBD. Use the Ceph backend driver to perform RBD operations on Ceph volumes.
Clone Of:
: 1646932 (view as bug list)
Environment:
Last Closed: 2017-12-13 20:37:32 UTC
Target Upstream Version:
pmorey: needinfo? (cyril)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1643516 None None None 2017-01-06 14:24:12 UTC
OpenStack gerrit 166414 'None' MERGED Implement get, add and delete for cinder store 2020-09-07 06:04:14 UTC
OpenStack gerrit 183363 'None' MERGED Support download from and upload to Cinder volumes 2020-09-07 06:04:14 UTC
OpenStack gerrit 458201 'None' MERGED Initialize privsep root_helper command 2020-09-07 06:04:14 UTC
OpenStack gerrit 510953 'None' MERGED Allow 'cinder' as a backend for Glance 2020-09-07 06:04:13 UTC
OpenStack gerrit 511275 'None' MERGED Enable Cinder as a backend for Glance 2020-09-07 06:04:12 UTC
OpenStack gerrit 513202 'None' MERGED Allow 'cinder' as a backend for Glance 2020-09-07 06:04:12 UTC
OpenStack gerrit 516100 'None' MERGED Enable Cinder as a backend for Glance 2020-09-07 06:04:13 UTC
RDO 7998 None None None 2017-07-31 14:48:44 UTC
RDO 10034 None None None 2017-10-09 15:21:15 UTC
RDO 10087 None None None 2017-10-12 14:43:03 UTC
RDO 10364 None None None 2017-11-02 17:00:29 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Sean Cohen 2015-12-21 18:42:20 UTC
Currently Glance's Cinder backend driver doesn't support uploading/downloading.

Blueprint of current implementation:
  https://blueprints.launchpad.net/glance/+spec/glance-cinder-driver

As missing parts in Cinder listed above (os-brick library, readonly-volumes, multi-attach) are now supported, now we can implement uploading and downloading for it.

Comment 2 Sean Cohen 2016-03-10 15:13:32 UTC
*** Bug 1154203 has been marked as a duplicate of this bug. ***

Comment 3 Mike McCune 2016-03-28 22:35:49 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 4 Flavio Percoco 2016-08-30 08:13:03 UTC
Added Gerrit's patch for the implementation

Comment 13 Paul Grist 2016-11-17 20:36:16 UTC
Here's what was discovered during testing of this RFE. It does not appear that this feature has adequate upstream CI testing and the feature is not working even with our attempt to run it with LVM.  It was also discovered that it will not work with Ceph behind cinder, but we will document that when the time comes.

In addition to the bugs found that this now depends on, Glance is not sending the correct initiator field to cinder during volume connection, and so the attach fails. We will work the dependent bugs first, then see if we can get back to this one, but target is now OSP12 based on priorities.

Comment 15 arkady kanevsky 2017-01-06 19:53:29 UTC
Paul,
Can we escalate development of the fix and then we can figure out if it works, and if we can deliver it earlier in appropriate JS one.

Comment 16 Rajini Karthik 2017-01-30 17:58:22 UTC
Is this feature available now? See https://bugs.launchpad.net/glance-store/+bug/1382681

Comment 17 Paul Grist 2017-02-15 15:39:11 UTC
Arkady/Ranjini - We are going to circle back on the list of bugs found testing this, the upstream fix was a key issue, but it wasn't the only problem found with the OSP deployment/test. We are tracking this against OSP12 and will follow up soon and will keep the needinfo on me for that.

Comment 18 Paul Grist 2017-03-20 18:17:33 UTC
Initial plan will be to test with LVM for verification of what has landed upstream.

Comment 22 Cyril Roelandt 2017-06-14 14:18:46 UTC
@Eric: Weren't there some other patches you wanted to land to fix this issue?

Comment 40 Jon Schlueter 2017-11-02 16:59:06 UTC
additional patches/changes are required to make this work and be testable

https://review.openstack.org/513202 - puppet-tripleo - stable/pike - merged 2017-11-02
https://review.openstack.org/#/c/516100/ - THT - stable/pike - proposed 2017-11-02

along with openstack-glance-15.0.0-2.el7 cbs build or better (incorporate fix for glance_store rootwrap filter path.)

openstack-glance-15.0.0-3.el7ost

Comment 41 Jon Schlueter 2017-11-02 17:10:11 UTC
Alan,

Can you double check comment #40 and external trackers please.  I tried to capture the details we were discussing with quick fact check on state of the patches and builds

Comment 42 Alan Bishop 2017-11-02 17:29:38 UTC
Added RH Gerrit reviews for rhos-12. Status in comment #40 is correct.

Comment 48 Alan Bishop 2017-11-07 17:51:20 UTC
Previous comment was meant to clear needsinfo flag.

Comment 49 Christian Schwede (cschwede) 2017-11-08 05:25:18 UTC
The last outstanding patch (backport to Pike) just landed: https://review.openstack.org/#/c/516100/

Comment 62 errata-xmlrpc 2017-12-13 20:37:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.