Bug 139469 - /etc/X11/xinit/xinitrc-common: line 45: 4690 Aborted
/etc/X11/xinit/xinitrc-common: line 45: 4690 Aborted
Status: CLOSED DUPLICATE of bug 138458
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-15 23:37 EST by Etanisla Lopez-Ortiz
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Etanisla Lopez-Ortiz 2004-11-15 23:37:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
root and user were able to start xorg normally before installing
Nvidia drivers.

Note boot runlevel is set to 3.

After install, root is able to start xorg normally. The user is not
able to start normally. When the user types "startx", the graphical
splash screen appears, along with the first icon for "Metacity window
manager". The graphical procedure doesn't progress any further.
Checking back at the console, I see:

*** glibc detected *** corrupted double-linked list: 0x08a9ebd0***
/etc/X11/xinit/xinitrc-common: line 45:  4690 Aborted       xmodmap
"$sysmodmap"

The fine folks on the Fedora List suggested that I submit a Bugzilla
report and point out that the bug seems to have been triggered by the
Nvidia drivers.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12 glibc-2.3.3-74 NVIDIA-Linux-x86-1.0-6629-pkg1

How reproducible:
Always

Steps to Reproduce:
1. Take fresh install of FC3. Install Nvidia 1.0-6629 drivers.
2. Boot to console. Login as a user.
3. "startx"

    

Actual Results:  Unable to start xorg as user, xorg hung at graphical
splash screen. Ctrl-Alt-BkSpc to force xorg to close.

Expected Results:  Xorg should have started.

Additional info:

Key error message:
*** glibc detected *** corrupted double-linked list: 0x08a9ebd0***
/etc/X11/xinit/xinitrc-common: line 45:  4690 Aborted       xmodmap
"$sysmodmap"

Key display driver (for GeForce 4 card):
NVIDIA-Linux-x86-1.0-6629-pkg1 (obtained from nvidia.com)

Bug may be triggered by Nvidia drivers.
Comment 1 Mike A. Harris 2004-11-16 20:59:30 EST

*** This bug has been marked as a duplicate of 138458 ***
Comment 2 Jackey 2005-01-15 22:47:01 EST
My system is FC3, after I updated my system, the firefox can't run, 
gedit can show a interface but can't work. I ran firefox in bash, got 
this messages: 
*** glibc detected *** corrupted double-linked list: 0x0814d458 *** 
 
What's it mean? How do I to solve it? 
Comment 3 Mike A. Harris 2005-01-17 10:54:41 EST
Jackey:  Your problem is different from this bug report.  Please ask
for help on the fedora-list@redhat.com and someone will advise you
of what to do.   Hope this helps.
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.