Bug 1394830 - The latest version of scapy breaks the DHCP validator
Summary: The latest version of scapy breaks the DHCP validator
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 10.0 (Newton)
Assignee: Tomas Sedovic
QA Contact: Ola Pavlenko
RHOS Documentation Team
URL:
Whiteboard:
: 1394829 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-14 14:24 UTC by Udi
Modified: 2016-12-14 16:32 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-validations-5.1.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:32:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 397727 None None None 2016-11-16 13:58:58 UTC
Launchpad 1634023 None None None 2016-11-14 15:59:05 UTC

Description Udi 2016-11-14 14:24:22 UTC
Description of problem:
Running the validator "DHCP on the Provisioning Network" results with:

Task 'Look for DHCP responses' failed:
Host: localhost
Message: Script `files/rogue_dhcp.py enp5s0f1` exited with code: 1

stderr:
    Traceback (most recent call last):
      File "/home/validations/.ansible/tmp/ansible-tmp-1479130289.59-266387329408030/rogue_dhcp.py", line 23, in <module>
        from scapy.all import BOOTP
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/all.py", line 28, in <module>
        from scapy.route6 import *
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/route6.py", line 273, in <module>
        conf.route6 = Route6()
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/route6.py", line 31, in __init__
        self.resync()
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/route6.py", line 44, in resync
        self.routes = read_routes6()
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/arch/linux.py", line 283, in read_routes6
        cset = scapy.utils6.construct_source_candidate_set(d, dp, devaddrs, LOOPBACK_NAME)
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/utils6.py", line 50, in construct_source_candidate_set
        if in6_isgladdr(addr) or in6_isuladdr(addr):
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/utils6.py", line 708, in in6_isgladdr
        return in6_isincluded(str, '2000::', 3)
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/utils6.py", line 651, in in6_isincluded
        temp = inet_pton(socket.AF_INET6, addr)
      File "/tmp/validations-venv/lib/python2.7/site-packages/scapy/pton_ntop.py", line 40, in inet_pton
        raise Exception("Illegal syntax for IP address")
    Exception: Illegal syntax for IP address

Failure! The validation failed for the following hosts:
* localhost


Version-Release number of selected component (if applicable):
openstack-tripleo-validations-5.1.0-3.el7ost.noarch


How reproducible:
100%

Comment 1 Jason E. Rist 2016-11-14 16:43:25 UTC
*** Bug 1394829 has been marked as a duplicate of this bug. ***

Comment 2 Tomas Sedovic 2016-11-14 17:41:33 UTC
Fix submitted upstream: https://review.openstack.org/#/c/397314/

Comment 3 Tomas Sedovic 2016-11-15 12:52:47 UTC
The upstream patch has merged, here's the backport to stable/newton: https://review.openstack.org/397727

Comment 4 Jason E. Rist 2016-11-15 20:23:32 UTC
Removing the blocker flag, as there is a patch posted upstream. Not a blocker due to it being a single validation case.

Comment 5 Tomas Sedovic 2016-11-16 12:08:38 UTC
The backport has merged, too.

Comment 7 Ana Krivokapic 2016-11-25 14:04:23 UTC
Works in openstack-tripleo-validations-5.1.0-5.el7ost.noarch

Comment 9 errata-xmlrpc 2016-12-14 16:32:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.