Bug 1394863 - Cloud Instances List View Table missing cells/improper rendering
Summary: Cloud Instances List View Table missing cells/improper rendering
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Libor Pichler
QA Contact: Mike Shriver
URL:
Whiteboard: cloud:openstack:view
: 1392213 1409952 (view as bug list)
Depends On:
Blocks: 1411433 1416470
TreeView+ depends on / blocked
 
Reported: 2016-11-14 15:35 UTC by Mike Shriver
Modified: 2017-06-12 16:46 UTC (History)
10 users (show)

Fixed In Version: 5.8.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1411433 1416470 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:46:09 UTC
Category: Bug
Cloudforms Team: Openstack
Target Upstream Version:
mshriver: automate_bug-


Attachments (Terms of Use)
Screenshot of All Instances on 5.7.0.14-rc4 (118.59 KB, image/jpeg)
2016-12-08 18:43 UTC, Mike Shriver
no flags Details

Description Mike Shriver 2016-11-14 15:35:27 UTC
Created attachment 1220470 [details]
Screenshot of Instance By Provider page

Description of problem:
Instances list view does not render OpenStack instances properly in the table. The last two columns, Last Analysis Time and Region, are munged together and the table is missing the final column for OpenStack instances.

Attached screenshot includes instances from EC2 and OpenStack to highlight the difference.

When the view is filtered by provider using the accordion tree, the final column in the view, 'Last Analysis Time', does not have table cells rendered in the column, only the header.

There are no errors logged in the browser console or in production.log: 
[----] I, [2016-11-14T10:28:38.930665 #2993:17544b8]  INFO -- : Started POST "/vm_cloud/reload" for 127.0.0.1 at 2016-11-14 10:28:38 -0500
[----] I, [2016-11-14T10:28:38.933538 #2993:17544b8]  INFO -- : Processing by VmCloudController#reload as JS
[----] I, [2016-11-14T10:28:40.045169 #2993:17544b8]  INFO -- :   Rendered layouts/_info_msg.html.haml (0.1ms)
[----] I, [2016-11-14T10:28:40.045490 #2993:17544b8]  INFO -- :   Rendered layouts/_flash_msg.html.haml (0.0ms)
[----] I, [2016-11-14T10:28:40.060613 #2993:17544b8]  INFO -- :   Rendered layouts/_list_grid.html.haml (14.3ms)
[----] I, [2016-11-14T10:28:40.060751 #2993:17544b8]  INFO -- :   Rendered layouts/gtl/_list.html.haml (15.1ms)
[----] I, [2016-11-14T10:28:40.060817 #2993:17544b8]  INFO -- :   Rendered layouts/_x_gtl.html.haml (15.9ms)
[----] I, [2016-11-14T10:28:40.061994 #2993:17544b8]  INFO -- :   Rendered layouts/_x_adv_searchbox.html.haml (0.7ms)
[----] I, [2016-11-14T10:28:40.063442 #2993:17544b8]  INFO -- :   Rendered layouts/_x_form_buttons.html.haml (0.0ms)
[----] I, [2016-11-14T10:28:40.063518 #2993:17544b8]  INFO -- :   Rendered layouts/_x_pagingcontrols.html.haml (1.2ms)
[----] I, [2016-11-14T10:28:40.080071 #2993:17544b8]  INFO -- : Completed 200 OK in 1146ms (Views: 0.2ms | ActiveRecord: 0.0ms)




Version-Release number of selected component (if applicable):
Testing on: 5.6.3.0.20161108115816_66df924

How reproducible:
Every time the page is loaded/refreshed, Chrome v54


Steps to Reproduce:
1. Add cloud provider for RHOS
2. View Instances/Instances By Provider

Actual results:
Improperly rendered table with missing cells and data in the wrong columns


Expected results:
Properly rendered table with accurate data.

Comment 3 Tzu-Mainn Chen 2016-12-08 17:02:20 UTC
Hi!  I just tried this out on the latest code, and the issue seems to be gone.  Mike, can you test this against 5.7?

Comment 4 Mike Shriver 2016-12-08 18:42:41 UTC
I am still seeing incorrect rendering:
Appliance: 5.7.0.14-rc4
Browser: Google Chrome Version 54.0.2840.100 (64-bit)

Observed on 'Instances By Provider' and 'All Instances' pages. New screenshot attached.

Comment 5 Mike Shriver 2016-12-08 18:43:25 UTC
Created attachment 1229586 [details]
Screenshot of All Instances on 5.7.0.14-rc4

Comment 7 Harpreet Kataria 2016-12-09 19:39:44 UTC
Mainn,

Following commit has fixed issue on master https://github.com/ManageIQ/manageiq/pull/12979. That is marked to be backported to EUWE but has not been backported yet. Let me know if you have any further questions.
https://bugzilla.redhat.com/show_bug.cgi?id=1392213 seems to be dup of this one as well.

Thanks,
~Harpreet

Comment 8 Tzu-Mainn Chen 2016-12-09 19:50:03 UTC
*** Bug 1392213 has been marked as a duplicate of this bug. ***

Comment 9 Tzu-Mainn Chen 2016-12-09 19:52:08 UTC
Reassigning to Libor, as the creator of the fix.  Thanks!

Comment 12 Satoe Imaishi 2017-01-25 15:15:55 UTC
*** Bug 1409952 has been marked as a duplicate of this bug. ***

Comment 14 Mike Shriver 2017-03-16 20:03:03 UTC
Verified in CFME 5.8.0.4, the cloud instances list view table is rendered properly, with all columns and data in the correct respective spot.


Note You need to log in before you can comment on or make changes to this bug.