Bug 1409952 - Inconsistency in cloud instances list view
Summary: Inconsistency in cloud instances list view
Keywords:
Status: CLOSED DUPLICATE of bug 1394863
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Jozef Zigmund
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 01:46 UTC by Jerome Marc
Modified: 2017-02-07 04:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-25 15:15:55 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Inconsistency in cloud instances list view (184.77 KB, image/png)
2017-01-04 01:46 UTC, Jerome Marc
no flags Details

Description Jerome Marc 2017-01-04 01:46:01 UTC
Created attachment 1237042 [details]
Inconsistency in cloud instances list view

Description of problem:
Instances from different cloud providers (AWS vs Azure, Google, OpenStack) don't display the same data for each row, causing inconsistency in the instances list view (see attached).

Version-Release number of selected component (if applicable):
5.7.0.17.20161219135818_725f92f 

How reproducible:
Always

Steps to Reproduce:
0. Have multiple clouds configured and smart-state analysis performed for some instances (e.g. Azure)
1. go to Compute > Cloud > Instances
2. select List View

Actual results:
The list data don't match the header for the instances apart from AWS instances.

Expected results:
All instances (Azure, Google and OpenStack should have their data match the list header.

Additional info:

Comment 2 Jozef Zigmund 2017-01-16 15:21:04 UTC
Hi Jerome,

I cannot reproduce it on current master, can you verify If you are able to reproduce the bug still ?

Comment 3 Jerome Marc 2017-01-16 17:53:52 UTC
I can still reproduce this issue on CF4.2. You need multiple clouds (e.g. AWS and Azure) and look at the list view under Compute > Cloud > Instances. In my case I also have Smart-State Analysis performed on Azure instances.

Let me know if you need access to an environment to reproduce.

Comment 4 Jozef Zigmund 2017-01-24 16:00:32 UTC
Hi Jerome, I've got good news. I was able to reproduce the bug, but on Darga branch (CFME 5.7.0.x version) and found that a bugfix was not backported there. So I've requested the backport in https://github.com/ManageIQ/manageiq/pull/12979

Comment 6 Satoe Imaishi 2017-01-25 15:15:55 UTC

*** This bug has been marked as a duplicate of bug 1394863 ***


Note You need to log in before you can comment on or make changes to this bug.