Bug 139521 - Non UTF-8 charcters in TestSuite.java
Non UTF-8 charcters in TestSuite.java
Status: CLOSED DUPLICATE of bug 141810
Product: Red Hat Developer Suite
Classification: Retired
Component: JDT (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 10:51 EST by Aaron Luchko
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Luchko 2004-11-16 10:51:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
There's a TestSuite.java file that contains some characters that are
ISO-8859-1 in one of the comments causing a build fail.  It should be
noted that this may be a JVM issue (with both IBM and BEA) as
discussed in https://bugs.eclipse.org/bugs/show_bug.cgi?id=40498


Version-Release number of selected component (if applicable):
eclipse-jdt-3.0.1-2

How reproducible:
Always

Steps to Reproduce:
Unzip
/usr/share/eclipse/plugins/org.eclipse.jdt.source_3.0.0/src/org.junit_3.8.1/junitsrc.zip
and 
junit/framework/TestSuite.java
contains some non-ascii characters on line 54 causing the build to fail.  

Additional info:

A workaround is to change the encoding of the file (or the entire
project in the workspace) to ISO-8859-1 but the characters should be
removed.
Comment 1 Aaron Luchko 2004-12-03 16:20:00 EST
duplicate of 141810

*** This bug has been marked as a duplicate of 141810 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.