Bug 141810 - Cannot open non UTF-8 characters
Summary: Cannot open non UTF-8 characters
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Aaron Luchko
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
: 139521 141794 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-03 21:18 UTC by Aaron Luchko
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 18:39:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2005:214 normal SHIPPED_LIVE eclipse bug fix and enhancement update 2005-04-01 05:00:00 UTC

Description Aaron Luchko 2004-12-03 21:18:07 UTC
Description of problem: 

The default encoding for everything in eclipse is UTF-8.  When IBM or
BEA jvm tries to open a file marked UTF-8 with non-UTF-8 characters
(image files, libraries, foreign characters) it fails.  This is
expected behavior from the jvm.  However as all files have this
setting the jvm runs into many problems building and constant problems
searching.  Eclipse.org does not share this problem the only reason I
can think for this is they either build it with sun jvm or change LANG
during startup.

How reproducible:
Always

Steps to Reproduce:
1. Try to build something with foreign characters in a source file or
perform a search on image files

Comment 1 Aaron Luchko 2004-12-03 21:20:13 UTC
*** Bug 139521 has been marked as a duplicate of this bug. ***

Comment 2 Aaron Luchko 2004-12-03 21:21:11 UTC
*** Bug 141794 has been marked as a duplicate of this bug. ***

Comment 3 Aaron Luchko 2004-12-03 22:53:34 UTC
Turns out this happens only with IBM jvm (BEA is not affected) and
eclipse.org IS affected, as to the confusion see bug 141831.

The problem can be worked around by changing LANG to "ISO-8859-1"
before starting up eclipse, unfortunatly this also leads to the output
on the command line of,

(process:12516): Gdk-WARNING **: locale not supported by C library

(process:12516): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.

still this is far less problematic than the problems encountered.

Comment 4 Aaron Luchko 2004-12-03 23:18:11 UTC
Tracking upstream bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=80188

Comment 5 Aaron Luchko 2005-01-17 18:39:58 UTC
The major manifestation of this, searching problems, have been fixed
by a recent backport, the inability to open certain files while an
annoyance is a problem with the files themselves, not with the jvm or
eclipse itself.  Closing the bug although we should still find some
way to get support for non text files which is a current and
legitimate bug.

Comment 6 David Lawrence 2005-04-01 23:30:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-214.html



Note You need to log in before you can comment on or make changes to this bug.