Bug 139588 - (i810) CRT/LCD switching broken
(i810) CRT/LCD switching broken
Status: CLOSED DUPLICATE of bug 141447
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-16 15:30 EST by Ulrich Kiermayr
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Kiermayr 2004-11-16 15:30:58 EST
Description of problem:
The CRT/LCD switch for my Laptop with the i810 driver is broken. (Dell
Latitude C400). 
The i810_drv.o from the latest fc2 (dated Sep 28) does not show the
Problem (all the other components unchanged.)

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12


How reproducible:
Use Fn+F8 (in my case)

Actual results:
Nothing - just a screen flicker.

Expected results:
Changing output: LCD -> CRT+LCD -> CRT -> LCD

Additional info:
Quite annoying, but using the old driver does not show any problems so
far.
Comment 1 Mike Deskevich 2005-01-03 17:53:26 EST
I'll add one more data point to this.  I ran into the same issue on my
IBM Thinkpad R-series.  I upgraded from FC1 to FC3 and cannot switch
from LCD to CRT using Fn+F7.  I also use the same i810 driver as the
original bug submitter.
Comment 2 David Kaplan 2005-01-24 14:45:20 EST
For Dell inspiron 1150, I have found two ways to use an external monitor.  One
is to start the computer and switch to the external monitor when in grub.  This
will make the external monitor availabel, but the LCD will not be for the duration.

The other is to use a program call i810switch to turn on and off the external
monitor.  This will leave LCD on.  For other dell's, the program i855crt works
for many.  For sony and toshiba, ltpconf appears to work, though I have not
tried it.
Comment 3 Colin Charles 2005-02-04 06:12:04 EST
Still a problem with xorg-x11-6.8.1-12.FC3.21.i386.rpm, on my Thinkpad R51. Can
confirm that from comment #2, during the reboot, things will work. But its
highly inconvenient

This used to work with XFree86 previously
Comment 4 Mike A. Harris 2005-02-07 21:21:28 EST
This is a duplicate of another bug currently in bugzilla that I don't have
the bug ID handy for.  There is a freedesktop.org bug that is tracking this
issue as well, along with suggested workarounds.  Alan Hourihane has aparently
fixed this problem, or provided a workaround in CVS head as well.

I'm going to leave this open for now until I run into the duplicate bug, but
if someone finds it before I do, please paste the bug # here.

Thanks.
Comment 5 Fernando Bellas 2005-02-09 09:38:46 EST
I have a DELL inspiron 510m with a 82852/855GM video card, and when I
press Fn+CRT/LCD, the X server dies. However, I can successfully use
i855crt (http://sourceforge.net/projects/i855crt) to use the projector.
Comment 6 David Kaplan 2005-02-09 15:32:33 EST
This bug is a duplicate of bug #141447.  On that bug, there is a link
to a freedesktop.org bug report that fixes all the problems.
Comment 7 Mike A. Harris 2005-02-11 11:18:11 EST

*** This bug has been marked as a duplicate of 141447 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:07:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.