Bug 141447 - Switch from laptop LCD to monitor fails
Switch from laptop LCD to monitor fails
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
: 139588 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 00:32 EST by David Kaplan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 20:38:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2004-12-01 00:32:55 EST
Description of problem:
Fn-F8 switches from the laptop LCD to an external monitor on my
computer (Dell Inspiron 1150).  In fc2, this worked reasonably well -
it would switch, but there would be strange lines at the top of the
screen, but ctrl-alt-backspace fixed things nicely.  In fc3, this
fails completely.  It tries to start up the monitor (i.e. the led on
the monitor goes green), but then it fails after a bit.  

Switching does work, however, from a virtual terminal.  And I can
start the machine and immediately switch to the external monitor and
it will boot fine in the external monitor, but then I cannot switch
back to the LCD.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.1

How reproducible:
All the time

Steps to Reproduce:
1.Boot laptop in LCD mode
2.Hit the buttons to switch to external monitor while in X
3.
  
Actual results:
Attempts to start X fail on external monitor.

Expected results:
Should figure it out and move to external monitor.

Additional info:
This bug appears to be related to Bug #140201.
Comment 1 Christopher Beland 2005-01-23 18:36:57 EST
FYI, similar symptoms are reported in Bug #139588.
Comment 2 David Kaplan 2005-01-24 14:42:58 EST
For Dell inspiron 1150, I have found two ways to use an external monitor.  One
is to start the computer and switch to the external monitor when in grub.  This
will make the external monitor availabel, but the LCD will not be for the duration.

The other is to use a program call i810switch to turn on and off the external
monitor.  This will leave LCD on.  For other dell's, the program i855crt works
for many.  For sony and toshiba, ltpconf appears to work, though I have not
tried it.
Comment 3 Mike A. Harris 2005-02-01 00:53:49 EST
When using special keystrokes such as Fn-F? on different laptop
hardware, the laptop's own BIOS is in control of things, and may
interfere with X.  X has no knowledge of what the BIOS is doing
behind it's back, and so one might find that these special keystrokes
never work at all, or they work in one X release and not in another.
Troubleshooting these problems are generally laptop make/model
specific, and BIOS revision specific.

People experiencing such problems are best reporting them directly
to X.Org at http://bugs.freedesktop.org to ensure a wider number
of developers see the bug report, and hopefully one of them has
the same hardware and can investigate the matter.

Once you have filed your bug report in the X.Org bugzilla, if you
paste the X.Org bug URL here, Red Hat will track the issue in the
upstream tracker, and if a fix becomes available, we will review
it for consideration in future Fedora Core updates.
Comment 4 Mike A. Harris 2005-02-01 00:54:53 EST
Setting status to "NEEDINFO", awaiting upstream bug report URL.
Comment 5 David Kaplan 2005-02-01 12:33:36 EST
https://bugs.freedesktop.org/show_bug.cgi?id=2444
Comment 6 David Kaplan 2005-02-07 19:35:46 EST
For my hardware, the switching problem has essentially been fixed by
some driver modifications.  Follow the above url to get the play by play.
Comment 7 Mike A. Harris 2005-02-07 20:38:13 EST
Thanks for the update David.  I've read through the full text of
the freedesktop.org bug report now.  Sounds like this will be fixed
in CVS head, and make it into X.Org X11 6.9.0 or 7.0 or whichever
is next.  You may also want to consider recommending X.Org to
backport the fix to 6.8.x also, and suggest it as a candidate for
XORG-6_8-branch for future stable updates.

Setting status to "UPSTREAM" for tracking in the X.Org bugzilla.

Thanks again.
Comment 8 Mike A. Harris 2005-02-11 11:18:30 EST
*** Bug 139588 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.