Bug 139647 - print queue gui link is missing from system/menu
print queue gui link is missing from system/menu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
: 137960 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 01:22 EST by Chris Petersen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 15:37:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Petersen 2004-11-17 01:22:47 EST
I've spent a good hour or so scanning packages in fc3 to find where
the print queue manager went (I believe there used to be a link under
the Preferences menu in gnome, although I don't think it was a
gnome-specific option).  All I can find is the print config, where you
set up the printers, but nowhere I can go in and edit/delete print jobs.
Comment 1 Colin Walters 2004-11-18 12:48:54 EST
The package you're referring to I believe is "printman".  Why do you want it? 
Its functionality has been superseded by several packages:
eggcups (desktop-printing) does job monitoring for a user's print jobs
gnome-default-printer (desktop-printing) allows you to set your default printer
And now every GNOME app uses the new print dialog, which shows you the status of
every printer.
Comment 2 Chris Petersen 2004-11-18 13:13:09 EST
I don't care what program I get the functionality from, I just want it
back (as it should be, if we are ever to provide a good user
experience for non-techie types).  Gnome-specific does me no good. 
Though I use gnome (for now), I use a lot of non-gnome apps.  eggcups
does nothing when I run it (that I can see).  And overall, none of
these items are in the menu.  I managed to get into the cups manager
via the web at localhost:631, but that's unacceptable for an average user.

And setting the default printer still doesn't give me access to the
queue to see what's printing, and to reorganize/pause/cancel jobs.
Comment 3 Colin Walters 2004-11-18 14:30:40 EST
The print notification icon (eggcups) should appear in the
notification area when you print a  document.  If you click on it, you
can cancel/pause your own jobs.  It is targeted for a normal user, not
a system administrator.

For system administrators, I think using the CUPS UI is not that bad.  
Comment 4 Chris Petersen 2004-11-18 14:53:53 EST
That explains it, then.  I don't HAVE a notification area.  It was
only full of useless things like redhat update, which just annoyed me,
so I removed it from my panel.

Anyway, now I know.  Would be nice to have printman back in the mix,
though.  From a UI perspective, a blank list in an actual program says
a lot more than a panel button that only shows up if there IS a list
(which indicated to me that there was no way to get at the queue). 
I'd much rather see an empty list than no list at all.
Comment 5 Colin Walters 2004-11-18 15:15:27 EST
A lot of other things use the notification area, removing it is
definitely not recommended.  You can pretty easily just remove the
up2date applet; right click and choose exit, then run
gnome-session-save.  

As for the UI - users will see eggcups appear when they print
something and should associate it with their print jobs.  So I don't
see a problem here.  What would having printman add exactly?
Comment 6 Chris Petersen 2004-11-18 15:26:52 EST
Just a personal ui preference, I guess.  Having SOME way to access the
list to make sure that it's empty would be nice (at the time, I was
debugging failing print jobs, and didn't know if they were queueing on
the linux box or the windows box that was sharing the printer, or if
the printer was eating them -- all of which are known to happen at
times in this setup).  I was mainly just surprised at the
disappearance of printman.

Anyway, feel free to close the bug if you feel that the panel applet
is sufficient.
Comment 7 Colin Walters 2004-11-18 15:37:45 EST
Well, as a sysadmin you have access to the CUPS logs, etc, which seem
like a good way to debug this.  Anyways, I think while not having
printman might be surprising for people coming from FC2/RHEL3, the new
way is better.

Thanks for the feedback, please feel free to file any other bugs you find!
Comment 8 Colin Walters 2004-11-27 12:13:59 EST
*** Bug 137960 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.