Bug 139667 - Promise S150 SX4 SATA Raid on HP ML110 server
Promise S150 SX4 SATA Raid on HP ML110 server
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks: FCMETA_INSTALL
  Show dependency treegraph
 
Reported: 2004-11-17 05:49 EST by Jonas
Modified: 2013-07-02 22:22 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-19 04:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas 2004-11-17 05:49:32 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Using a HP ML110 server with SATA Raid (Promise S150 SX4 
controller) and Raid 5 (with 3 harddisks)
2. Using Fedora Core 3 (or 2)
3. Doesn't work - finds drivers but freezes.
4. Core 2 and Core 3 uses different drivers (name of the driver) but 
the result is the same
  
Actual results:


Expected results:


Additional info:
HP have drivers for Redhat 9.0 (and SuSE 9) - shouldn't they work on 
Fedora?
Comment 1 Darin May 2004-11-24 04:51:36 EST
FC3 chokes on install with a Promise FastTrack 378 RAID 1 config. 
Interrupt #11 errors and eventual lockup.
Comment 2 John Brown 2004-12-21 06:42:38 EST
I also have install lockup on a HP ML110 SATA, I'm not attempting to
use any of it's hardware (well kind of) raid features.  The Kernel
pickes up the controller and one the disks, then the install locks and
goes no further.  
Comment 3 John Brown 2005-01-10 10:41:38 EST
Have attempted to use an Adaptec 1210SA in the ML110 and that lockup a
the same point in the boot sequernce during install (just after the
driver has detected the first disk).  How ever turn off acpi "append
acpi=off" and it works.  I will re-test with the ogrinal controler.
Comment 4 David Serreli 2005-02-18 12:14:04 EST
have attempt to disable acpi mode, and try to install fc3 on HP ML110
proliant to.
No more succes than John apparently. My promise is a S150 SX4. 
Nobody found a solution ?
Comment 5 Jonas 2005-04-29 11:49:03 EDT
Have tried with both Fedora Core 4 test 1 with the same result. I have the 
sourcecodes for the promise drivers but dont know how to use them.
Comment 6 Trevor Cordes 2005-07-12 22:15:08 EDT
This sounds suspiciously familiar to bug #128180.  Same lost interupt symtpom
and results (hang).  Sounds like the problem may be outside the specific card
chipset drivers.  These cards reportedly work fine on other OS's.
Comment 7 Dave Jones 2005-07-15 13:30:46 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Red Ochsenbein 2005-07-20 15:18:34 EDT
Installation of FC4 still freezes... 
Comment 9 Dave Jones 2005-09-30 02:00:43 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 10 Red Ochsenbein 2005-09-30 05:02:43 EDT
To test with the last kernel update is a bit hard since the problem occures on
installation. I tried the UNOFFICIAL Fedora Core 4.1 from
http://fedora.isphuset.no/ but the kernel used there is 2.6.12-1.1447_FC4 which
didn't work. Any ideas how I can try to install the server with the current
kernel package?
Comment 11 Dave Jones 2005-09-30 19:48:34 EDT
http://fedora.isphuset.no/ contains an unofficial Fedora 4.1, which may get you
up and running, as it has a install kernel based on one of the errata kernels.
Comment 12 Red Ochsenbein 2005-10-01 04:12:25 EDT
I tried this as stated in my last comment.
Comment 13 Dave Jones 2005-11-10 13:57:27 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 14 Red Ochsenbein 2005-11-10 14:05:43 EST
I will check this as soon as you lead me to a guide how to create ISOs with the
latest kernel in it. I found several How-tos for FC2 and FC3 but it seems these
don't work for FC4 or the anaconda-runtime scripts for FC4 are broken. Lost
already about 5 days trying to create new ISOs.
Comment 15 Dave Jones 2005-11-10 16:45:43 EST
theres an unofficial FC4.2 at http://fedora.isphuset.no
which has an updated kernel, (though not the current one), but that may be new
enough to fix your problem.
Comment 16 Red Ochsenbein 2005-11-12 03:39:26 EST
Tried with Unofficial FC4.2. Still no success...
Comment 17 Dave Jones 2005-11-19 04:04:05 EST
Due to the overhead involved in creating new ISOs (which is what would be
required for fixing bugs seen at installation time that don't have workarounds),
this bug has been closed.

For more information and suggestions, please see bug 169613

Thanks.

Note You need to log in before you can comment on or make changes to this bug.