Bug 1396674 - Include fix to upstream dracclient bug 1639339 "JobManagement.get_job() causes FutureWarning" in OSP 10
Summary: Include fix to upstream dracclient bug 1639339 "JobManagement.get_job() cause...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-dracclient
Version: 10.0 (Newton)
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: ga
: 10.0 (Newton)
Assignee: RHOS Maint
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks: 1356451 1335593
TreeView+ depends on / blocked
 
Reported: 2016-11-18 23:03 UTC by Richard Pioso
Modified: 2016-12-14 16:33 UTC (History)
23 users (show)

Fixed In Version: python-dracclient-1.0.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1396667
Environment:
Last Closed: 2016-12-14 16:33:50 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 393929 None None None 2016-11-18 23:03:04 UTC
Launchpad 1639339 None None None 2016-11-18 23:03:04 UTC

Description Richard Pioso 2016-11-18 23:03:04 UTC
Description of problem:

Upstream bug 1639339 "JobManagement.get_job() causes FutureWarning" was resolved. The fix applied to the python-dracclient project, which has only one (1) branch, master. It is not yet available in OSP 10. This bug requests that it be included in OSP 10.

Version-Release number of selected component (if applicable):

OSP 10

Additional info:

The bug report is available on Launchpad at https://bugs.launchpad.net/python-dracclient/+bug/1639339.

Comment 1 Dmitry Tantsur 2016-11-25 13:08:18 UTC
Done

Comment 5 Richard Pioso 2016-12-06 19:59:54 UTC
We deployed OSP 10 RC. I confirmed that that deployment contains the fix. /usr/lib/python2.7/site-packages/dracclient/resources/job.py has the patch that was merged to python-dracclient's master branch. Thank you!

[root@director ~]# yum list

Loaded plugins: product-id, search-disabled-repos, subscription-manager,
              : versionlock
Installed Packages

...

python-dracclient.noarch       1.0.0-2.el7ost     @RH7-RHOS-10.0-RC-2016-11-30.9

...

I confirmed that the /usr/lib/python2.7/site-packages/dracclient/resources/job.py in python-dracclient.noarch has the patch that was merged to python-dracclient's master branch.

Comment 7 errata-xmlrpc 2016-12-14 16:33:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.