Bug 1396667 - [ironic] Include fix to upstream bug 1637671 "DRAC get_bios_config() vendor passthru causes AttributeError exception" in OSP 10
Summary: [ironic] Include fix to upstream bug 1637671 "DRAC get_bios_config() vendor p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 10.0 (Newton)
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: rc
: 10.0 (Newton)
Assignee: Lucas Alvares Gomes
QA Contact: Raviv Bar-Tal
URL:
Whiteboard:
Depends On:
Blocks: 1335596 1356451
TreeView+ depends on / blocked
 
Reported: 2016-11-18 22:31 UTC by Richard Pioso
Modified: 2016-12-14 16:33 UTC (History)
21 users (show)

Fixed In Version: openstack-ironic-6.2.1-5.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of: 1396543
: 1396674 (view as bug list)
Environment:
Last Closed: 2016-12-14 16:33:38 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 392548 None None None 2016-11-18 22:53:21 UTC
Launchpad 1637671 None None None 2016-11-18 22:49:26 UTC

Description Richard Pioso 2016-11-18 22:31:59 UTC
Description of problem:

Upstream bug 1637671 "DRAC get_bios_config() vendor passthru causes AttributeError exception" was resolved and backported to the stable/newton branch. The fix is not yet available in OSP 10. This bug requests that it be included in OSP 10.

Version-Release number of selected component (if applicable):

OSP 10

Additional info:

The bug report is available on Launchpad at https://bugs.launchpad.net/ironic/+bug/1637671.

Comment 1 Dmitry Tantsur 2016-11-25 13:37:58 UTC
Done

Comment 3 Raviv Bar-Tal 2016-12-01 09:46:03 UTC
The merged package version is verified.
Test was not done downstream due to HA unavailability

Comment 4 arkady kanevsky 2016-12-01 13:48:31 UTC
Why is that not verified on FV2 stamp?

Comment 6 Richard Pioso 2016-12-05 22:20:20 UTC
We deployed OSP 10 RC. I confirmed that that deployment contains the fix. /usr/lib/python2.7/site-packages/ironic/drivers/modules/drac/vendor_passthru.py has the patch that was backported to ironic's stable/newton branch. Thank you!

[root@director ~]# yum list

Loaded plugins: product-id, search-disabled-repos, subscription-manager,
              : versionlock
Installed Packages

...

openstack-ironic-conductor.noarch
                               1:6.2.2-2.el7ost   @RH7-RHOS-10.0-RC-2016-11-30.9

...

rhosp-director-images.noarch   10.0-20161130.1.el7ost
                                                  @RH7-RHOS-10.0-RC-2016-11-30.9
rhosp-director-images-ipa.noarch
                               10.0-20161130.1.el7ost
                                                  @RH7-RHOS-10.0-RC-2016-11-30.9

...

Available Packages

...

rhosp-release.noarch           10.0-3.el7ost      RH7-RHOS-10.0-RC-2016-11-30.9

...

Comment 7 Richard Pioso 2016-12-06 17:18:03 UTC
(In reply to Richard Pioso from comment #6)
> We deployed OSP 10 RC. I confirmed that that deployment contains the fix.
> /usr/lib/python2.7/site-packages/ironic/drivers/modules/drac/vendor_passthru.
> py has the patch that was backported to ironic's stable/newton branch. Thank
> you!
> 
> [root@director ~]# yum list
> 
> Loaded plugins: product-id, search-disabled-repos, subscription-manager,
>               : versionlock
> Installed Packages
> 
> ...
> 
> openstack-ironic-conductor.noarch
>                                1:6.2.2-2.el7ost  
> @RH7-RHOS-10.0-RC-2016-11-30.9
> 
> ...
> 
> rhosp-director-images.noarch   10.0-20161130.1.el7ost
>                                                  
> @RH7-RHOS-10.0-RC-2016-11-30.9
> rhosp-director-images-ipa.noarch
>                                10.0-20161130.1.el7ost
>                                                  
> @RH7-RHOS-10.0-RC-2016-11-30.9
> 
> ...
> 
> Available Packages
> 
> ...
> 
> rhosp-release.noarch           10.0-3.el7ost     
> RH7-RHOS-10.0-RC-2016-11-30.9
> 
> ...

I had overlooked that the "Fixed In Version" was changed by Jon Schlueter on 20-16-11-29 02:31:30 EST from openstack-ironic-conductor-6.2.1-5.el7ost to openstack-ironic-6.2.1-5.el7ost. I reexamined our OSP 10 RC installation and found the following openstack-ironic* packages installed. Note that there is no openstack-ironic-6.2.1-5.el7ost.

[root@director ~]# yum list

Loaded plugins: product-id, search-disabled-repos, subscription-manager,
              : versionlock
Installed Packages

...

openstack-ironic-api.noarch    1:6.2.2-2.el7ost   @RH7-RHOS-10.0-RC-2016-11-30.9
openstack-ironic-common.noarch 1:6.2.2-2.el7ost   @RH7-RHOS-10.0-RC-2016-11-30.9
openstack-ironic-conductor.noarch
                               1:6.2.2-2.el7ost   @RH7-RHOS-10.0-RC-2016-11-30.9
openstack-ironic-inspector.noarch
                               4.2.1-1.el7ost     @RH7-RHOS-10.0-RC-2016-11-30.9

...

Therefore, I guessed that the file that needs to be fixed, /usr/lib/python2.7/site-packages/ironic/drivers/modules/drac/vendor_passthru.py, might be in openstack-ironic-common.noarch. Sure enough, it is. And that file has the patch that was backported to ironic's stable/newton branch.

Comment 8 Richard Pioso 2016-12-06 17:21:05 UTC
Should the "Fixed In Version" be openstack-ironic-common-6.2.2-2.el7ost, instead of openstack-ironic-6.2.1-5.el7ost? Please see Comment 7 above.

Comment 9 Sean Merrow 2016-12-09 15:25:31 UTC
John, can you please clear up the confusion about which package has the fix for Richard?

Comment 10 Jon Schlueter 2016-12-09 15:56:58 UTC
Yes I think I can clear it up.  

openstack-ironic-6.2.1-5.el7ost is the build NVR also name of srpm that patch was first included in.  Since that point in time openstack-ironic-6.2.2-2.el7ost was built it also includes that patch. 


openstack-ironic-common-6.2.2-2.el7ost

openstack-ironic-conductor-6.2.1-5.el7ost

These are RPM built from open stack ironic package.  Hope that helps.
To make my life easier when wrangling OSP releases we try to keep fixed in version pointing at builds not specific packages or bare revisions. So we have tools we can use to find and translate to the build NVR that was referenced.

Comment 12 errata-xmlrpc 2016-12-14 16:33:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.