Bug 139691 - Kernel panic at boot in 2.6.9-1.678_FC3
Kernel panic at boot in 2.6.9-1.678_FC3
Status: CLOSED DUPLICATE of bug 139674
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 10:58 EST by Stephen Murray
Modified: 2015-01-04 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 16:24:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Murray 2004-11-17 10:58:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Downloaded/installed latest kernel using RHN up2date.
Rebooted.
After kernel is loaded, kernel panic results.

Messages:

Red Hat nash version 4.1.18 starting
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
kernel panic - not syncing: Attempted to kill init!

Reverted to prior kernel 2.6.9-1.667, no problems.

grub.conf:

title Fedora Core (2.6.9-1.678_FC3)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-1.678_FC3 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.9-1.678_FC3.img

title Fedora Core (2.6.9-1.667)
        root (hd0,0)
        kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
        initrd /initrd-2.6.9-1.667.img

Tried changing "root=LABEL=/" to "root=/dev/sda3", same error.



Version-Release number of selected component (if applicable):
kernel-2.6.9-1.678_FC3

How reproducible:
Always

Steps to Reproduce:
1. reboot and select the kernel

    

Actual Results:  kernel panic

Expected Results:  system boot

Additional info:

See description above.
Comment 1 Mark Rush 2004-11-17 11:40:53 EST
seeing this too
Comment 2 Mark Rush 2004-11-17 11:50:03 EST
Sorry, here's my specs:
P4 3.0e
Asus P4C800-E Deluxe
4x512 Geil DDR400
eVGA geforce fx 5900 128
sb audigy gamer
rt8139 nic
seagate 80g sata
toshiba dvd
lite-on cdrw
ps/2 keyboard and mouse

I should add that it fails to find volumes when attempting to boot.
Comment 3 Dave Jones 2004-11-17 12:24:34 EST
which sata controllers do you guys have ? 
this could be a dupe of 139674
Comment 4 Stephen Murray 2004-11-17 12:38:54 EST
It's builtin to the box (Dell 4600). From "lspci -v"

00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) SATA Controller (rev
02) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Dell: Unknown device 0174
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 9
        I/O ports at fe00 [size=8]
        I/O ports at fe10 [size=4]
        I/O ports at fe20 [size=8]
        I/O ports at fe30 [size=4]
        I/O ports at fea0 [size=16]
Comment 5 Mark Rush 2004-11-17 13:41:07 EST
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Asustek Computer, Inc.: Unknown device 80a6
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 185
        I/O ports at efe0 [size=8]
        I/O ports at efac [size=4]
        I/O ports at efa0 [size=8]
        I/O ports at efa8 [size=4]
        I/O ports at ef60 [size=16]
Comment 6 Daniel C. Gonzalez 2004-11-17 14:18:35 EST
I have the same kernel panic on a Dell Dimension 8400.
The 2.6.9-1.677smp kernel runs fine, but when I upgraded to the
2.6.9-1.678_FC3smp kernel, I started getting that panic.  Here's
some of the output from "lspci -v":

00:1f.1 IDE interface: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family)
IDE Controller (rev 03) (prog-if 8a [Master SecP PriP])
        Subsystem: Dell: Unknown device 0177
        Flags: bus master, medium devsel, latency 0, IRQ 169
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at ffa0 [size=16]

00:1f.2 IDE interface: Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA
Controller (rev 03) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Dell: Unknown device 0177
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 217
        I/O ports at fe00 [size=8]
        I/O ports at fe10 [size=4]
        I/O ports at fe20 [size=8]
        I/O ports at fe30 [size=4]
        I/O ports at fea0 [size=16]
        Memory at dffffc00 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [70] Power Management version 2

Comment 7 Christof Efkemann 2004-11-17 15:15:37 EST
I have the same problem on my Intel D875PBZ board, also with a SATA
controller:

00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) SATA Controller (rev
02) (prog-if 8f [Master SecP SecO PriP PriO])
        Subsystem: Intel Corp.: Unknown device 425a
        Flags: bus master, 66Mhz, medium devsel, latency 0, IRQ 185
        I/O ports at ec00 [size=8]
        I/O ports at e800 [size=4]
        I/O ports at e400 [size=8]
        I/O ports at e000 [size=4]
        I/O ports at dc00 [size=16]
Comment 8 Dave Jones 2004-11-17 16:24:39 EST
ok, these are all intel ich controllers, so I'm duping this to keep them all in
the same place. thanks.

*** This bug has been marked as a duplicate of 139674 ***

Note You need to log in before you can comment on or make changes to this bug.