Bug 139674 - kernel-2.6.9-1.3_FC2 breaks multiple SATA drivers.
kernel-2.6.9-1.3_FC2 breaks multiple SATA drivers.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
: 139691 139749 139779 139786 139791 MISSING_ROOT_LVM2 140011 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 08:07 EST by josip
Modified: 2015-01-04 17:12 EST (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 16:29:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josip 2004-11-17 08:07:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
kernel-2.6.9-1.3_FC2 fails to boot from SATA drive (a Seagate
ST3160023AS) attached to Intel D865PERL motherboard via Intel Corp.
82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02), and
produces a kernel panic instead.

Previous kernel-2.6.8-1.521 works fine on the same machine.

Conclusion: kernel-2.6.9-1.3_FC2 is seriously broken.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.3_FC2

How reproducible:
Always

Steps to Reproduce:
1. install kernel-2.6.9-1.3_FC2 on SATA drive with ICH5 interface
2. boot
3. kernel panic results
    

Actual Results:  Kernel panic complains about not being able to access
disk

Expected Results:  Normal boot

Additional info:
Comment 1 Denice 2004-11-17 14:23:09 EST
I'm seeing the same thing here; ie. same motherboard: Intel D865PERL,
SATA-150, 2x Seagate ST3200822AS..
Comment 2 Denice 2004-11-17 15:22:20 EST
P.S. I should have added PCI output:

$ /sbin/lspci 
00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G550 AGP
(rev 01)
02:07.0 FireWire (IEEE 1394): Lucent Microelectronics FW323 (rev 61)
02:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet
Controller (rev 01)
Comment 3 Dave Jones 2004-11-17 16:24:42 EST
*** Bug 139691 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2004-11-17 17:24:31 EST
*** Bug 139749 has been marked as a duplicate of this bug. ***
Comment 5 Lars Damerow 2004-11-17 20:42:58 EST
I'm having the same issue, but on an HP xw8200 workstation. Here's my
lspci output:

00:00.0 Host bridge: Intel Corp. Workstation Memory Controller Hub
(rev 0a)
00:02.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
A0 (rev 0a)
00:03.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
A1 (rev 0a)
00:04.0 PCI bridge: Intel Corp. Memory Controller Hub PCI Express Port
B0 (rev 0a)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02)
01:00.0 PCI bridge: Intel Corp. PCI Bridge Hub A (rev 09)
01:00.1 PIC: Intel Corp. PCI Bridge Hub I/OxAPIC Interrupt Controller
A (rev 09)
01:00.2 PCI bridge: Intel Corp. PCI Bridge Hub B (rev 09)
01:00.3 PIC: Intel Corp. PCI Bridge Hub I/OxAPIC Interrupt Controller
B (rev 09)
02:01.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 08)
02:01.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 08)
02:05.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030
PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)
02:05.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1030
PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)
10:02.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A
IEEE-1394a-2000 Controller (PHY/Link)
10:03.0 Ethernet controller: Intel Corp. 82541GI/PI Gigabit Ethernet
Controller (rev 05)
40:00.0 VGA compatible controller: nVidia Corporation Quadro FX 3400
(rev a2)
Comment 6 Bill Nottingham 2004-11-18 00:58:03 EST
It appears to never be getting to piix_init_one.
Comment 7 Bill Nottingham 2004-11-18 01:12:14 EST
... because 000:1f.2 already has driver PCI_IDE.
Comment 8 Bill Nottingham 2004-11-18 02:58:53 EST
This is because the new code in ide/generic.c matches all PCI
devices... oddly, when it matches, instead of generic_init_one (which
appears to have already been called earlier), it's calling
pci_device_probe (which succeeds.)
Comment 9 Bill Nottingham 2004-11-18 03:04:18 EST
So, the ide_scan_pcidev fails (due to the check in generic_init_one),
but the generic PCI code (done via pci_register_driver()) succeeds.

I suppose we want to take out the blanket match ID from
drivers/ide/pci/generic.c?
Comment 10 Bill Nottingham 2004-11-18 03:42:57 EST
*** Bug 139779 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2004-11-18 03:43:29 EST
*** Bug 139786 has been marked as a duplicate of this bug. ***
Comment 12 Alan Cox 2004-11-18 08:04:41 EST
No we need to find out what the actual problem is
Comment 13 Alan Cox 2004-11-18 08:12:01 EST
Looking over the code your description of the failure appears to make
no sense.

The generic ide module loads. It will scan and ignore other PCI IDE
devices it is offered and then stay in memory in case of hotplug of an
unknown IDE device. This is correct kernel behaviour. It will not have
claimed the SATA devices so should not interfere in any way at all.

The code appears correct. I'm also unable to duplicate it on 2.6.9-ac
with a generic own built kernel, so I'm either missing something or
this is a bug in the user space.

Comment 14 Alan Cox 2004-11-18 08:27:02 EST
Ok found it - it is kernel and its been there since about 2.4.9.

Comment 15 Alan Cox 2004-11-18 08:34:09 EST
Fixed in my devel tree. We might want to propogate these fixes back to
RHEL3 as well.

A small number of pci setup routines in the IDE layer assumed > 0 was
an error as well as < 0. This is no longer true as of 2.4.9 or so.
This may explain a couple of other long standing hangs on boot too.

Comment 16 Andrew Rechenberg 2004-11-18 10:52:55 EST
Seeing this on a Dell Optiplex GX270 as well.  Is there a patch
available somewhere that we can apply to the kernel SRPM to build a
working 2.6.9 kernel for these issues?

Thanks.

Here's my info:

Handle 0x0100
        DMI type 1, 25 bytes.
        System Information
                Manufacturer: Dell Computer Corporation
                Product Name: OptiPlex GX270

00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#1 (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#2 (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#3 (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#4 (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX
5200] (rev a1)
02:07.0 Multimedia audio controller: Creative Labs [SB Live! Value]
EMU10k1X
02:07.1 Input device controller: Creative Labs [SB Live! Value] Input
device controller
02:0c.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet
Controller (rev 02)
Comment 17 Dave Jones 2004-11-18 12:08:00 EST
I'll get rpm's out into -testing with this fixed today.
Comment 18 Dave Jones 2004-11-18 18:46:57 EST
*** Bug 139791 has been marked as a duplicate of this bug. ***
Comment 19 Dave Jones 2004-11-18 21:45:15 EST
*** Bug 139982 has been marked as a duplicate of this bug. ***
Comment 20 Dave Jones 2004-11-18 21:45:24 EST
*** Bug 139986 has been marked as a duplicate of this bug. ***
Comment 21 Bill Nottingham 2004-11-19 00:08:03 EST
Please try the new rpms in testing for both FC2 and FC3.
Comment 22 Stephen Murray 2004-11-19 09:31:22 EST
Just installed and booted the latest "681" kernel for FC3, so far so
good. It's up and running without problem.

The only app that seems broken is VMWare, but it's been doing that
since FC3 day 1 with the original kernel. I had a workaround but it
doesn't work with this kernel, however I view this as a VMWare problem
not a kernel issue.

Good work guys !
Comment 23 Don Moore 2004-11-19 11:37:16 EST
I loaded and kernel-2.6.9-1.681_FC3 from updates/testing on Dell/GX280 .
For now all- is well, and booted fine with WD 36gb 10Krpm SATA disk/
ICH6W. Thanks,
-/don
Comment 24 Denice 2004-11-19 12:29:52 EST
Okay for me too at FC2: Intel Corp. 82801EB (ICH5) Serial ATA 150
Comment 25 Taner Halicioglu 2004-11-19 12:44:22 EST
Working fine on FC2 (2.6.9-1.6_FC2smp) w/ hardware:

00:1f.2 IDE interface: Intel Corp. 6300ESB SATA Storage Controller
(rev 02)

Good job, thanks!

-Taner
Comment 26 Thomas Chung 2004-11-19 12:51:06 EST
I have just tested both kernel-2.6.9-1.681_FC3.i686.rpm 
kernel-smp-2.6.9-1.681_FC3.i686.rpm on our FC3 test system and they
both rebooted successfully.

Test System: Dell Precision 370n with SATA drive
$ /sbin/lspci | grep SATA
00:1f.2 IDE interface: Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA
Controller (rev 03)

Thank you and I'll update http://fedoranews.org/blog/index.php?p=92

Thomas Chung
FedoraNEWS.ORG
Comment 27 Mark Rush 2004-11-19 12:56:19 EST
681 working fine here, too.
Comment 28 Dave Jones 2004-11-19 16:27:37 EST
*** Bug 140011 has been marked as a duplicate of this bug. ***
Comment 29 Dave Jones 2004-11-19 16:29:06 EST
fixed in 681
Comment 30 Matthew E. Lauterbach 2004-11-20 07:15:54 EST
I get that exact same error after installing FC3 i386 to SATA on my AMD64. 
Install works fine.  Subsequent boots fail with the same error.  I'll get you
lspci output as soon as I can.
Comment 31 Matthew E. Lauterbach 2004-11-20 07:18:05 EST
Forgot to mention:  This happens to me on the first boot.  So, it still has
stock FC3 kernel.  No updates have been done.
Comment 32 Matthew E. Lauterbach 2004-11-20 08:44:17 EST
I tried FC3 x86_64.  Boot fails with the same error.  The motherboard is a
Chaintech VNF3-250.  Here is the promised lspci:

00:00.0 Host bridge: nVidia Corporation: Unknown device 00e1 (rev a1)
00:01.0 ISA bridge: nVidia Corporation: Unknown device 00e0 (rev a2)
00:01.1 SMBus: nVidia Corporation nForce 250Gb PCI System Management (rev a1)
00:02.0 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.1 USB Controller: nVidia Corporation CK8S USB Controller (rev a1)
00:02.2 USB Controller: nVidia Corporation CK8S USB Controller (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb AC'97
Audio Controller (rev a1)
00:08.0 IDE interface: nVidia Corporation CK8S Parallel ATA Controller (v2.5)
(rev a2)
00:0a.0 IDE interface: nVidia Corporation CK8S Serial ATA Controller (v2.5) (rev a2)
00:0b.0 PCI bridge: nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge (rev a2)
00:0e.0 PCI bridge: nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200]
(rev a1)
02:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
02:07.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)
02:0a.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
02:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
Comment 33 Matthew E. Lauterbach 2004-11-20 09:41:45 EST
I used rescue and did 'chroot /mnt/sysimage' and scp'ed over the .681 kernel for
x86_64 and installed.  Boot still fails with the same error message.
Comment 34 Andrew Gormanly 2004-11-20 09:46:37 EST
Shouldn't the broken RPMs be pulled from the updates directories so no
one else hits this bug?  Apart from non-booting systems looking bad,
there will be people pulling down kernel packages over dial-up...
Comment 35 Neil Marjoram 2004-11-21 10:27:38 EST
I notice on this bug someone mentions VMware not working, mine does.
Something strange with VMware, the original build I had was from July,
however there is a build with the same build version dated November -
this seems to work fine. Download it again from VMware and try again.
Comment 36 Rob Hughes 2004-11-21 13:59:07 EST
This is hitting me even with the 681 kernel. Same story, 2.6.8 from
FC2 boots fine. I'm on a NForce2 board though, not an Intel, but am
booting from a single SATA drive. 
Comment 37 Andy Piper 2004-11-21 19:40:12 EST
I'm finding this same problem with a Gigabyte K8VNXP (VIA KT8T800
chipset) when attempting to booth with
kernel-2.6.9-1.681_FC3.i686.rpm. It works fine (well it boots
anyway...) with the stock FC3 kernel installed on SATA.

Kernel panic - not syncing: Attempted to kill init!
during boot and repeated IO errors after that.

I have tried removing 681, deleting the cached version in
/var/cache/yum, and reinstalling (in case I'd picked up the "bad"
version of the update). No luck.

[andyp@castor ~]$ lspci | grep SATA
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID
Controller (rev 80)
Comment 38 Stephen Murray 2004-11-22 09:53:20 EST
Looks like this bug has been marked "CLOSED", so I am wondering if Red
Hat is seeing these latest comments. I would suggest that anyone still
seeing the problem reopen a new, fresh bug report and reference this
thread. The 681 fix worked for me so I'm not the best person to that.
Comment 39 Matthew E. Lauterbach 2004-11-22 12:14:05 EST
Created new bug #140367 as this one is closed.

Note You need to log in before you can comment on or make changes to this bug.