Bug 139699 - Upgraded from FC2; Fonts Print Larger Than Preview
Upgraded from FC2; Fonts Print Larger Than Preview
Status: CLOSED DUPLICATE of bug 140584
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 11:39 EST by Morbus Iff
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 09:38:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The Disobey.com text file "Print To File" (56.22 KB, application/octet-stream)
2004-11-23 15:03 EST, Morbus Iff
no flags Details
The Firebird Print Preview (UL) and Save To File (LR) (191.69 KB, image/jpeg)
2004-11-23 16:27 EST, Morbus Iff
no flags Details

  None (edit)
Description Morbus Iff 2004-11-17 11:39:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
This machine is an upgrade from Fedora Core 2 to Fedora Core 3 using
the DVD iso. The upgrade went without visual hitch, and my previously
defined printer was still functional once the upgrade was finished.
The printer (via printconf-gui) is a Networked Windows (SMB) using the
DeskJet 820C driver (the printer is actually 820Cxi), and no other
settings have been changed.

Under Fedora Core 2, I had manually installed Thunderbird 0.8 (and
then 0.9), and printing was as you'd expect: no problems. Under Fedora
Core 3, however, Thunderbird will "Print Preview" the page just fine,
but upon printing, the font is upwards of 2 points larger, such that
the text scrolls off the right edge of the page. The font face appears
to be the same (monospaced Courier or Monaco?), just larger.

I've tried recreating the printer from scratch, as well as testing the
Thunderbird 0.8 RPM, and the behavior is the same: Print Preview looks
just fine, but the font is always bigger than the page width allows.
I've tried with and without "convert to PS", with no change.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install an existing printer in FC2.
2. Upgrade FC2 to FC3.
3. Print.

Expected Results:  The actual printed page should reflect the Print
Preview - it did in FC2, but not in FC3. The #fedora channel suggested
missing fonts, but theoretically, FC3 should have upgraded any font
package that had been working as I expected it to in FC2.

Additional info:
Comment 1 Morbus Iff 2004-11-22 16:27:07 EST
I've confirmed some more about this, primarily that it appears to deal
with PS and not CUPS. It also appears to happen only on monospaced
fonts. Here's a reliable way to test (which I've had a few people
confirm);

1. Load a text file in your browser, which'll display in monospaced.
Try http://disobey.com/detergent/zines/anti-press_ezine/00latest.txt.

2. Look at a "Print Preview", and you'll notice a wide right-margin.

3. Now, Print the page "to file" (which'll default to something like
/home/morbus/mozilla.ps). Load that file in ggv, and you'll notice the
font size is bigger, and the right margin is substantially smaller.

In this particular case, besides the larger font size, there's no true
harm in this side effect - since the text file is wrapped to less than
80 columns, it just happens to print without cutting off any text. For
an email message, however, where lines may not wrap, they'd fall off
the right-margin of the page. You can do the same steps as above
within Thunderbird to see an example.

As for happening only to monospaced, here's an example:

1. Open Thunderbird, and go to Tools > Options > Display.
2. "Use the following font" should be "Fixed width font".
3. Reload a mail message, it should be variable (probably Times).
4. Run through the preview/ps steps above. Everything is normal.

So, it's only related to PS and only than to monospaced fonts.
Comment 2 Scott R. Godin 2004-11-22 16:30:32 EST
I can confirm that this happens here as well. I too have
upgrade-installed from FC2 to FC3 on this box .. I had just installed
FC2 (clean-install) a week before FC3 was released (and promptly
downloaded and installed by me) so there wasn't much of the original
install that could have changed. 
Comment 3 Morbus Iff 2004-11-23 15:03:20 EST
Created attachment 107331 [details]
The Disobey.com text file "Print To File"

This is the generated PS file for the Firebird/Disobey.com URL steps. Some
helpful Postscript folks were asking for it.
Comment 4 Morbus Iff 2004-11-23 16:27:26 EST
Created attachment 107338 [details]
The Firebird Print Preview (UL) and Save To File (LR)

This is a screenshot of the "Print Preview" in Firebird (in the Upper Left).
This is what I'm considering the "right appearance", and is what I was seeing
in FC2. In the lower right hand corner, you can see the results of GGV opening
up the "Print To File" .ps version, which is what I'm considering the "wrong
appearance". The GGV view is what I see when I print out the file. Note,
predominantly, the difference in right margin size.
Comment 5 Matteo Corti 2004-11-24 09:14:44 EST
Hi, this seems to be a font problem (Courier in the urw fonts package).
See bug 140584
Comment 6 Tim Waugh 2004-11-24 09:38:35 EST
Yes, that looks like the root cause to me.  Thanks.

*** This bug has been marked as a duplicate of 140584 ***

Note You need to log in before you can comment on or make changes to this bug.