Bug 140584 - Courier fonts are too big (NimbusMonL)
Courier fonts are too big (NimbusMonL)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: urw-fonts (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
: Reopened
: 137336 138893 139344 139699 140197 140735 141051 142590 147947 167122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 13:53 EST by Matt Clapp
Modified: 2007-11-30 17:10 EST (History)
25 users (show)

See Also:
Fixed In Version: FC6/F7 update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 09:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of bad fonts in ghostview (114.73 KB, text/plain)
2004-12-15 00:04 EST, Matt Clapp
no flags Details
proper behavior using old urw-fonts-2.1-7 (84.31 KB, text/plain)
2004-12-15 00:13 EST, Matt Clapp
no flags Details

  None (edit)
Description Matt Clapp 2004-11-23 13:53:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
When using enscript to print to a ps file or directly to my printer,
and also when printing text directly to my printer (PCL printer, not
real PS printer,) anything printed with Courier font will go outside
the margins.  It's as if the actual font is bigger than ghostscript
thinks it is.

I believe this is the problem:
http://www.linuxquestions.org/questions/showthread.php?s=&threadid=249481

If I specify a different font, then everything looks correct.  It
seems to only happen with Courier, the default monospace font.

Version-Release number of selected component (if applicable):
version 2.2, release 6

How reproducible:
Always

Steps to Reproduce:
1. print a text file with long lines (at least 80 chars in some lines)
to a postscript file using enscript.  (enscript -2rj --file=outfile.ps
infile.txt) The -2rj option causes to pages to be printed side-by-side
with boundary lines which shows the effect well.
2. View with ghostscript or print on a non-PS printer
3.
    

Actual Results:  Long lines will overprint past the normal margin.
(e.g. into the second page from the first page on a side-by-side layout)

Expected Results:  ghostscript should correctly display fonts that
stay within the boundaries

Additional info:

ghostscript v7.07 release 33
Comment 1 Matt Clapp 2004-11-23 18:04:19 EST
Sorry, in the previous comment, the proper syntax of the enscript
commaand would be:
enscript -2rj --output=outfile.ps infile.txt

I have found that if I use urw-fonts v2.1 r7, this problem does not
occur.  It seems to be limited to the latest Fedora Core 3 version of
urw-fonts.
Comment 2 Matteo Corti 2004-11-24 08:52:38 EST
*** Bug 138893 has been marked as a duplicate of this bug. ***
Comment 3 Matteo Corti 2004-11-24 08:58:09 EST
Downgrading to urw-fonts-2.1-7.noarch.rpm from FC2 fixes the problem
Comment 4 Tim Waugh 2004-11-24 09:38:41 EST
*** Bug 139699 has been marked as a duplicate of this bug. ***
Comment 5 Morbus Iff 2004-11-24 09:57:30 EST
Confirmed - all problems stated in bug 139699 are solved with a
downgrading to urw-fonts-2.1.7.noarch.rpm. Thanks!
Comment 6 Tim Waugh 2004-11-24 11:22:06 EST
*** Bug 140735 has been marked as a duplicate of this bug. ***
Comment 7 Ngo Than 2004-12-07 12:17:23 EST
could you please attach the screenshots, which show the different
please. thanks
Comment 8 Morbus Iff 2004-12-07 12:22:42 EST
There are screenshots and generated PSs in bug 139699.
Comment 9 Tim Waugh 2004-12-13 11:38:16 EST
*** Bug 139344 has been marked as a duplicate of this bug. ***
Comment 10 Tim Waugh 2004-12-13 16:49:28 EST
*** Bug 142590 has been marked as a duplicate of this bug. ***
Comment 13 Matt Clapp 2004-12-15 00:04:58 EST
Created attachment 108591 [details]
screenshot of bad fonts in ghostview

This screenshot shows Courier fonts rendered in ghostview.  The original ps was
created from a text file by:
enscript -2rj --output=test.ps

You can see that even though lines do get wrapped (see lower-left of page) they
are wrapped too late, as though the fonts are expected to be smaller than they
are actually rendered.
Comment 14 Matt Clapp 2004-12-15 00:13:13 EST
Created attachment 108592 [details]
proper behavior using old urw-fonts-2.1-7

screen shot exactly under the same conditions as last attachment, EXCEPT using
the old urw-fonts package: urw-fonts-2.1-7

Note that none of the lines overflow their boundaries, and the actual size of
the font is smaller.
Comment 15 Tim Waugh 2005-01-11 04:40:12 EST
*** Bug 137336 has been marked as a duplicate of this bug. ***
Comment 16 Tim Waugh 2005-02-14 04:52:20 EST
*** Bug 147947 has been marked as a duplicate of this bug. ***
Comment 17 Ngo Than 2005-02-24 06:59:52 EST
I have tried to change to ascender/descender in NimbusMonL in urw-fonts-2.2-8.
It looks ok now. You will find the new version in rawhide.

Please reopen the bug again if the problem is still show ups. Thanks
Comment 18 Matt Clapp 2005-02-25 12:05:18 EST
Sorry for the newbie question, but I'd like to test this, and I can't find
urw-fonts-2.2-8.

I've looked in
http://download.fedora.redhat.com/pub/fedora/linux/core/development/ and can't
find anything but 2.2-6, and I've even google-searched for urw-fonts-2.2-8 with
no results.

Any help as to where this is, so I can get it and test it? thanks
Comment 19 Rasmus Ory Nielsen 2005-02-26 10:25:43 EST
wfm
Comment 20 Michal Jaegermann 2005-03-25 13:01:41 EST
So a month ago this bug, and others like #142590 which were eventually
determined to be manifestations of the same thing, were CLOSED RAWHIDE
but an obvious update to FC3 was not issued.  This means that people
all over the place are still troubled by the same problem with a known fix.
What happened?
Comment 21 Ngo Than 2005-03-30 05:23:06 EST
can someone please tell me if the problem is really fixed in urw-fonts-2.2-8?

if yes, i will build fixed urw-fonts package for fc3 update today.
Comment 22 Axel Thimm 2005-03-30 05:36:32 EST
The sizes have improved, but are still bigger than the FC2 package. At least
mythtv users report that this package is still cropping their displays due to
oversized fonts and they resort to FC2's version.

http://www.google.de/search?q=mythtv+urw-fonts+fc2

FWIW I already rebuilt the rawhide package at ATrpms (replacing 8 with 7.99 to
allow for upgrade to the upcoming official version) and it was used by the
people that complained on too big fonts, returning the above feedback.

Thanks!
Comment 23 Matt Clapp 2005-03-30 10:40:29 EST
This problem has been completely fixed for me.  I have not seen any cropping
since I upgraded to the new font package.
Comment 24 brucem 2005-04-01 14:55:53 EST
I installed the new font package in fc3;i.e., urw-fonts 2.2.8. That fixed the
Courier print problem from Thinderbird. However, after doing that, in the
Thunderbird "print preview," I am seeing NimbusSansL words being cropped at the
right edge of the page, though the hardcopy looks fine coming out of the print
driver. In other words, the preview is messed up, but the printed copy is good.
Different problem?
Comment 26 Ra P. 2005-04-18 18:25:19 EDT
Where can I get a fixed font package for FC3?  Where do I download "rawhide"
pacakges, I don't see them under
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/

Thanks.
Comment 27 John W. Lockhart 2005-04-18 19:08:12 EDT
"rawhide" packages are found in the "development" tree --

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/

Currently, these are FC4-test packages, to the best of my knowledge.  Being
development versions, they could break.  That having been said, I tried a
urw-fonts update and 2.3-1 seems okay on the FC2 box I was using.
Comment 28 Ngo Than 2005-04-19 05:47:42 EDT
It's already built in FC3-update tree today. It still needs to be signed and
pushed. sorry for delay
Comment 29 Aleksey Nogin 2005-04-19 13:07:12 EDT
*** Bug 140197 has been marked as a duplicate of this bug. ***
Comment 30 Jonathan S. Shapiro 2005-04-19 19:39:23 EDT
Ngo: do you happen to know if this is the same issue that has plagued ps2pdf? I
have noted that conversions from PS files to PDF files mess up any conversion
involving Courier. The symptoms are very similar to what is being described
above. If your answer is "I don't know", let me know -- I have lots of messed up
documents I can test on. :-)

The weird part is that these documents displayed *correctly* in ghostview. It
was only the transformation to PDF that seemed to mess them up.
Comment 31 Ngo Than 2005-09-06 07:43:14 EDT
*** Bug 167122 has been marked as a duplicate of this bug. ***
Comment 32 Jonathan S. Shapiro 2005-09-06 07:54:08 EDT
The originally reported issue is fixed in FC4 so far as I can tell. My
recommendation is to close this bug with WONTFIX unless somebody reports that
the current FC4 version of urw-fonts is giving problems for (e.g.) mythtv. I am
no longer seeing problems in ps2pdf, which was the original issue, and was
definitely being caused by a urw-fonts glitch.
Comment 33 Warren Togami 2005-09-30 14:13:00 EDT
*** Bug 141051 has been marked as a duplicate of this bug. ***
Comment 34 Adam Augustine 2005-10-08 14:58:43 EDT
Looks like this persists for MythTV 18.1 on FC4 urw-fonts-2.3-1.
Comment 35 Adam Augustine 2005-10-08 15:53:27 EDT
Downgrading to 2.1-7 seems to resolve the problem for MythTV 0.18.1
Comment 36 Florin Andrei 2005-10-19 22:04:50 EDT
This is an old bug, I confirm it on FC4 with MythTV, is there any progress?
Comment 37 Giac0m0 2006-03-01 11:33:36 EST
Is it possible to prevent Yum from automatically upgrading the fonts package 
when running:

# yum -y upgrade

While we wait for Core 5 ?
Comment 38 John W. Lockhart 2006-03-01 12:02:16 EST
Check out the '--exclude' option of yum; it should allow you to
exclude any package from updates.

Comment 39 erick sunarto 2006-04-30 18:09:31 EDT
bug still exist in FC5 with mythtv :((
Comment 40 Si Coeshott 2006-07-04 12:26:12 EDT
I confirm that this bug still exists with Fedora Core 5 and MythTV using
urw-fonts-2.3-6.1. Problem fixed by downgrading to urw-fonts-2.1-7 i.e FC2.
Comment 41 Florin Andrei 2006-07-04 13:26:49 EDT
(In reply to comment #40)
> I confirm that this bug still exists with Fedora Core 5 and MythTV using
> urw-fonts-2.3-6.1. Problem fixed by downgrading to urw-fonts-2.1-7 i.e FC2.
> 

If urw-fonts was an Extras package, it would be flagged as "orphan", lol :-)

And yes, the problem was never fixed for MythTV. Still persists with FC5.
Someone with enough privileges please reopen the bug.
Comment 42 Axel Thimm 2006-07-04 13:54:07 EDT
OK, reopening (and moving to FC5).
Comment 43 Jake Gage 2006-12-25 05:34:02 EST
Confirmed in FC6.
Comment 44 Ngo Than 2007-06-15 09:34:27 EDT
1.0.7pre41 upstream now includes the fix. I will build urw-fonts-2.3-7.fc6 in 
FC6/F7 update soon. Thanks for your report
Comment 45 Nigel Jewell 2007-06-15 13:58:50 EDT
Is this also gonna be fixed in RHEL4?

Note You need to log in before you can comment on or make changes to this bug.