Bug 1397108 - DNF can't update Vim
Summary: DNF can't update Vim
Status: CLOSED DUPLICATE of bug 1263888
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-21 16:04 UTC by Vít Ondruch
Modified: 2016-11-22 09:18 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-21 21:30:45 UTC


Attachments (Terms of Use)
debugdata (6.16 MB, application/x-xz)
2016-11-21 16:04 UTC, Vít Ondruch
no flags Details

Description Vít Ondruch 2016-11-21 16:04:02 UTC
Created attachment 1222432 [details]
debugdata

Description of problem:
DNF can't update Vim, although everything seems to be in order.

Version-Release number of selected component (if applicable):
$ rpm -q dnf
dnf-2.0.0-0.rc1.4.fc26.noarch

$ rpm -q libdnf
libdnf-0.7.0-0.2git8bd77f8.fc26.x86_64

$ rpm -q libsolv
libsolv-0.6.24-1.fc26.x86_64

$ rpm -q hawkey 
hawkey-0.6.3-6.fc26.x86_64

$ rpm -q vim* -a
vim-taglist-4.6-11.fc24.noarch
vim-enhanced-8.0.086-1.fc26.x86_64
vim-minimal-8.0.086-1.fc26.x86_64
vim-common-8.0.086-1.fc26.x86_64
vim-command-t-4.0-1.fc25.x86_64
vim-fugitive-2.2-5.fc25.noarch
vim-nerdtree-4.2.0-13.fc24.noarch
vim-filesystem-8.0.086-1.fc26.x86_64
vim-X11-8.0.086-1.fc26.x86_64
vim-commentary-1.3-1.fc25.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
]$ LANG=C.UTF-8 sudo dnf upgrade --disablerepo=* --enablerepo=rawhide https://kojipkgs.fedoraproject.org//packages/vim/8.0.094/1.fc26/x86_64/vim-X11-8.0.094-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.094/1.fc26/x86_64/vim-common-8.0.094-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.094/1.fc26/x86_64/vim-enhanced-8.0.094-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.094/1.fc26/x86_64/vim-filesystem-8.0.094-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.094/1.fc26/x86_64/vim-minimal-8.0.094-1.fc26.x86_64.rpm --debugsolver
Repository 'tiliado-nuvolaplayer' is missing name in configuration, using id.
Last metadata expiration check: 0:22:23 ago on Mon Nov 21 16:38:39 2016 CET.
Error: 
 Problem 1: problem with installed package vim-fugitive-2.2-5.fc25.noarch
  - package vim-fugitive-2.2-5.fc25.noarch requires /usr/bin/vim, but none of the providers can be installed
  - package vim-fugitive-2.2-5.fc25.noarch requires /usr/bin/vim, but none of the providers can be installed
  - cannot install both vim-enhanced-2:8.0.094-1.fc26.x86_64 and vim-enhanced-2:8.0.086-1.fc26.x86_64
  - cannot install both vim-enhanced-2:8.0.094-1.fc26.x86_64 and vim-enhanced-2:8.0.086-1.fc26.x86_64
  - conflicting requests
 Problem 2: problem with installed package sudo-1.8.19-0.2.20161108git738c3cb.fc26.x86_64
  - package sudo-1.8.19-0.2.20161108git738c3cb.fc26.x86_64 requires /usr/bin/vi, but none of the providers can be installed
  - package sudo-1.8.19-0.2.20161108git738c3cb.fc26.x86_64 requires /usr/bin/vi, but none of the providers can be installed
  - cannot install both vim-minimal-2:8.0.094-1.fc26.x86_64 and vim-minimal-2:8.0.086-1.fc26.x86_64
  - cannot install both vim-minimal-2:8.0.094-1.fc26.x86_64 and vim-minimal-2:8.0.086-1.fc26.x86_64
  - conflicting requests
 Problem 3: problem with installed package vim-commentary-1.3-1.fc25.noarch
  - package vim-commentary-1.3-1.fc25.noarch requires /usr/bin/vim, but none of the providers can be installed
  - package vim-commentary-1.3-1.fc25.noarch requires /usr/bin/vim, but none of the providers can be installed
  - package vim-enhanced-2:8.0.086-1.fc26.x86_64 requires vim-common = 2:8.0.086-1.fc26, but none of the providers can be installed
  - package vim-enhanced-2:8.0.086-1.fc26.x86_64 requires vim-common = 2:8.0.086-1.fc26, but none of the providers can be installed
  - cannot install both vim-common-2:8.0.094-1.fc26.x86_64 and vim-common-2:8.0.086-1.fc26.x86_64
  - cannot install both vim-common-2:8.0.094-1.fc26.x86_64 and vim-common-2:8.0.086-1.fc26.x86_64
  - conflicting requests
 Problem 4: problem with installed package vim-command-t-4.0-1.fc25.x86_64
  - package vim-command-t-4.0-1.fc25.x86_64 requires /usr/bin/vim, but none of the providers can be installed
  - package vim-command-t-4.0-1.fc25.x86_64 requires /usr/bin/vim, but none of the providers can be installed
  - package vim-enhanced-2:8.0.086-1.fc26.x86_64 requires vim-common = 2:8.0.086-1.fc26, but none of the providers can be installed
  - package vim-enhanced-2:8.0.086-1.fc26.x86_64 requires vim-common = 2:8.0.086-1.fc26, but none of the providers can be installed
  - cannot install both vim-common-2:8.0.094-1.fc26.x86_64 and vim-common-2:8.0.086-1.fc26.x86_64
  - cannot install both vim-common-2:8.0.094-1.fc26.x86_64 and vim-common-2:8.0.086-1.fc26.x86_64
  - package vim-X11-2:8.0.094-1.fc26.x86_64 requires vim-common = 2:8.0.094-1.fc26, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages)


Expected results:
Update works just fine.

Additional info:

Comment 1 Vít Ondruch 2016-11-21 16:31:18 UTC
Just a silly idea ... isn't this something related to Epoch? Isn't Epoch accidentally omitted somewhere?

Comment 2 Igor Gnatenko 2016-11-21 21:30:45 UTC
that seems very similar to 1263888.

*** This bug has been marked as a duplicate of bug 1263888 ***

Comment 3 Michael Mráka 2016-11-22 08:03:36 UTC
Vit can you download packages, create a local repo out of them and check whether it will update from that repo?
Thanks.

Comment 4 Vít Ondruch 2016-11-22 09:18:17 UTC
If only --reporfrompath worked :/ (bug 1394893).


Note You need to log in before you can comment on or make changes to this bug.