This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1263888 - dnf behaves non deterministically during local install
dnf behaves non deterministically during local install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
26
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Jaroslav Mracek
Fedora Extras Quality Assurance
: Reopened, Triaged
: 1270779 1324470 1397108 1414961 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 21:29 EDT by Harald Reindl
Modified: 2017-03-31 06:25 EDT (History)
17 users (show)

See Also:
Fixed In Version: libdnf-0.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-12 17:53:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
here are your debugdata (7.44 MB, application/octet-stream)
2015-11-13 06:30 EST, Harald Reindl
no flags Details
another debugdata (7.13 MB, application/octet-stream)
2016-07-26 08:59 EDT, Harald Reindl
no flags Details
debugdata again (6.71 MB, application/x-bzip)
2016-08-30 10:16 EDT, Harald Reindl
no flags Details
debugdata again - different machine (7.46 MB, application/x-bzip)
2016-08-30 10:18 EDT, Harald Reindl
no flags Details
debugdata (9.39 MB, application/x-xz)
2016-11-22 03:20 EST, Vít Ondruch
no flags Details
rpm -qa (54.34 KB, text/plain)
2017-01-13 04:42 EST, Harald Reindl
no flags Details
dnf-extras that should be installable (227.97 KB, application/zip)
2017-01-13 10:35 EST, Jaroslav Mracek
no flags Details
Fc24 extras (196.23 KB, application/x-gzip)
2017-01-13 11:13 EST, Jaroslav Mracek
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github openSUSE/libsolv/issues/174 None None None 2017-01-19 12:02 EST

  None (edit)
Description Harald Reindl 2015-09-16 21:29:28 EDT
may somebody explain why at the first try DNF talks about "not installable" and just cursor-up + enter no problems with updates from local RPMs - the only difference i see is that the fist time metadata are downloaded which are in the second case are in the cache

the whole metadata download for a local update/install is pure nonsense until there are no external dependencies and DNF is just terrible slow at all in case of repeated local updates waiting for some seconds while with YUm it was a "that i would do - yes/no" enter - done while DNF sits around doing nothing useful

Fehler: package coreutils-8.23-11.fc22.x86_64 is not installable.
package firefox-41.0-2.fc22.x86_64 is not installable.
package xorg-x11-server-common-1.17.2-2.fc22.1.x86_64 is not installable.
package xorg-x11-server-Xorg-1.17.2-2.fc22.1.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)


[root@srv-rhsoft:/downloads]$ dnf update *.rpm
cachedir: /var/cache/dnf                                                                                                                                                                                           
Loaded plugins: protected_packages, kickstart, noroot, reposync, debuginfo-install, Query, copr, playground, config-manager, builddep, generate_completion_cache, download, needs-restarting                       
DNF version: 1.1.1                                                                                                                                                                                                 
repo: using cache for: rpmfusion-nonfree-updates-testing                                                                                                                                                           
not found deltainfo for: RPM Fusion for Fedora 22 - Nonfree - Test Updates                                                                                                                                         
not found updateinfo for: RPM Fusion for Fedora 22 - Nonfree - Test Updates                                                                                                                                        
rhsoft-repo with generic rpms                                                                                                                                                      152 kB/s | 4.4 kB     00:00     
not found deltainfo for: rhsoft-repo with generic rpms                                                                                                                                                             
not found updateinfo for: rhsoft-repo with generic rpms                                                                                                                                                            
repo: using cache for: updates-testing                                                                                                                                                                             
repo: using cache for: fedora                                                                                                                                                                                      
not found deltainfo for: Fedora 22 - x86_64                                                                                                                                                                        
not found updateinfo for: Fedora 22 - x86_64
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 22 - Free
not found updateinfo for: RPM Fusion for Fedora 22 - Free
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 22 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Free - Updates
repo: using cache for: rpmfusion-nonfree-updates
not found deltainfo for: RPM Fusion for Fedora 22 - Nonfree - Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Nonfree - Updates
repo: using cache for: updates
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
not found updateinfo for: google-chrome
rhsoft-repo for fedora                                                                                                                                                             4.7 MB/s | 174 kB     00:00    
not found deltainfo for: rhsoft-repo for fedora
not found updateinfo for: rhsoft-repo for fedora
repo: using cache for: rpmfusion-free-updates-testing
not found deltainfo for: RPM Fusion for Fedora 22 - Free - Test Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Free - Test Updates
repo: using cache for: rpmfusion-nonfree
not found deltainfo for: RPM Fusion for Fedora 22 - Nonfree
not found updateinfo for: RPM Fusion for Fedora 22 - Nonfree
rpmfusion-nonfree-updates-testing: using metadata from Fri Apr 10 19:47:11 2015.
rhsoft-generic: using metadata from Thu Jun 26 17:11:16 2014.
updates-testing: using metadata from Wed Sep 16 00:37:10 2015.
fedora: using metadata from Sat May 23 12:23:20 2015.
adobe-linux-x86_64: using metadata from Fri Aug  7 22:34:33 2015.
rpmfusion-free: using metadata from Wed Aug  5 14:49:43 2015.
rpmfusion-free-updates: using metadata from Sun Aug 30 16:31:20 2015.
rpmfusion-nonfree-updates: using metadata from Sun Aug 30 16:38:41 2015.
updates: using metadata from Wed Sep 16 23:03:46 2015.
google-chrome: using metadata from Wed Sep 16 22:03:56 2015.
rhsoft-fedora: using metadata from Wed Sep 16 16:00:32 2015.
rpmfusion-free-updates-testing: using metadata from Fri Apr 10 19:47:11 2015.
rpmfusion-nonfree: using metadata from Wed Aug  5 09:07:52 2015.
Last metadata expiration check performed 0:00:09 ago on Thu Sep 17 03:24:19 2015.
Completion plugin: Generating completion cache...
--> Abhängigkeitsauflösung wird gestartet
--> Abhängigkeitsauflösung wurde abgeschlossen
Fehler: package coreutils-8.23-11.fc22.x86_64 is not installable.
package firefox-41.0-2.fc22.x86_64 is not installable.
package xorg-x11-server-common-1.17.2-2.fc22.1.x86_64 is not installable.
package xorg-x11-server-Xorg-1.17.2-2.fc22.1.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
[root@srv-rhsoft:/downloads]$ dnf update *.rpm
cachedir: /var/cache/dnf
Loaded plugins: protected_packages, kickstart, noroot, reposync, debuginfo-install, Query, copr, playground, config-manager, builddep, generate_completion_cache, download, needs-restarting
DNF version: 1.1.1
repo: using cache for: rpmfusion-nonfree-updates-testing
not found deltainfo for: RPM Fusion for Fedora 22 - Nonfree - Test Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Nonfree - Test Updates
repo: using cache for: rhsoft-generic
not found deltainfo for: rhsoft-repo with generic rpms
not found updateinfo for: rhsoft-repo with generic rpms
repo: using cache for: updates-testing
repo: using cache for: fedora
not found deltainfo for: Fedora 22 - x86_64
not found updateinfo for: Fedora 22 - x86_64
repo: using cache for: adobe-linux-x86_64
not found deltainfo for: Adobe Systems Incorporated
not found updateinfo for: Adobe Systems Incorporated
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 22 - Free
not found updateinfo for: RPM Fusion for Fedora 22 - Free
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 22 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Free - Updates
repo: using cache for: rpmfusion-nonfree-updates
not found deltainfo for: RPM Fusion for Fedora 22 - Nonfree - Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Nonfree - Updates
repo: using cache for: updates
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
not found updateinfo for: google-chrome
repo: using cache for: rhsoft-fedora
not found deltainfo for: rhsoft-repo for fedora
not found updateinfo for: rhsoft-repo for fedora
repo: using cache for: rpmfusion-free-updates-testing
not found deltainfo for: RPM Fusion for Fedora 22 - Free - Test Updates
not found updateinfo for: RPM Fusion for Fedora 22 - Free - Test Updates
repo: using cache for: rpmfusion-nonfree
not found deltainfo for: RPM Fusion for Fedora 22 - Nonfree
not found updateinfo for: RPM Fusion for Fedora 22 - Nonfree
rpmfusion-nonfree-updates-testing: using metadata from Fri Apr 10 19:47:11 2015.
rhsoft-generic: using metadata from Thu Jun 26 17:11:16 2014.
updates-testing: using metadata from Wed Sep 16 00:37:10 2015.
fedora: using metadata from Sat May 23 12:23:20 2015.
adobe-linux-x86_64: using metadata from Fri Aug  7 22:34:33 2015.
rpmfusion-free: using metadata from Wed Aug  5 14:49:43 2015.
rpmfusion-free-updates: using metadata from Sun Aug 30 16:31:20 2015.
rpmfusion-nonfree-updates: using metadata from Sun Aug 30 16:38:41 2015.
updates: using metadata from Wed Sep 16 23:03:46 2015.
google-chrome: using metadata from Wed Sep 16 22:03:56 2015.
rhsoft-fedora: using metadata from Wed Sep 16 16:00:32 2015.
rpmfusion-free-updates-testing: using metadata from Fri Apr 10 19:47:11 2015.
rpmfusion-nonfree: using metadata from Wed Aug  5 09:07:52 2015.
Last metadata expiration check performed 0:00:31 ago on Thu Sep 17 03:24:19 2015.
--> Abhängigkeitsauflösung wird gestartet
---> Paket coreutils.x86_64 8.23-10.fc22 wird aktualisiert
---> Paket coreutils.x86_64 8.23-11.fc22 wird eine Aktualisierung
---> Paket firefox.x86_64 41.0-1.fc22 wird aktualisiert
---> Paket firefox.x86_64 41.0-2.fc22 wird eine Aktualisierung
---> Paket xorg-x11-server-common.x86_64 1.17.2-2.fc22 wird aktualisiert
---> Paket xorg-x11-server-common.x86_64 1.17.2-2.fc22.1 wird eine Aktualisierung
---> Paket xorg-x11-server-Xorg.x86_64 1.17.2-2.fc22 wird aktualisiert
---> Paket xorg-x11-server-Xorg.x86_64 1.17.2-2.fc22.1 wird eine Aktualisierung
--> Abhängigkeitsauflösung wurde abgeschlossen
Abhängigkeiten sind aufgelöst.
===================================================================================================================================================================================================================
 Paket                                                      Arch                                       Version                                              Paketquelle                                      Größe
===================================================================================================================================================================================================================
Aktualisieren:
 coreutils                                                  x86_64                                     8.23-11.fc22                                         @commandline                                     2.9 M
 firefox                                                    x86_64                                     41.0-2.fc22                                          @commandline                                      72 M
 xorg-x11-server-Xorg                                       x86_64                                     1.17.2-2.fc22.1                                      @commandline                                     1.4 M
 xorg-x11-server-common                                     x86_64                                     1.17.2-2.fc22.1                                      @commandline                                      43 k

Transaktionsübersicht
===================================================================================================================================================================================================================
Aktualisieren  4 Packages

Gesamtgröße: 77 M
Ist dies in Ordnung? [j/N] :
Comment 1 Honza Silhan 2015-09-21 05:14:51 EDT
Can you upload the exact RPMs, please?
Comment 2 Harald Reindl 2015-09-21 05:18:37 EDT
it don't matter which RPM's - my own repos have metadata_expire=30m, dnf-cache-timers are disabled by intention and it happens nearly regulary when do a "dnf update /downloads/*.rpm" the first time when it downloads the metadata (for whatever reason, see other bugreport)

whenever that happens, just cursor-up + enter and it works fine
Comment 3 Harald Reindl 2015-09-22 08:50:00 EDT
[root@rh:/downloads]$ ls
insgesamt 11M
-rw-r----- 1 harry verwaltung  34K 2015-09-22 14:43 dnf-plugins-core-0.1.12-1.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung 2,3M 2015-09-22 14:43 glib2-2.44.1-2.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung 1,6M 2015-09-22 14:43 icedtea-web-1.6.1-2.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung 5,7M 2015-09-22 14:42 plasma-desktop-5.4.1-5.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung  57K 2015-09-22 14:43 python3-dnf-plugins-core-0.1.12-1.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung  83K 2015-09-22 14:43 python-dnf-plugins-core-0.1.12-1.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung 468K 2015-09-22 14:43 sqlite-3.8.11.1-1.fc22.x86_64.rpm

_________________________________________________

[root@rh:/downloads]$ dnf update *.rpm
rhsoft-repo with generic rpms                                                                                                                                                       19 kB/s | 4.4 kB     00:00    
rhsoft-repo for fedora                                                                                                                                                             552 kB/s | 174 kB     00:00    
Last metadata expiration check performed 0:00:09 ago on Tue Sep 22 14:46:40 2015.
Paket python3-dnf-plugins-core ist nicht installiert, es kann nicht aktualisiert werden.
Fehler: nothing provides python-dnf-plugins-core = 0.1.12-1.fc22 needed by dnf-plugins-core-0.1.12-1.fc22.noarch.
package glib2-2.44.1-2.fc22.x86_64 is not installable.
package icedtea-web-1.6.1-2.fc22.x86_64 is not installable.
package plasma-desktop-5.4.1-5.fc22.x86_64 is not installable.
package python-dnf-plugins-core-0.1.12-1.fc22.noarch is not installable.
package sqlite-3.8.11.1-1.fc22.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)

_________________________________________________

[root@rh:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:00:34 ago on Tue Sep 22 14:46:40 2015.
Paket python3-dnf-plugins-core ist nicht installiert, es kann nicht aktualisiert werden.
Abhängigkeiten sind aufgelöst.
===================================================================================================================================================================================================================
 Paket                                                       Arch                                       Version                                             Paketquelle                                      Größe
===================================================================================================================================================================================================================
Aktualisieren:
 dnf-plugins-core                                            noarch                                     0.1.12-1.fc22                                       @commandline                                      34 k
 glib2                                                       x86_64                                     2.44.1-2.fc22                                       @commandline                                     2.2 M
 icedtea-web                                                 x86_64                                     1.6.1-2.fc22                                        @commandline                                     1.5 M
 plasma-desktop                                              x86_64                                     5.4.1-5.fc22                                        @commandline                                     5.7 M
 python-dnf-plugins-core                                     noarch                                     0.1.12-1.fc22                                       @commandline                                      83 k 
 sqlite                                                      x86_64                                     3.8.11.1-1.fc22                                     @commandline                                     468 k 
                                                                                                                                                                                                                   
Transaktionsübersicht                                                                                                                                                                                              
===================================================================================================================================================================================================================
Aktualisieren  6 Packages                                                                                                                                                                                          
                                                                                                                                                                                                                   
Gesamtgröße: 10 M                                                                                                                                                                                                  
Ist dies in Ordnung? [j/N] :y                                                                                                                                                                                      
Pakete werden heruntergeladen:
Comment 4 Harald Reindl 2015-09-22 13:45:06 EDT
boah that is just a joke hopefully - localupdates have worked with YUM virtually ever and now that?

[root@srv-rhsoft:/downloads]$ ls
insgesamt 121M
-rw-r----- 1 harry verwaltung  260K 2015-09-22 19:09 dnf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   87K 2015-09-22 19:09 dnf-conf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   34K 2015-09-22 19:08 dnf-plugins-core-0.1.12-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   79K 2015-09-22 19:09 dnf-yum-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   34K 2015-09-22 19:08 fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   73M 2015-09-22 19:30 firefox-41.0-4.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   91K 2015-09-22 19:33 hawkey-0.6.1-1.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   20M 2015-09-22 19:15 kernel-core-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung  9,6M 2015-09-22 19:13 kernel-devel-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung 1009K 2015-09-22 19:10 kernel-headers-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   18M 2015-09-22 19:16 kernel-modules-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   84K 2015-09-22 19:33 python-dnf-plugins-core-0.1.12-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   76K 2015-09-22 19:33 python-hawkey-0.6.1-1.fc22.x86_64.rpm

[root@srv-rhsoft:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:04:01 ago on Tue Sep 22 19:31:24 2015.
Fehler: nothing provides python2-dnf = 1.1.2-2.fc22 needed by dnf-1.1.2-2.fc22.noarch.
nothing provides python2-dnf >= 1.1.2 needed by python-dnf-plugins-core-0.1.12-2.fc22.noarch.
nothing provides python2-dnf >= 1.1.2 needed by python-dnf-plugins-core-0.1.12-2.fc22.noarch.
nothing provides python2-dnf = 1.1.2-2.fc22 needed by dnf-1.1.2-2.fc22.noarch.
package python-dnf-1.1.1-2.fc22.noarch requires dnf-conf = 1.1.1-2.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

[root@srv-rhsoft:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:04:19 ago on Tue Sep 22 19:31:24 2015.
Fehler: nothing provides python2-dnf = 1.1.2-2.fc22 needed by dnf-1.1.2-2.fc22.noarch.
nothing provides python2-dnf >= 1.1.2 needed by python-dnf-plugins-core-0.1.12-2.fc22.noarch.
nothing provides python2-dnf >= 1.1.2 needed by python-dnf-plugins-core-0.1.12-2.fc22.noarch.
nothing provides python2-dnf = 1.1.2-2.fc22 needed by dnf-1.1.2-2.fc22.noarch.
package python-dnf-1.1.1-2.fc22.noarch requires dnf-conf = 1.1.1-2.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

[root@srv-rhsoft:/downloads]$ ls
insgesamt 122M
-rw-r----- 1 harry verwaltung  260K 2015-09-22 19:09 dnf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   87K 2015-09-22 19:09 dnf-conf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   34K 2015-09-22 19:08 dnf-plugins-core-0.1.12-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   79K 2015-09-22 19:09 dnf-yum-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   34K 2015-09-22 19:08 fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   73M 2015-09-22 19:30 firefox-41.0-4.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   91K 2015-09-22 19:33 hawkey-0.6.1-1.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   20M 2015-09-22 19:15 kernel-core-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung  9,6M 2015-09-22 19:13 kernel-devel-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung 1009K 2015-09-22 19:10 kernel-headers-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   18M 2015-09-22 19:16 kernel-modules-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung  445K 2015-09-22 19:39 python2-dnf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   84K 2015-09-22 19:33 python-dnf-plugins-core-0.1.12-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   76K 2015-09-22 19:33 python-hawkey-0.6.1-1.fc22.x86_64.rpm
[root@srv-rhsoft:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:09:13 ago on Tue Sep 22 19:31:24 2015.
Paket python2-dnf ist nicht installiert, es kann nicht aktualisiert werden.
Fehler: package python-dnf-1.1.1-2.fc22.noarch requires dnf-conf = 1.1.1-2.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

[root@srv-rhsoft:/downloads]$ ls
insgesamt 122M
-rw-r----- 1 harry verwaltung  260K 2015-09-22 19:09 dnf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   87K 2015-09-22 19:09 dnf-conf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   34K 2015-09-22 19:08 dnf-plugins-core-0.1.12-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   79K 2015-09-22 19:09 dnf-yum-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   34K 2015-09-22 19:08 fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   73M 2015-09-22 19:30 firefox-41.0-4.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   91K 2015-09-22 19:33 hawkey-0.6.1-1.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   20M 2015-09-22 19:15 kernel-core-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung  9,6M 2015-09-22 19:13 kernel-devel-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung 1009K 2015-09-22 19:10 kernel-headers-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung   18M 2015-09-22 19:16 kernel-modules-4.1.8-200.fc22.x86_64.rpm
-rw-r----- 1 harry verwaltung  445K 2015-09-22 19:39 python2-dnf-1.1.2-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   84K 2015-09-22 19:33 python-dnf-plugins-core-0.1.12-2.fc22.noarch.rpm
-rw-r----- 1 harry verwaltung   76K 2015-09-22 19:33 python-hawkey-0.6.1-1.fc22.x86_64.rpm
[root@srv-rhsoft:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:09:13 ago on Tue Sep 22 19:31:24 2015.
Paket python2-dnf ist nicht installiert, es kann nicht aktualisiert werden.
Fehler: package python-dnf-1.1.1-2.fc22.noarch requires dnf-conf = 1.1.1-2.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

[root@srv-rhsoft:/downloads]$ rpm -Uvh python2-dnf-1.1.2-2.fc22.noarch.rpm
Fehler: Fehlgeschlagende Abhängigkeiten:
        dnf-conf = 1.1.2-2.fc22 wird benötigt von python2-dnf-1.1.2-2.fc22.noarch
        python-hawkey >= 0.6.1 wird benötigt von python2-dnf-1.1.2-2.fc22.noarch
[root@srv-rhsoft:/downloads]$ rpm -Uvh *.rpm
Fehler: Fehlgeschlagende Abhängigkeiten:
        dnf-conf = 1.1.1-2.fc22 wird benötigt von (installiert) python-dnf-1.1.1-2.fc22.noarch
[root@srv-rhsoft:/downloads]$ 


___________________________________________________________________


WTF

[root@srv-rhsoft:/downloads]$ rpm -Uvh --force --nodeps dnf*.rpm hawkey*.rpm python*.rpm
Vorbereiten...                        ################################# [100%]
Aktualisierung/ Installation...

   1:hawkey-0.6.1-1.fc22              ################################# [  7%]
   2:python-hawkey-0.6.1-1.fc22       ################################# [ 13%]
   3:dnf-conf-1.1.2-2.fc22            ################################# [ 20%]
   4:python2-dnf-1.1.2-2.fc22         ################################# [ 27%]
   5:dnf-1.1.2-2.fc22                 ################################# [ 33%]
   6:python-dnf-plugins-core-0.1.12-2.################################# [ 40%]
   7:dnf-plugins-core-0.1.12-2.fc22   ################################# [ 47%]
   8:dnf-yum-1.1.2-2.fc22             ################################# [ 53%]
Aufräumen/ Entfernen...
   9:dnf-yum-1.1.1-2.fc22             ################################# [ 60%]
  10:dnf-plugins-core-0.1.12-1.fc22   ################################# [ 67%]
  11:python-dnf-plugins-core-0.1.12-1.################################# [ 73%]
  12:python-hawkey-0.6.0-1.fc22       ################################# [ 80%]
  13:hawkey-0.6.0-1.fc22              ################################# [ 87%]
  14:dnf-1.1.1-2.fc22                 ################################# [ 93%]
  15:dnf-conf-1.1.1-2.fc22            ################################# [100%]
[root@srv-rhsoft:/downloads]$ package-cleanup --problems

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.


Geladene Plugins: etckeeper
Package python-dnf-1.1.1-2.fc22.noarch hat fehlende Abhängigkeiten zu dnf-conf = ('0', '1.1.1', '2.fc22')
[root@srv-rhsoft:/downloads]$ rpm -e python-dnf-1.1.1-2.fc22.noarch
[root@srv-rhsoft:/downloads]$ package-cleanup --problems

Yum-utils package has been deprecated, use dnf instead.
See 'man yum2dnf' for more information.


Geladene Plugins: etckeeper
No Problems Found
Comment 5 Harald Reindl 2015-09-22 13:51:12 EDT
DNF just don't work reliebale and still stands for "did not finish" - thank you for replacing a working package management with it!

[root@rh:/downloads]$ rpm -Uvh --force --nodeps dnf*.rpm hawkey*.rpm python*.rpm
Vorbereiten...                        ################################# [100%]
Aktualisierung/ Installation...

   1:hawkey-0.6.1-1.fc22              ################################# [  7%]
   2:python-hawkey-0.6.1-1.fc22       ################################# [ 13%]
   3:dnf-conf-1.1.2-2.fc22            ################################# [ 20%]
   4:python2-dnf-1.1.2-2.fc22         ################################# [ 27%]
   5:dnf-1.1.2-2.fc22                 ################################# [ 33%]
   6:python-dnf-plugins-core-0.1.12-2.################################# [ 40%]
   7:dnf-plugins-core-0.1.12-2.fc22   ################################# [ 47%]
   8:dnf-yum-1.1.2-2.fc22             ################################# [ 53%]
Aufräumen/ Entfernen...
   9:dnf-yum-1.1.1-2.fc22             ################################# [ 60%]
  10:dnf-plugins-core-0.1.12-1.fc22   ################################# [ 67%]
  11:python-dnf-plugins-core-0.1.12-1.################################# [ 73%]
  12:python-hawkey-0.6.0-1.fc22       ################################# [ 80%]
  13:hawkey-0.6.0-1.fc22              ################################# [ 87%]
  14:dnf-1.1.1-2.fc22                 ################################# [ 93%]
  15:dnf-conf-1.1.1-2.fc22            ################################# [100%]
[root@rh:/downloads]$ rpm -e python-dnf-1.1.1-2.fc22.noarch
[root@rh:/downloads]$ dnf update *.rpm
rhsoft-repo with generic rpms                                                                                                                                                       17 kB/s | 4.4 kB     00:00    
rhsoft-repo for fedora                                                                                                                                                             561 kB/s | 174 kB     00:00    
Last metadata expiration check performed 0:00:08 ago on Tue Sep 22 19:47:56 2015.
Das Paket dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-conf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-yum ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python2-dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Fehler: package fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch is not installable.
package firefox-41.0-4.fc22.x86_64 is not installable.
package kernel-core-4.1.8-200.fc22.x86_64 is not installable.
package kernel-devel-4.1.8-200.fc22.x86_64 is not installable.
package kernel-headers-4.1.8-200.fc22.x86_64 is not installable.
package kernel-modules-4.1.8-200.fc22.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
[root@rh:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:01:50 ago on Tue Sep 22 19:47:56 2015.
Das Paket dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-conf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-yum ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python2-dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Abhängigkeiten sind aufgelöst.
===================================================================================================================================================================================================================
 Paket                                              Arch                                    Version                                                            Paketquelle                                   Größe
===================================================================================================================================================================================================================
Installieren:
 kernel-core                                        x86_64                                  4.1.8-200.fc22                                                     @commandline                                   19 M
 kernel-devel                                       x86_64                                  4.1.8-200.fc22                                                     @commandline                                  9.5 M
 kernel-modules                                     x86_64                                  4.1.8-200.fc22                                                     @commandline                                   18 M
Aktualisieren:
 fedora-easy-karma                                  noarch                                  0-0.26.20150921gitc932687a.fc22                                    @commandline                                   33 k
 firefox                                            x86_64                                  41.0-4.fc22                                                        @commandline                                   72 M
 kernel-headers                                     x86_64                                  4.1.8-200.fc22                                                     @commandline                                  1.0 M

Transaktionsübersicht
===================================================================================================================================================================================================================
Installieren   3 Packages
Aktualisieren  3 Packages

Gesamtgröße: 120 M
Ist dies in Ordnung? [j/N] :y
Pakete werden heruntergeladen:
Transaktionsüberprüfung wird ausgeführt
Transaktionsprüfung war erfolgreich.
Transaktion wird getestet
Transaktionstest war erfolgreich.
Transaktion wird ausgeführt
  Installieren     : kernel-core-4.1.8-200.fc22.x86_64                                                                                                                                                         1/9 
  Installieren     : kernel-modules-4.1.8-200.fc22.x86_64                                                                                                                                                      2/9 
  Aktualisieren    : kernel-headers-4.1.8-200.fc22.x86_64                                                                                                                                                      3/9 
  Aktualisieren    : firefox-41.0-4.fc22.x86_64                                                                                                                                                                4/9 
  Aktualisieren    : fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch                                                                                                                                  5/9 
  Installieren     : kernel-devel-4.1.8-200.fc22.x86_64                                                                                                                                                        6/9 
  Aufräumen        : kernel-headers-4.1.7-200.fc22.x86_64                                                                                                                                                      7/9 
  Aufräumen        : fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22.noarch                                                                                                                                  8/9 
  Aufräumen        : firefox-41.0-3.fc22.x86_64                                                                                                                                                                9/9 
  Überprüfung läuft: kernel-core-4.1.8-200.fc22.x86_64                                                                                                                                                         1/9 
  Überprüfung läuft: kernel-devel-4.1.8-200.fc22.x86_64                                                                                                                                                        2/9 
  Überprüfung läuft: kernel-modules-4.1.8-200.fc22.x86_64                                                                                                                                                      3/9 
  Überprüfung läuft: fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch                                                                                                                                  4/9 
  Überprüfung läuft: firefox-41.0-4.fc22.x86_64                                                                                                                                                                5/9 
  Überprüfung läuft: kernel-headers-4.1.8-200.fc22.x86_64                                                                                                                                                      6/9 
  Überprüfung läuft: fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22.noarch                                                                                                                                  7/9 
  Überprüfung läuft: firefox-41.0-3.fc22.x86_64                                                                                                                                                                8/9 
  Überprüfung läuft: kernel-headers-4.1.7-200.fc22.x86_64                                                                                                                                                      9/9 

Installiert:
  kernel-core.x86_64 4.1.8-200.fc22                                   kernel-devel.x86_64 4.1.8-200.fc22                                   kernel-modules.x86_64 4.1.8-200.fc22                                  

Aktualisiert:
  fedora-easy-karma.noarch 0-0.26.20150921gitc932687a.fc22                              firefox.x86_64 41.0-4.fc22                              kernel-headers.x86_64 4.1.8-200.fc22                             

Komplett!
Comment 6 Harald Reindl 2015-09-22 14:10:27 EDT
LAUGHABLE that you developers don't face that issue - are you using yum-deprecated all the time?

[root@testserver:/data]$ rpm -Uvh --force --nodeps dnf*.rpm hawkey*.rpm python*.rpm
Vorbereiten...                        ################################# [100%]
Aktualisierung/ Installation...

   1:hawkey-0.6.1-1.fc22              ################################# [  7%]
   2:python-hawkey-0.6.1-1.fc22       ################################# [ 13%]
   3:dnf-conf-1.1.2-2.fc22            ################################# [ 20%]
   4:python2-dnf-1.1.2-2.fc22         ################################# [ 27%]
   5:dnf-1.1.2-2.fc22                 ################################# [ 33%]
   6:python-dnf-plugins-core-0.1.12-2.################################# [ 40%]
   7:dnf-plugins-core-0.1.12-2.fc22   ################################# [ 47%]
   8:dnf-yum-1.1.2-2.fc22             ################################# [ 53%]
Aufräumen/ Entfernen...
   9:dnf-yum-1.1.1-2.fc22             ################################# [ 60%]
  10:dnf-plugins-core-0.1.11-1.fc22   ################################# [ 67%]
  11:python-dnf-plugins-core-0.1.11-1.################################# [ 73%]
  12:python-hawkey-0.6.0-1.fc22       ################################# [ 80%]
  13:hawkey-0.6.0-1.fc22              ################################# [ 87%]
  14:dnf-1.1.1-2.fc22                 ################################# [ 93%]
  15:dnf-conf-1.1.1-2.fc22            ################################# [100%]
[root@testserver:/data]$ rpm -e python-dnf-1.1.1-2.fc22.noarch
[root@testserver:/data]$ dnf update *.rpm
RPM Fusion for Fedora 22 - Nonfree - Test Updates                                                                                                                                  4.3 kB/s | 399  B     00:00     
rhsoft-repo with generic rpms                                                                                                                                                      9.8 kB/s | 4.4 kB     00:00     
RPM Fusion for Fedora 22 - Free - Test Updates                                                                                                                                     2.6 kB/s | 399  B     00:00     
Fedora 22 - x86_64 - Test Updates                                                                                                                                                  809 kB/s | 5.0 MB     00:06     
Fedora 22 - x86_64                                                                                                                                                                 2.1 MB/s |  41 MB     00:19     
RPM Fusion for Fedora 22 - Free - Updates                                                                                                                                          706 kB/s |  73 kB     00:00     
RPM Fusion for Fedora 22 - Nonfree - Updates                                                                                                                                       459 kB/s |  28 kB     00:00     
rhsoft-repo for fedora                                                                                                                                                             325 kB/s | 174 kB     00:00     
Fedora 22 - x86_64 - Updates                                                                                                                                                       2.3 MB/s |  14 MB     00:06     
rhsoft-repo with generic rpms                                                                                                                                                      539  B/s | 257  B     00:00     
Last metadata expiration check performed 0:00:09 ago on Tue Sep 22 20:08:40 2015.                                                                                                                                  
Das Paket dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.                                                                                                                 
Das Paket dnf-conf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-yum ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python2-dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Fehler: package fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch is not installable.
package hwdata-0.282-1.fc22.noarch is not installable.
package kernel-core-4.1.8-200.fc22.x86_64 is not installable.
package kernel-headers-4.1.8-200.fc22.x86_64 is not installable.
package man-db-2.7.1-9.fc22.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
[root@testserver:/data]$ dnf update *.rpm
Last metadata expiration check performed 0:00:33 ago on Tue Sep 22 20:08:40 2015.
Das Paket dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-conf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket dnf-yum ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python2-dnf ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-dnf-plugins-core ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Das Paket python-hawkey ist bereits in einer höheren Version installiert, es kann nicht aktualisiert werden.
Abhängigkeiten sind aufgelöst.
===================================================================================================================================================================================================================
 Paket                                              Arch                                    Version                                                            Paketquelle                                   Größe
===================================================================================================================================================================================================================
Installieren:
 kernel-core                                        x86_64                                  4.1.8-200.fc22                                                     @commandline                                   19 M
Aktualisieren:
 fedora-easy-karma                                  noarch                                  0-0.26.20150921gitc932687a.fc22                                    @commandline                                   33 k
 hwdata                                             noarch                                  0.282-1.fc22                                                       @commandline                                  1.4 M
 kernel-headers                                     x86_64                                  4.1.8-200.fc22                                                     @commandline                                  1.0 M
 man-db                                             x86_64                                  2.7.1-9.fc22                                                       @commandline                                  822 k

Transaktionsübersicht
===================================================================================================================================================================================================================
Installieren   1 Package
Aktualisieren  4 Packages

Gesamtgröße: 23 M
Ist dies in Ordnung? [j/N] :y
Pakete werden heruntergeladen:
Transaktionsüberprüfung wird ausgeführt
Transaktionsprüfung war erfolgreich.
Transaktion wird getestet
Transaktionstest war erfolgreich.
Transaktion wird ausgeführt
  Aktualisieren    : man-db-2.7.1-9.fc22.x86_64                                                                                                                                                                1/9 
  Aktualisieren    : kernel-headers-4.1.8-200.fc22.x86_64                                                                                                                                                      2/9 
  Aktualisieren    : hwdata-0.282-1.fc22.noarch                                                                                                                                                                3/9 
  Aktualisieren    : fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch                                                                                                                                  4/9 
  Installieren     : kernel-core-4.1.8-200.fc22.x86_64                                                                                                                                                         5/9 
  Aufräumen        : kernel-headers-4.1.7-200.fc22.x86_64                                                                                                                                                      6/9 
  Aufräumen        : hwdata-0.281-1.fc22.noarch                                                                                                                                                                7/9 
  Aufräumen        : fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22.noarch                                                                                                                                  8/9 
  Aufräumen        : man-db-2.7.1-8.fc22.x86_64                                                                                                                                                                9/9 
  Überprüfung läuft: kernel-core-4.1.8-200.fc22.x86_64                                                                                                                                                         1/9 
  Überprüfung läuft: fedora-easy-karma-0-0.26.20150921gitc932687a.fc22.noarch                                                                                                                                  2/9 
  Überprüfung läuft: hwdata-0.282-1.fc22.noarch                                                                                                                                                                3/9 
  Überprüfung läuft: kernel-headers-4.1.8-200.fc22.x86_64                                                                                                                                                      4/9 
  Überprüfung läuft: man-db-2.7.1-9.fc22.x86_64                                                                                                                                                                5/9 
  Überprüfung läuft: fedora-easy-karma-0-0.24.20150508gitc8e437c0.fc22.noarch                                                                                                                                  6/9 
  Überprüfung läuft: man-db-2.7.1-8.fc22.x86_64                                                                                                                                                                7/9 
  Überprüfung läuft: kernel-headers-4.1.7-200.fc22.x86_64                                                                                                                                                      8/9 
  Überprüfung läuft: hwdata-0.281-1.fc22.noarch                                                                                                                                                                9/9
Comment 7 Honza Silhan 2015-09-30 04:38:30 EDT
Do [1], please. The issue that DNF behaves non deterministic when it has all metadata downloaded is wrong and will be tracked in this report.

I didn't get what you report in your other comments. Can you tell us the short summory what it does and what you expect, please?

tip: post outputs of commands when LANG=en_US.UTF-8 is set.

[1] https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-resolution-problem
Comment 8 Harald Reindl 2015-09-30 04:49:48 EDT
https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-resolution-problem would not be needed if DNF would behave somehow similar to YUM and clearly show *what* it thinks is wrong with dependencies up to libnames and libsonames

with DNF it's completly impossible to just look at the output and find out which package is repsonsible to maybe consider removing this one completly from the system

all that "only shiny output for noobs to not overwheelm them" is harmful, they noob users typically don't use DNF/YUM in the terminal and the advanced users now need to debug and dig for infos which where just visible many years and frankly *that informations* leaded that i was ablke to understand how all the deps and packages work together - starting today with Linux would mean i never reach the level of knowledge i have today

JUST GIVE OUT THE DEPENDECY PROBLEMS ON THE TERMINAL

"I didn't get what you report in your other comments" -> well, i didn't get what DNF is trying to report - there is no way to know if it's just another random and wrong "i can't solve deps" or a real problem nor what dependency - and please don't come with the *way too large* logs where you need to find a needle in the haystack

another problem: that logs and the size of /var/cache/dnf are as big as complete server setups including userdata here........
Comment 9 Harald Reindl 2015-11-03 10:09:52 EST
the outpout i see most often from dnf is "is not installable" while it is just NOT true, sometimes a second try suceeds, in cases like below it's just too stupid that the pretended "dhcp-compat-12:4.3.3-6.fc23.x86_64 is not installable" is the root-cause for "nothing provides dhcp-common = 12:4.3.3-6.fc23"
_________________________________________________________________________

--> Starting dependency resolution
--> Finished dependency resolution
Error: nothing provides dhcp-common = 12:4.3.3-6.fc23 needed by dhcp-client-12:4.3.3-6.fc23.x86_64.
package dhcp-common-12:4.3.3-6.fc23.noarch is not installable.
package dhcp-compat-12:4.3.3-6.fc23.x86_64 is not installable.
package dhcp-libs-12:4.3.3-6.fc23.x86_64 is not installable.
package dhcp-relay-12:4.3.3-6.fc23.x86_64 is not installable.
package dhcp-server-12:4.3.3-6.fc23.x86_64 is not installable.
package grep-2.22-1.fc23.x86_64 is not installable.
package nss-3.20.1-1.0.fc23.x86_64 is not installable.
package nss-sysinit-3.20.1-1.0.fc23.x86_64 is not installable.
package nss-tools-3.20.1-1.0.fc23.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
_________________________________________________________________________

[root@rh:/downloads]$ yum-deprecated update *.rpm
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.
Loaded plugins: etckeeper
Examining dbus-1.10.2-1.fc23.x86_64.rpm: 1:dbus-1.10.2-1.fc23.x86_64
Marking dbus-1.10.2-1.fc23.x86_64.rpm as an update to 1:dbus-1.10.0-1.fc23.x86_64
Examining dbus-libs-1.10.2-1.fc23.x86_64.rpm: 1:dbus-libs-1.10.2-1.fc23.x86_64
Marking dbus-libs-1.10.2-1.fc23.x86_64.rpm as an update to 1:dbus-libs-1.10.0-1.fc23.x86_64
Examining dbus-x11-1.10.2-1.fc23.x86_64.rpm: 1:dbus-x11-1.10.2-1.fc23.x86_64
Marking dbus-x11-1.10.2-1.fc23.x86_64.rpm as an update to 1:dbus-x11-1.10.0-1.fc23.x86_64
Examining dhcp-client-4.3.3-6.fc23.x86_64.rpm: 12:dhcp-client-4.3.3-6.fc23.x86_64
Marking dhcp-client-4.3.3-6.fc23.x86_64.rpm as an update to 12:dhcp-client-4.3.3-5.fc23.x86_64
Examining dhcp-common-4.3.3-6.fc23.noarch.rpm: 12:dhcp-common-4.3.3-6.fc23.noarch
Marking dhcp-common-4.3.3-6.fc23.noarch.rpm as an update to 12:dhcp-common-4.3.3-5.fc23.noarch
Examining dhcp-compat-4.3.3-6.fc23.x86_64.rpm: 12:dhcp-compat-4.3.3-6.fc23.x86_64
Marking dhcp-compat-4.3.3-6.fc23.x86_64.rpm as an update to 12:dhcp-compat-4.3.3-5.fc23.x86_64
Examining dhcp-libs-4.3.3-6.fc23.x86_64.rpm: 12:dhcp-libs-4.3.3-6.fc23.x86_64
Marking dhcp-libs-4.3.3-6.fc23.x86_64.rpm as an update to 12:dhcp-libs-4.3.3-5.fc23.x86_64
Examining dhcp-relay-4.3.3-6.fc23.x86_64.rpm: 12:dhcp-relay-4.3.3-6.fc23.x86_64
Marking dhcp-relay-4.3.3-6.fc23.x86_64.rpm as an update to 12:dhcp-relay-4.3.3-5.fc23.x86_64
Examining dhcp-server-4.3.3-6.fc23.x86_64.rpm: 12:dhcp-server-4.3.3-6.fc23.x86_64
Marking dhcp-server-4.3.3-6.fc23.x86_64.rpm as an update to 12:dhcp-server-4.3.3-5.fc23.x86_64
Examining grep-2.22-1.fc23.x86_64.rpm: grep-2.22-1.fc23.x86_64
Marking grep-2.22-1.fc23.x86_64.rpm as an update to grep-2.21-7.fc23.x86_64
Examining nss-3.20.1-1.0.fc23.x86_64.rpm: nss-3.20.1-1.0.fc23.x86_64
Marking nss-3.20.1-1.0.fc23.x86_64.rpm as an update to nss-3.20.0-1.3.fc23.x86_64
Examining nss-sysinit-3.20.1-1.0.fc23.x86_64.rpm: nss-sysinit-3.20.1-1.0.fc23.x86_64
Marking nss-sysinit-3.20.1-1.0.fc23.x86_64.rpm as an update to nss-sysinit-3.20.0-1.3.fc23.x86_64
Examining nss-tools-3.20.1-1.0.fc23.x86_64.rpm: nss-tools-3.20.1-1.0.fc23.x86_64
Marking nss-tools-3.20.1-1.0.fc23.x86_64.rpm as an update to nss-tools-3.20.0-1.3.fc23.x86_64
Resolving Dependencies
--> Running transaction check
---> Package dbus.x86_64 1:1.10.0-1.fc23 will be updated
---> Package dbus.x86_64 1:1.10.2-1.fc23 will be an update
---> Package dbus-libs.x86_64 1:1.10.0-1.fc23 will be updated
---> Package dbus-libs.x86_64 1:1.10.2-1.fc23 will be an update
---> Package dbus-x11.x86_64 1:1.10.0-1.fc23 will be updated
---> Package dbus-x11.x86_64 1:1.10.2-1.fc23 will be an update
---> Package dhcp-client.x86_64 12:4.3.3-5.fc23 will be updated
---> Package dhcp-client.x86_64 12:4.3.3-6.fc23 will be an update
---> Package dhcp-common.noarch 12:4.3.3-5.fc23 will be updated
---> Package dhcp-common.noarch 12:4.3.3-6.fc23 will be an update
---> Package dhcp-compat.x86_64 12:4.3.3-5.fc23 will be updated
---> Package dhcp-compat.x86_64 12:4.3.3-6.fc23 will be an update
---> Package dhcp-libs.x86_64 12:4.3.3-5.fc23 will be updated
---> Package dhcp-libs.x86_64 12:4.3.3-6.fc23 will be an update
---> Package dhcp-relay.x86_64 12:4.3.3-5.fc23 will be updated
---> Package dhcp-relay.x86_64 12:4.3.3-6.fc23 will be an update
---> Package dhcp-server.x86_64 12:4.3.3-5.fc23 will be updated
---> Package dhcp-server.x86_64 12:4.3.3-6.fc23 will be an update
---> Package grep.x86_64 0:2.21-7.fc23 will be updated
---> Package grep.x86_64 0:2.22-1.fc23 will be an update
---> Package nss.x86_64 0:3.20.0-1.3.fc23 will be updated
---> Package nss.x86_64 0:3.20.1-1.0.fc23 will be an update
---> Package nss-sysinit.x86_64 0:3.20.0-1.3.fc23 will be updated
---> Package nss-sysinit.x86_64 0:3.20.1-1.0.fc23 will be an update
---> Package nss-tools.x86_64 0:3.20.0-1.3.fc23 will be updated
---> Package nss-tools.x86_64 0:3.20.1-1.0.fc23 will be an update
--> Finished Dependency Resolution
Comment 10 Honza Silhan 2015-11-09 11:23:13 EST
(In reply to Jan Silhan from comment #7)
> Do [1], please.
> 
> [1]
> https://github.com/rpm-software-management/dnf/wiki/Bug-Reporting#dependency-
> resolution-problem

^ attach the debugdata, please. Then we could know what you had installed and what are the requirements of packages you want to install.

(In reply to Harald Reindl from comment #8)
> JUST GIVE OUT THE DEPENDECY PROBLEMS ON THE TERMINAL

legit, tracked in the bug 1148627.
Comment 11 Harald Reindl 2015-11-09 11:25:57 EST
do you *really* explain me that this issue is not reproducable easily?

[harry@rh:~]$ rpm -qa | grep dnf
dnf-yum-1.1.3-1.fc23.noarch
dnf-plugins-core-0.1.13-1.fc23.noarch
python3-dnf-1.1.3-1.fc23.noarch
dnf-1.1.3-1.fc23.noarch
python3-dnf-plugins-core-0.1.13-1.fc23.noarch
etckeeper-dnf-1.18.2-1.fc23.noarch
dnf-conf-1.1.3-1.fc23.noarch
Comment 12 Harald Reindl 2015-11-13 06:30 EST
Created attachment 1093593 [details]
here are your debugdata

bo idea why you just can't download the packages from koji at your own and type "dnf update *.rpm" in a console, in doubt just install the packages regulary and then "dnf downgrade dhcp\*" and you have all you need to reproduce

https://koji.fedoraproject.org/koji/buildinfo?buildID=695813

-rw-r----- 1 harry verwaltung 299K 2015-11-13 12:21 dhcp-client-4.3.3-6.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 193K 2015-11-13 12:22 dhcp-common-4.3.3-6.fc23.noarch.rpm
-rw-r----- 1 harry verwaltung 137K 2015-11-13 12:21 dhcp-libs-4.3.3-6.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 512K 2015-11-13 12:21 dhcp-server-4.3.3-6.fc23.x86_64.rpm

[root@srv-rhsoft:/downloads]$ rpm -q libsolv hawkey dnf
libsolv-0.6.14-2.fc23.x86_64
hawkey-0.6.2-1.fc23.x86_64
dnf-1.1.3-1.fc23.noarch
Comment 13 Harald Reindl 2015-11-18 07:17:46 EST
pure nonsense - libuuid = 2.27.1-2.fc23 is provided by "libuuid-2.27.1-2.fc23.x86_64.rpm" which is part of *

libsolv-0.6.14-2.fc23.x86_64
hawkey-0.6.2-1.fc23.x86_64
dnf-1.1.4-1.fc23.noarch

[root@rh:/downloads]$ dnf update *.rpm
Last metadata expiration check performed 0:00:50 ago on Wed Nov 18 13:13:35 2015.
Package libblkid-devel not installed, cannot update it.
Package libfdisk-devel not installed, cannot update it.
Package libmount-devel not installed, cannot update it.
Package libpng-static not installed, cannot update it.
Package libpng-tools not installed, cannot update it.
Package libsmartcols-devel not installed, cannot update it.
Package libuuid-devel not installed, cannot update it.
Package python3-libmount not installed, cannot update it.
Package uuidd not installed, cannot update it.
Error: nothing provides libuuid = 2.27.1-2.fc23 needed by libblkid-2.27.1-2.fc23.x86_64.
___________________________________________________

yum-deprecated is *so much* smarter than dnf!

Resolving Dependencies
--> Running transaction check
---> Package hwdata.noarch 0:0.283-1.fc23 will be updated
---> Package hwdata.noarch 0:0.284-1.fc23 will be an update
---> Package libblkid.x86_64 0:2.27.1-1.fc23 will be updated
---> Package libblkid.x86_64 0:2.27.1-2.fc23 will be an update
---> Package libfdisk.x86_64 0:2.27.1-1.fc23 will be updated
---> Package libfdisk.x86_64 0:2.27.1-2.fc23 will be an update
---> Package libmount.x86_64 0:2.27.1-1.fc23 will be updated
---> Package libmount.x86_64 0:2.27.1-2.fc23 will be an update
---> Package libpng.x86_64 2:1.6.17-2.fc23 will be updated
---> Package libpng.x86_64 2:1.6.17-3.fc23 will be an update
---> Package libsmartcols.x86_64 0:2.27.1-1.fc23 will be updated
---> Package libsmartcols.x86_64 0:2.27.1-2.fc23 will be an update
---> Package libuuid.x86_64 0:2.27.1-1.fc23 will be updated
---> Package libuuid.x86_64 0:2.27.1-2.fc23 will be an update
---> Package util-linux.x86_64 0:2.27.1-1.fc23 will be updated
---> Package util-linux.x86_64 0:2.27.1-2.fc23 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Dependencies Resolved
___________________________________________________

[root@rh:/downloads]$ ls
insgesamt 5,2M
-rw-r----- 1 harry verwaltung 1,4M 2015-11-18 13:12 hwdata-0.284-1.fc23.noarch.rpm
-rw-r----- 1 harry verwaltung 179K 2015-11-18 13:12 libblkid-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  75K 2015-11-18 13:13 libblkid-devel-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 220K 2015-11-18 13:12 libfdisk-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  75K 2015-11-18 13:13 libfdisk-devel-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 196K 2015-11-18 13:12 libmount-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  76K 2015-11-18 13:13 libmount-devel-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 118K 2015-11-18 13:12 libpng-1.6.17-3.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 121K 2015-11-18 13:12 libpng-static-1.6.17-3.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  42K 2015-11-18 13:12 libpng-tools-1.6.17-3.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 138K 2015-11-18 13:12 libsmartcols-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  71K 2015-11-18 13:13 libsmartcols-devel-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  79K 2015-11-18 13:12 libuuid-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  86K 2015-11-18 13:13 libuuid-devel-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 105K 2015-11-18 13:12 python3-libmount-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 2,2M 2015-11-18 13:12 util-linux-2.27.1-2.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  93K 2015-11-18 13:12 uuidd-2.27.1-2.fc23.x86_64.rpm
Comment 14 Harald Reindl 2016-01-17 17:19:53 EST
it's also broken for normal operations

===================================================================================================================================================================================================================
 Package                                             Arch                                        Version                                                Repository                                            Size
===================================================================================================================================================================================================================
Skipping packages with broken dependencies:
 kernel-core                                         x86_64                                      4.3.3-301.fc23                                         updates-testing                                       20 M
 kernel-devel                                        x86_64                                      4.3.3-301.fc23                                         updates-testing                                       10 M
 kernel-modules                                      x86_64                                      4.3.3-301.fc23                                         updates-testing                                       18 M

Transaction Summary
===================================================================================================================================================================================================================
Skip  3 Packages

Nothing to do.
Etckeeper plugin: post transaction commit
Completion plugin: Generating completion cache...
Complete!
__________________________________________________________

yum-deprecated:

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                             Arch                                        Version                                                Repository                                            Size
===================================================================================================================================================================================================================
Installing:
 kernel-core                                         x86_64                                      4.3.3-301.fc23                                         updates-testing                                       20 M
 kernel-devel                                        x86_64                                      4.3.3-301.fc23                                         updates-testing                                       10 M
 kernel-modules                                      x86_64                                      4.3.3-301.fc23                                         updates-testing                                       18 M

Transaction Summary
===================================================================================================================================================================================================================
Install  3 Packages

Total download size: 48 M
Installed size: 106 M
Is this ok [y/d/N]: y
Comment 15 Greg` 2016-01-22 05:24:44 EST
what " libsolv " version have you got?  i did have problems like these but once downgraded libsolv from 0.6.15 to 0.6.14 in F23 it now works as expected
Comment 16 Greg` 2016-01-22 05:28:36 EST
perhaps the libsolv package maintainers could package 0.6.17
Comment 17 Harald Reindl 2016-01-22 05:32:53 EST
just look at https://bugzilla.redhat.com/show_bug.cgi?id=1263888#c12 with no single feedback from the developers - they would NOT need any debug data, just try it out with random packages containing sub-package dependencies

"non deterministically" is plain wrong
IT IS deterministically with local packages

the kernel above was a ordinary "dnf upgrade"

harry@srv-rhsoft:~]$ rpm -q libsolv
libsolv-0.6.15-1.fc23.x86_64
Comment 18 Greg` 2016-01-22 23:36:16 EST
as i suggested, Downgrade YOUR LIBSOLV to 0.6.14. cause 0.6.15 is Buggy
Comment 19 Harald Reindl 2016-01-23 05:47:51 EST
comment 14 was only a side note - you got it?

please realize that this *only* would solve regular kernel updates, wehn you look at bodhi i typically download kernels from koji and then we are at the *real* topic of this bugreport that DNF don't work and never worked proper with "dnf update *.rpm" - period
Comment 20 Harald Reindl 2016-02-25 05:34:59 EST
it's laughable

[root@rh:/downloads]$ ls
total 41M
-rw-r----- 1 harry verwaltung 220K 2016-02-25 11:29 java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  32M 2016-02-25 11:30 java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung 3.1M 2016-02-25 11:28 qt5-qtbase-5.5.1-12.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  23K 2016-02-25 11:28 qt5-qtbase-common-5.5.1-12.fc23.noarch.rpm
-rw-r----- 1 harry verwaltung 5.3M 2016-02-25 11:28 qt5-qtbase-gui-5.5.1-12.fc23.x86_64.rpm

__________________________________________

[root@rh:/downloads]$ dnf -y update *.rpm        
Last metadata expiration check performed 0:24:30 ago on Thu Feb 25 11:08:20 2016.
Error: package qt5-qtbase-gui-5.5.1-12.fc23.x86_64 is not installable.
package qt5-qtbase-gui-5.5.1-11.fc23.x86_64 requires qt5-qtbase(x86-64) = 5.5.1-11.fc23, but none of the providers can be installed.
package plasma-workspace-5.5.4-3.fc23.x86_64 requires plasma-workspace-libs(x86-64) = 5.5.4-3.fc23, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
__________________________________________

[root@rh:/downloads]$ yum-deprecated -y update *.rpm   
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Loaded plugins: etckeeper
Examining java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64.rpm: 1:java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64
Marking java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64.rpm as an update to 1:java-1.8.0-openjdk-1.8.0.72-6.b15.fc23.x86_64
Examining java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64.rpm: 1:java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64
Marking java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64.rpm as an update to 1:java-1.8.0-openjdk-headless-1.8.0.72-6.b15.fc23.x86_64
Examining qt5-qtbase-5.5.1-12.fc23.x86_64.rpm: qt5-qtbase-5.5.1-12.fc23.x86_64
Marking qt5-qtbase-5.5.1-12.fc23.x86_64.rpm as an update to qt5-qtbase-5.5.1-11.fc23.x86_64
Examining qt5-qtbase-common-5.5.1-12.fc23.noarch.rpm: qt5-qtbase-common-5.5.1-12.fc23.noarch
Marking qt5-qtbase-common-5.5.1-12.fc23.noarch.rpm as an update to qt5-qtbase-common-5.5.1-11.fc23.noarch
Examining qt5-qtbase-gui-5.5.1-12.fc23.x86_64.rpm: qt5-qtbase-gui-5.5.1-12.fc23.x86_64
Marking qt5-qtbase-gui-5.5.1-12.fc23.x86_64.rpm as an update to qt5-qtbase-gui-5.5.1-11.fc23.x86_64
Resolving Dependencies
--> Running transaction check
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.72-6.b15.fc23 will be updated
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.72-7.b15.fc23 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.72-6.b15.fc23 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.72-7.b15.fc23 will be an update
---> Package qt5-qtbase.x86_64 0:5.5.1-11.fc23 will be updated
---> Package qt5-qtbase.x86_64 0:5.5.1-12.fc23 will be an update
---> Package qt5-qtbase-common.noarch 0:5.5.1-11.fc23 will be updated
---> Package qt5-qtbase-common.noarch 0:5.5.1-12.fc23 will be an update
---> Package qt5-qtbase-gui.x86_64 0:5.5.1-11.fc23 will be updated
---> Package qt5-qtbase-gui.x86_64 0:5.5.1-12.fc23 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                           Arch                         Version                                        Repository                                                                     Size
===================================================================================================================================================================================================================
Updating:
 java-1.8.0-openjdk                                x86_64                       1:1.8.0.72-7.b15.fc23                          /java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64                                499 k
 java-1.8.0-openjdk-headless                       x86_64                       1:1.8.0.72-7.b15.fc23                          /java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64                       103 M
 qt5-qtbase                                        x86_64                       5.5.1-12.fc23                                  /qt5-qtbase-5.5.1-12.fc23.x86_64                                              8.4 M
 qt5-qtbase-common                                 noarch                       5.5.1-12.fc23                                  /qt5-qtbase-common-5.5.1-12.fc23.noarch                                       0.0
 qt5-qtbase-gui                                    x86_64                       5.5.1-12.fc23                                  /qt5-qtbase-gui-5.5.1-12.fc23.x86_64                                           16 M

Transaction Summary
===================================================================================================================================================================================================================
Upgrade  5 Packages

Total size: 127 M
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
etckeeper: pre transaction commit
Warning: RPMDB altered outside of yum.
  Updating   : qt5-qtbase-common-5.5.1-12.fc23.noarch                                                                                                                                                         1/10
  Updating   : qt5-qtbase-5.5.1-12.fc23.x86_64                                                                                                                                                                2/10
  Updating   : 1:java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64                                                                                                                                       3/10
warning: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64/jre/lib/security/java.security created as /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64/jre/lib/security/java.security.rpmnew
  Updating   : 1:java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64                                                                                                                                                4/10
  Updating   : qt5-qtbase-gui-5.5.1-12.fc23.x86_64                                                                                                                                                            5/10
  Cleanup    : qt5-qtbase-gui-5.5.1-11.fc23.x86_64                                                                                                                                                            6/10
  Cleanup    : qt5-qtbase-common-5.5.1-11.fc23.noarch                                                                                                                                                         7/10
  Cleanup    : qt5-qtbase-5.5.1-11.fc23.x86_64                                                                                                                                                                8/10
  Cleanup    : 1:java-1.8.0-openjdk-1.8.0.72-6.b15.fc23.x86_64                                                                                                                                                9/10
  Cleanup    : 1:java-1.8.0-openjdk-headless-1.8.0.72-6.b15.fc23.x86_64                                                                                                                                      10/10
etckeeper: post transaction commit
  Verifying  : qt5-qtbase-5.5.1-12.fc23.x86_64                                                                                                                                                                1/10
  Verifying  : 1:java-1.8.0-openjdk-1.8.0.72-7.b15.fc23.x86_64                                                                                                                                                2/10
  Verifying  : qt5-qtbase-common-5.5.1-12.fc23.noarch                                                                                                                                                         3/10
  Verifying  : 1:java-1.8.0-openjdk-headless-1.8.0.72-7.b15.fc23.x86_64                                                                                                                                       4/10
  Verifying  : qt5-qtbase-gui-5.5.1-12.fc23.x86_64                                                                                                                                                            5/10
  Verifying  : 1:java-1.8.0-openjdk-1.8.0.72-6.b15.fc23.x86_64                                                                                                                                                6/10
  Verifying  : qt5-qtbase-5.5.1-11.fc23.x86_64                                                                                                                                                                7/10
  Verifying  : qt5-qtbase-gui-5.5.1-11.fc23.x86_64                                                                                                                                                            8/10
  Verifying  : qt5-qtbase-common-5.5.1-11.fc23.noarch                                                                                                                                                         9/10
  Verifying  : 1:java-1.8.0-openjdk-headless-1.8.0.72-6.b15.fc23.x86_64                                                                                                                                      10/10

Updated:
  java-1.8.0-openjdk.x86_64 1:1.8.0.72-7.b15.fc23        java-1.8.0-openjdk-headless.x86_64 1:1.8.0.72-7.b15.fc23        qt5-qtbase.x86_64 0:5.5.1-12.fc23        qt5-qtbase-common.noarch 0:5.5.1-12.fc23
  qt5-qtbase-gui.x86_64 0:5.5.1-12.fc23

Complete!
Comment 21 Igor Gnatenko 2016-04-11 07:45:20 EDT
*** Bug 1324470 has been marked as a duplicate of this bug. ***
Comment 22 Harald Reindl 2016-04-14 10:25:10 EDT
and you *really* wonder when people are upset about DNF?

[root@rh:/downloads]$ ls
total 396K
-rw-r----- 1 harry verwaltung 273K 2016-04-14 16:21 avahi-0.6.32-1.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  15K 2016-04-14 16:21 avahi-glib-0.6.32-1.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  61K 2016-04-14 16:21 avahi-libs-0.6.32-1.fc23.x86_64.rpm
-rw-r----- 1 harry verwaltung  39K 2016-04-14 16:21 avahi-tools-0.6.32-1.fc23.x86_64.rpm
[root@rh:/downloads]$ dnf update *.rpm 
Last metadata expiration check: 0:01:18 ago on Thu Apr 14 16:22:26 2016.
Error: nothing provides avahi-libs(x86-64) = 0.6.32-1.fc23 needed by avahi-0.6.32-1.fc23.x86_64.
nothing provides avahi-libs(x86-64) = 0.6.32-1.fc23 needed by avahi-glib-0.6.32-1.fc23.x86_64.
package avahi-libs-0.6.32-1.fc23.x86_64 is not installable.
package avahi-tools-0.6.32-1.fc23.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
[root@rh:/downloads]$ yum-deprecated --disablerepo=\* update *.rpm
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Loaded plugins: etckeeper
Examining avahi-0.6.32-1.fc23.x86_64.rpm: avahi-0.6.32-1.fc23.x86_64
Marking avahi-0.6.32-1.fc23.x86_64.rpm as an update to avahi-0.6.32-0.4.rc.fc23.x86_64
Examining avahi-glib-0.6.32-1.fc23.x86_64.rpm: avahi-glib-0.6.32-1.fc23.x86_64
Marking avahi-glib-0.6.32-1.fc23.x86_64.rpm as an update to avahi-glib-0.6.32-0.4.rc.fc23.x86_64
Examining avahi-libs-0.6.32-1.fc23.x86_64.rpm: avahi-libs-0.6.32-1.fc23.x86_64
Marking avahi-libs-0.6.32-1.fc23.x86_64.rpm as an update to avahi-libs-0.6.32-0.4.rc.fc23.x86_64
Examining avahi-tools-0.6.32-1.fc23.x86_64.rpm: avahi-tools-0.6.32-1.fc23.x86_64
Marking avahi-tools-0.6.32-1.fc23.x86_64.rpm as an update to avahi-tools-0.6.32-0.4.rc.fc23.x86_64
Resolving Dependencies
--> Running transaction check
---> Package avahi.x86_64 0:0.6.32-0.4.rc.fc23 will be updated
---> Package avahi.x86_64 0:0.6.32-1.fc23 will be an update
---> Package avahi-glib.x86_64 0:0.6.32-0.4.rc.fc23 will be updated
---> Package avahi-glib.x86_64 0:0.6.32-1.fc23 will be an update
---> Package avahi-libs.x86_64 0:0.6.32-0.4.rc.fc23 will be updated
---> Package avahi-libs.x86_64 0:0.6.32-1.fc23 will be an update
---> Package avahi-tools.x86_64 0:0.6.32-0.4.rc.fc23 will be updated
---> Package avahi-tools.x86_64 0:0.6.32-1.fc23 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies

Dependencies Resolved
Comment 23 Fedora Admin XMLRPC Client 2016-07-08 05:31:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 24 Fedora End Of Life 2016-07-19 13:55:01 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 25 Harald Reindl 2016-07-19 14:00:58 EDT
this was *never* solved and hence a system without yum-deprecated is still unuseable when someone wants to helpf fedora-development with early testing or builds packages local
Comment 26 Igor Gnatenko 2016-07-21 05:11:43 EDT
That debugdata is useless:
disable: unknown package 'dhcp-common-12:4.3.3-6.fc23.noarch@@commandline'
disable: unknown package 'dhcp-libs-12:4.3.3-6.fc23.x86_64@@commandline'
disable: unknown package 'dhcp-server-12:4.3.3-6.fc23.x86_64@@commandline'
str2job: unknown package 'dhcp-client-12:4.3.3-6.fc23.x86_64@@commandline'
str2job: unknown package 'dhcp-common-12:4.3.3-6.fc23.noarch@@commandline'
str2job: unknown package 'dhcp-libs-12:4.3.3-6.fc23.x86_64@@commandline'
str2job: unknown package 'dhcp-server-12:4.3.3-6.fc23.x86_64@@commandline'


guess it has been fixed. Can you provide some minimal example which I can reproduce?
Comment 27 Harald Reindl 2016-07-21 05:19:14 EDT
dunno what is there useless - that's what it gave out while pretended that deps are broken while not realize that the pretended missing one is within * on the command line

that typically happens everytime when "dnf update *.rpm" has involved sub-packages with version-dependencies between the local rpm packages 

well, it's a longer time since a touched DNF bedcause "yum --disablerepo=\* update *.rpm" works relieable and without download metadata where DNF cries that no repo is available
Comment 28 Harald Reindl 2016-07-21 06:10:21 EDT
here you go on F24:
https://koji.fedoraproject.org/koji/buildinfo?buildID=784346

"guess it has been fixed" - nothing has been fixed and everybody of the developers who really would care could have found a simple reprodcuer over all the months - yum *never* had such problems over a decade
______________________________________

[root@rh:/downloads]$ ls | grep rpm
-rw-r----- 1 harry verwaltung 5.1M 2016-07-21 10:51 systemd-229-9.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 151K 2016-07-21 12:07 systemd-compat-libs-229-9.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 456K 2016-07-21 10:51 systemd-libs-229-9.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 1.2M 2016-07-21 10:51 systemd-udev-229-9.fc24.x86_64.rpm
______________________________________

[root@rh:/downloads]$ dnf update *.rpm
Last metadata expiration check: 0:17:29 ago on Thu Jul 21 11:50:15 2016.
Error: nothing provides systemd-libs = 229-9.fc24 needed by systemd-229-9.fc24.x86_64.
nothing provides systemd-libs(x86-64) = 229-9.fc24 needed by systemd-compat-libs-229-9.fc24.x86_64.
package systemd-libs-229-9.fc24.x86_64 is not installable.
package systemd-udev-229-9.fc24.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
______________________________________

[root@rh:/downloads]$ yum-deprecated update *.rpm
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Loaded plugins: etckeeper
Examining systemd-229-9.fc24.x86_64.rpm: systemd-229-9.fc24.x86_64
Marking systemd-229-9.fc24.x86_64.rpm as an update to systemd-229-8.fc24.x86_64
Examining systemd-compat-libs-229-9.fc24.x86_64.rpm: systemd-compat-libs-229-9.fc24.x86_64
Marking systemd-compat-libs-229-9.fc24.x86_64.rpm as an update to systemd-compat-libs-229-8.fc24.x86_64
Examining systemd-libs-229-9.fc24.x86_64.rpm: systemd-libs-229-9.fc24.x86_64
Marking systemd-libs-229-9.fc24.x86_64.rpm as an update to systemd-libs-229-8.fc24.x86_64
Examining systemd-udev-229-9.fc24.x86_64.rpm: systemd-udev-229-9.fc24.x86_64
Marking systemd-udev-229-9.fc24.x86_64.rpm as an update to systemd-udev-229-8.fc24.x86_64
Resolving Dependencies
--> Running transaction check
---> Package systemd.x86_64 0:229-8.fc24 will be updated
---> Package systemd.x86_64 0:229-9.fc24 will be an update
---> Package systemd-compat-libs.x86_64 0:229-8.fc24 will be updated
---> Package systemd-compat-libs.x86_64 0:229-9.fc24 will be an update
---> Package systemd-libs.x86_64 0:229-8.fc24 will be updated
---> Package systemd-libs.x86_64 0:229-9.fc24 will be an update
---> Package systemd-udev.x86_64 0:229-8.fc24 will be updated
---> Package systemd-udev.x86_64 0:229-9.fc24 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies

Dependencies Resolved
Comment 29 Michael Mráka 2016-07-21 06:57:57 EDT
Harald please keep calm...

# ls -l systemd-*
-rw-r--r--. 1 root root 5317384 Jul 21 12:22 systemd-229-9.fc24.x86_64.rpm
-rw-r--r--. 1 root root  466374 Jul 21 12:23 systemd-libs-229-9.fc24.x86_64.rpm
-rw-r--r--. 1 root root 1234510 Jul 21 12:23 systemd-udev-229-9.fc24.x86_64.rpm
# dnf update ./systemd-*
Last metadata expiration check: 1:24:27 ago on Thu Jul 21 10:59:35 2016.
Dependencies resolved.
==========================================================================================================
 Package                   Arch                Version                    Repository                 Size
==========================================================================================================
Upgrading:
 systemd                   x86_64              229-9.fc24                 @commandline              5.1 M
 systemd-libs              x86_64              229-9.fc24                 @commandline              455 k
 systemd-udev              x86_64              229-9.fc24                 @commandline              1.2 M

Transaction Summary
==========================================================================================================
Upgrade  3 Packages

Total size: 6.7 M
Is this ok [y/N]:

We can't reproduce your bug, so now what? We need to figure out what's the difference between your system and fresh F24 (from the test above) which causes the bug you see. If you can help us to find the cause please do otherwise it's really hard to fix the bug we can't see.
Comment 30 Harald Reindl 2016-07-21 07:05:19 EDT
it's interesting that you don't take "systemd-compat-libs" into the game since the error is "nothing provides systemd-libs(x86-64) = 229-9.fc24 needed by systemd-compat-libs-229-9.fc24.x86_64" and without that package in the transaction the *real problem* that DNF is unable to solve such deps when the required versioned dependencie is part of the local files
Comment 31 Igor Gnatenko 2016-07-21 07:15:07 EDT
(In reply to Harald Reindl from comment #30)
> it's interesting that you don't take "systemd-compat-libs" into the game
> since the error is "nothing provides systemd-libs(x86-64) = 229-9.fc24
> needed by systemd-compat-libs-229-9.fc24.x86_64" and without that package in
> the transaction the *real problem* that DNF is unable to solve such deps
> when the required versioned dependencie is part of the local files

[brain@x1carbon ~]$ sudo docker run -it --rm fedora:24 bash
[root@35f5beb3adbf /]# cd mnt
[root@35f5beb3adbf mnt]# rpm -qa | grep "^systemd" | sort -n
systemd-229-8.fc24.x86_64
systemd-libs-229-8.fc24.x86_64
[root@35f5beb3adbf mnt]# dnf install systemd-compat-libs
Fedora 24 - x86_64                                                                                                                              2.8 MB/s |  47 MB     00:16    
Fedora 24 - x86_64 - Updates                                                                                                                    2.6 MB/s |  11 MB     00:04    
Last metadata expiration check: 0:00:04 ago on Thu Jul 21 11:13:14 2016.
Dependencies resolved.
================================================================================================================================================================================
 Package                                            Arch                                  Version                                   Repository                             Size
================================================================================================================================================================================
Installing:
 systemd-compat-libs                                x86_64                                229-8.fc24                                fedora                                151 k

Transaction Summary
================================================================================================================================================================================
Install  1 Package

Total download size: 151 k
Installed size: 265 k
Is this ok [y/N]: y
Downloading Packages:
systemd-compat-libs-229-8.fc24.x86_64.rpm                                                                                                       195 kB/s | 151 kB     00:00    
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                            70 kB/s | 151 kB     00:02     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : systemd-compat-libs-229-8.fc24.x86_64                                                                                                                       1/1 
  Verifying   : systemd-compat-libs-229-8.fc24.x86_64                                                                                                                       1/1 

Installed:
  systemd-compat-libs.x86_64 229-8.fc24                                                                                                                                         

Complete!
[root@35f5beb3adbf mnt]# curl -O https://kojipkgs.fedoraproject.org//packages/systemd/229/9.fc24/x86_64/systemd-229-9.fc24.x86_64.rpm 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 5192k  100 5192k    0     0  1198k      0  0:00:04  0:00:04 --:--:-- 1198k
[root@35f5beb3adbf mnt]# curl -O https://kojipkgs.fedoraproject.org//packages/systemd/229/9.fc24/x86_64/systemd-compat-libs-229-9.fc24.x86_64.rpm
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  150k  100  150k    0     0  70148      0  0:00:02  0:00:02 --:--:-- 70169
[root@35f5beb3adbf mnt]# curl -O https://kojipkgs.fedoraproject.org//packages/systemd/229/9.fc24/x86_64/systemd-libs-229-9.fc24.x86_64.rpm
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  455k  100  455k    0     0   202k      0  0:00:02  0:00:02 --:--:--  202k
[root@35f5beb3adbf mnt]# dnf --disablerepo=\* -C update ./*.rpm
Dependencies resolved.
================================================================================================================================================================================
 Package                                          Arch                                Version                                   Repository                                 Size
================================================================================================================================================================================
Upgrading:
 systemd                                          x86_64                              229-9.fc24                                @commandline                              5.1 M
 systemd-compat-libs                              x86_64                              229-9.fc24                                @commandline                              151 k
 systemd-libs                                     x86_64                              229-9.fc24                                @commandline                              455 k

Transaction Summary
================================================================================================================================================================================
Upgrade  3 Packages

Total size: 5.7 M
Is this ok [y/N]: n
Operation aborted.



provide some real easy reproducer that we will be able reproduce -> fix.
Comment 32 Harald Reindl 2016-07-21 07:18:05 EDT
seriously?

* just install systemd-compat-libs before try to update
* download the *four* packages of comment 28
* cd downloadfolder
* dnf update *.rpm

DNF fails when local packages have hard, version dependent deps between themself, that's it
Comment 33 Harald Reindl 2016-07-21 07:20:20 EDT
and *no* that is not systemd related - the whole bugreport shows several exmaples over months where "x requires y in version z but nothing provides it" while the package with provides it is part of *
Comment 34 Harald Reindl 2016-07-21 07:29:24 EDT
"dnf --disablerepo=\* -C update ./*.rpm" - so why can't you just do the same as the reporter? 

we had also cases where DNF pretended unsolveable deps without mention what is the problem when metadata of a repo with a short cachetime where refreshed due "dnf update *.rpm" 

just press cursor-up+enter and suddenly it worked - multiple times, for multiple transactions - look at the bugreports from last year
Comment 35 Michael Mráka 2016-07-21 07:46:31 EDT
> it's interesting that you don't take "systemd-compat-libs" into the game
> since the error is "nothing provides systemd-libs(x86-64) = 229-9.fc24
> needed by systemd-compat-libs-229-9.fc24.x86_64" and without that package in
> the transaction the *real problem* that DNF is unable to solve such deps
> when the required versioned dependencie is part of the local files

Ok, my fault for not reading carefully. systemd-compat-libs was not installed on my system so I skipped it. On the other hand still works for me:


# dnf install systemd-compat-libs
...
Installed:
  systemd-compat-libs.x86_64 229-8.fc24
# ls -l systemd-*
-rw-r--r--. 1 root root 5317384 Jul 21 12:22 systemd-229-9.fc24.x86_64.rpm
-rw-r--r--. 1 root root  154162 Jul 21 13:36 systemd-compat-libs-229-9.fc24.x86_64.rpm
-rw-r--r--. 1 root root  466374 Jul 21 12:23 systemd-libs-229-9.fc24.x86_64.rpm
-rw-r--r--. 1 root root 1234510 Jul 21 12:23 systemd-udev-229-9.fc24.x86_64.rpm
                                                      
# dnf update ./systemd-*
Last metadata expiration check: 2:40:37 ago on Thu Jul 21 10:59:35 2016.
Dependencies resolved.
===============================================================================
 Package                  Arch        Version          Repository         Size
===============================================================================
Upgrading:
 systemd                  x86_64      229-9.fc24       @commandline      5.1 M
 systemd-compat-libs      x86_64      229-9.fc24       @commandline      151 k
 systemd-libs             x86_64      229-9.fc24       @commandline      455 k
 systemd-udev             x86_64      229-9.fc24       @commandline      1.2 M

Transaction Summary
===============================================================================
Upgrade  4 Packages

Total size: 6.8 M
Is this ok [y/N]: 
# dnf --disablerepo=\* -C update ./systemd-*
Dependencies resolved.
===============================================================================
 Package                  Arch        Version          Repository         Size
===============================================================================
Upgrading:
 systemd                  x86_64      229-9.fc24       @commandline      5.1 M
 systemd-compat-libs      x86_64      229-9.fc24       @commandline      151 k
 systemd-libs             x86_64      229-9.fc24       @commandline      455 k
 systemd-udev             x86_64      229-9.fc24       @commandline      1.2 M

Transaction Summary
===============================================================================
Upgrade  4 Packages

Total size: 6.8 M
Is this ok [y/N]: 


There's likely something different in your configuration which triggers the error.
Comment 36 Harald Reindl 2016-07-21 07:56:25 EDT
ok, so i will try later or tomorrow on a VM downgrade and upgrade with debuginfos, now then we at least are trying to do the same and there is feedback not like the last time where nothing came back after provide the requested data until yesterday

2015-11-09 11:23:13 EST 
attach the debugdata, please

2015-11-13 06:30 EST
here are your debugdata (7.44 MB, application/octet-stream)

2016-07-08
This package has changed ownership

2016-07-21
That debugdata is useless

while i still don't get *what* is useless there
Comment 37 Harald Reindl 2016-07-21 13:31:31 EDT
i really have no idea *why* DNF acts *that non deterministically*

just downgraded systemd to the 229-8.fc24 build, dnf update *.rpm with the downloads -> works this time fine (3 attempts, 1 downloaded repo-metadata too) and so it seems we really need to figure out what in the debugdata from "2015-11-13 06:30" is unusable since they are generated as advised
Comment 38 Igor Gnatenko 2016-07-21 15:30:48 EDT
(In reply to Harald Reindl from comment #37)
> i really have no idea *why* DNF acts *that non deterministically*
> 
> just downgraded systemd to the 229-8.fc24 build, dnf update *.rpm with the
> downloads -> works this time fine (3 attempts, 1 downloaded repo-metadata
> too) and so it seems we really need to figure out what in the debugdata from
> "2015-11-13 06:30" is unusable since they are generated as advised

I guess this has been fixed at some point in DNF. We had a lot of releases since that.
Comment 39 Harald Reindl 2016-07-21 15:32:46 EDT
for sure not - https://bugzilla.redhat.com/show_bug.cgi?id=1263888#c28 - was TODAY for a brand new systemd-build which made it hours later into updates-testing
Comment 40 Harald Reindl 2016-07-26 08:59 EDT
Created attachment 1184268 [details]
another debugdata

again a random error and in "dnf.log" there is a python stacktrace too

[root@rh:/downloads]$ dnf update *.rpm
Last metadata expiration check: 0:08:56 ago on Tue Jul 26 14:48:07 2016.
Error: package gd-2.2.3-2.fc24.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
_________________________________

Jul 26 14:57:04 DEBUG --> Starting dependency resolution
Jul 26 14:57:04 DEBUG --> Finished dependency resolution
Jul 26 14:57:04 DDEBUG timer: depsolve: 82 ms
Jul 26 14:57:04 SUBDEBUG
Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 139, in resolving
    base.resolve(cli.demands.allow_erasing)
  File "/usr/lib/python3.5/site-packages/dnf/base.py", line 541, in resolve
    raise exc
dnf.exceptions.DepsolveError: package gd-2.2.3-2.fc24.x86_64 is not installable
Jul 26 14:57:04 CRITICAL Error: package gd-2.2.3-2.fc24.x86_64 is not installable
Jul 26 14:57:04 INFO (try to add '--allowerasing' to command line to replace conflicting packages)
Jul 26 14:57:04 DDEBUG Cleaning up.
_________________________________

as always "yum-deprecated" works like a charme

yum-deprecated --disablerepo=\*  update *.rpm

Updated:
  bind.x86_64 32:9.10.4-1.P2.fc24         bind-chroot.x86_64 32:9.10.4-1.P2.fc24   bind-libs.x86_64 32:9.10.4-1.P2.fc24   bind-libs-lite.x86_64 32:9.10.4-1.P2.fc24   bind-license.noarch 32:9.10.4-1.P2.fc24
  bind-utils.x86_64 32:9.10.4-1.P2.fc24   gd.x86_64 0:2.2.3-2.fc24
_________________________________

[root@rh:/downloads]$ ls | grep rpm
-rw-r----- 1 harry verwaltung 1.9M 2016-07-26 14:46 bind-9.10.4-1.P2.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung  90K 2016-07-26 14:46 bind-chroot-9.10.4-1.P2.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 151K 2016-07-26 14:46 bind-libs-9.10.4-1.P2.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 1.1M 2016-07-26 14:46 bind-libs-lite-9.10.4-1.P2.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung  89K 2016-07-26 14:46 bind-license-9.10.4-1.P2.fc24.noarch.rpm
-rw-r----- 1 harry verwaltung 407K 2016-07-26 14:46 bind-utils-9.10.4-1.P2.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 135K 2016-07-26 14:47 gd-2.2.3-2.fc24.x86_64.rpm
Comment 41 Igor Gnatenko 2016-07-26 10:43:51 EDT
now I realized that debugdata is useless due to dnf bug (hawkey actually) as it creates multiple @commandline repos with empty info.

Can you give some reproducer based on Fedora 24 container image?
Comment 42 Harald Reindl 2016-07-26 10:55:47 EDT
no, i can't give a clear reproducer, i just see that behavior often from day one and in most cases where i intend to update a bnuch of packages from koji downloads i started to use yum-deprecated in general to prevent anger since my goal is test packages and give karma as soon it is possible and makes sense

also that "dnf --disablerepo=\*" by default don't work without add another param is annoying because when i know that all deps are solveable with the local files provided there is no need to download metadata (yum in the past did that only when it had to solve a additional dependency and was degraded in that context in the meantime too)
Comment 43 Igor Gnatenko 2016-07-27 05:34:56 EDT
*** Bug 1270779 has been marked as a duplicate of this bug. ***
Comment 44 Harald Reindl 2016-08-30 09:51:58 EDT
___________________________________

[root@testserver:/data]$ dnf update *.rpm
Last metadata expiration check: 0:00:41 ago on Tue Aug 30 15:48:58 2016.
Package pango-devel not installed, cannot update it.
Error: package pango-1.40.2-1.fc24.x86_64 is not installable.
package pcre-8.39-3.fc24.x86_64 is not installable.
package pcre-devel-8.39-3.fc24.x86_64 is not installable
(try to add '--allowerasing' to command line to replace conflicting packages)
___________________________________

[root@testserver:/data]$ yum-deprecated --disablerepo=\* update *.rpm
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Examining libinput-1.4.2-1.fc24.x86_64.rpm: libinput-1.4.2-1.fc24.x86_64
Marking libinput-1.4.2-1.fc24.x86_64.rpm as an update to libinput-1.4.1-1.fc24.x86_64
Examining pango-1.40.2-1.fc24.x86_64.rpm: pango-1.40.2-1.fc24.x86_64
Marking pango-1.40.2-1.fc24.x86_64.rpm as an update to pango-1.40.1-1.fc24.x86_64
Examining pango-devel-1.40.2-1.fc24.x86_64.rpm: pango-devel-1.40.2-1.fc24.x86_64
Package pango-devel not installed, cannot update it. Run yum install to install it instead.
Examining pcre-8.39-3.fc24.x86_64.rpm: pcre-8.39-3.fc24.x86_64
Marking pcre-8.39-3.fc24.x86_64.rpm as an update to pcre-8.39-2.fc24.x86_64
Examining pcre-devel-8.39-3.fc24.x86_64.rpm: pcre-devel-8.39-3.fc24.x86_64
Marking pcre-devel-8.39-3.fc24.x86_64.rpm as an update to pcre-devel-8.39-2.fc24.x86_64
Resolving Dependencies
--> Running transaction check
---> Package libinput.x86_64 0:1.4.1-1.fc24 will be updated
---> Package libinput.x86_64 0:1.4.2-1.fc24 will be an update
---> Package pango.x86_64 0:1.40.1-1.fc24 will be updated
---> Package pango.x86_64 0:1.40.2-1.fc24 will be an update
---> Package pcre.x86_64 0:8.39-2.fc24 will be updated
---> Package pcre.x86_64 0:8.39-3.fc24 will be an update
---> Package pcre-devel.x86_64 0:8.39-2.fc24 will be updated
---> Package pcre-devel.x86_64 0:8.39-3.fc24 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies

Dependencies Resolved

Updated:
  libinput.x86_64 0:1.4.2-1.fc24                        pango.x86_64 0:1.40.2-1.fc24                        pcre.x86_64 0:8.39-3.fc24                        pcre-devel.x86_64 0:8.39-3.fc24
Comment 45 Igor Gnatenko 2016-08-30 09:59:43 EDT
--debugsolver
Comment 46 Harald Reindl 2016-08-30 10:16 EDT
Created attachment 1195930 [details]
debugdata again
Comment 47 Harald Reindl 2016-08-30 10:18 EDT
Created attachment 1195932 [details]
debugdata again - different machine
Comment 48 Harald Reindl 2016-08-30 10:24:33 EDT
if that debugdata is again not useable i suggest dnf developers starting to fix that so users can at least provide useful informations

DNF in general is very silent in case of dependency errors compared to YUM which tells you files and sonames where problems are - well in that case it's clear that it can't output something useful because there is no problem in the deps but in DNF or it's libraries

given how long we are now punished with deprecation warnings while tehre is still no full replacement of "yum-utils" (especially package-cleanup and repomanage --old) and critical things like "yum --security update" are also still missing people get REALLY tired

[root@srv-rhsoft:~]$ rpm -qa | grep dnf
python3-dnf-1.1.10-1.fc24.noarch
dnf-1.1.10-1.fc24.noarch
dnf-plugins-core-0.1.21-3.fc24.noarch
dnf-conf-1.1.10-1.fc24.noarch
python3-dnf-plugins-core-0.1.21-3.fc24.noarch
dnf-yum-1.1.10-1.fc24.noarch
etckeeper-dnf-1.18.5-1.fc24.noarch

[root@srv-rhsoft:~]$ rpm -q hawkey
hawkey-0.6.3-5.fc24.x86_64

[root@srv-rhsoft:~]$ rpm -q libsolv
libsolv-0.6.23-2.fc24.x86_64
Comment 49 Igor Gnatenko 2016-08-30 12:03:25 EDT
basically something is wrong here:
str2job: unknown package 'pcre-devel-8.39-3.fc24.x86_64@@commandline'

which is really weird. Looking more.



> package-cleanup
It never worked correctly. Though there is some replacement for it in DNF itself.

> repomanage
it's in dnf-plugins-extras for long time.
Comment 50 Harald Reindl 2016-08-30 12:27:20 EDT
package-cleanup --leaves --all as well as --orphans are working correctly here for many years while the replacements in DNF rely on /var/lib/dnf instead of the rpm databas itself which makes them completely fragile and useless
Comment 51 Igor Gnatenko 2016-08-30 12:34:44 EDT
Michael, could you take a look why it prints our "str2job: unknown package 'pcre-devel-8.39-3.fc24.x86_64@@commandline'". It looks correctly defined in repos.
Comment 52 Michael Schröder 2016-08-31 05:33:27 EDT
Because the package is disabled. This is a bug, of course, the testcase reader should still use the package even if it is disabled. I'll change the code.

But I guess dnf should not exclude packages from the command line when you do --disablerepo=\*. It should only disable "real" repos.
Comment 53 Harald Reindl 2016-08-31 05:37:06 EDT
oh and when you are at it "--cacheonly" could be implicit in case of all network repos disabled as yum did for a decade....
Comment 54 Igor Gnatenko 2016-08-31 05:40:02 EDT
(In reply to Michael Schröder from comment #52)
> Because the package is disabled.
Where do you see it? This is what I checked in first place, but have not found.
Comment 55 Michael Schröder 2016-08-31 05:42:06 EDT
The testcase contains:

disable pkg pcre-8.39-3.fc24.x86_64@@commandline
Comment 56 Igor Gnatenko 2016-11-14 11:38:25 EST
So after all I was able to reproduce on DNF 2.0...

[brain@brain python-serpy]$ sudo dnf install ./openssl-* --debugsolver
[sudo] password for brain: 
Last metadata expiration check: 0:28:16 ago on Mon Nov 14 17:07:56 2016 CET.
Failed to synchronize cache for repo 'rhpkg-rawhide', disabling.
Error: 
 Problem 1: problem with installed package authconfig-6.2.10-14.fc25.x86_64
  - package authconfig-6.2.10-14.fc25.x86_64 requires /usr/bin/openssl, but none of the providers can be installed
  - package authconfig-6.2.10-14.fc25.x86_64 requires /usr/bin/openssl, but none of the providers can be installed
  - cannot install both openssl-1:1.1.0b-4.fc26.x86_64 and openssl-1:1.1.0c-1.fc26.x86_64
  - cannot install both openssl-1:1.1.0b-4.fc26.x86_64 and openssl-1:1.1.0c-1.fc26.x86_64
  - conflicting requests
 Problem 2: problem with installed package realmd-0.16.2-5.fc25.x86_64
  - package realmd-0.16.2-5.fc25.x86_64 requires authconfig, but none of the providers can be installed
  - package realmd-0.16.2-5.fc25.x86_64 requires authconfig, but none of the providers can be installed
  - package authconfig-6.2.10-14.fc25.x86_64 requires /usr/bin/openssl, but none of the providers can be installed
  - package authconfig-6.2.10-14.fc25.x86_64 requires /usr/bin/openssl, but none of the providers can be installed
  - package openssl-1:1.1.0c-1.fc26.x86_64 requires openssl-libs(x86-64) = 1:1.1.0c-1.fc26, but none of the providers can be installed
  - package openssl-1:1.1.0c-1.fc26.x86_64 requires openssl-libs(x86-64) = 1:1.1.0c-1.fc26, but none of the providers can be installed
  - cannot install both openssl-libs-1:1.1.0b-4.fc26.x86_64 and openssl-libs-1:1.1.0c-1.fc26.x86_64
  - cannot install both openssl-libs-1:1.1.0b-4.fc26.x86_64 and openssl-libs-1:1.1.0c-1.fc26.x86_64
  - conflicting requests
 Problem 3: problem with installed package fprintd-pam-0.7.0-1.fc26.x86_64
  - package fprintd-pam-0.7.0-1.fc26.x86_64 requires authconfig, but none of the providers can be installed
  - package fprintd-pam-0.7.0-1.fc26.x86_64 requires authconfig, but none of the providers can be installed
  - package authconfig-6.2.10-14.fc25.x86_64 requires /usr/bin/openssl, but none of the providers can be installed
  - package authconfig-6.2.10-14.fc25.x86_64 requires /usr/bin/openssl, but none of the providers can be installed
  - package openssl-1:1.1.0c-1.fc26.x86_64 requires openssl-libs(x86-64) = 1:1.1.0c-1.fc26, but none of the providers can be installed
  - package openssl-1:1.1.0c-1.fc26.x86_64 requires openssl-libs(x86-64) = 1:1.1.0c-1.fc26, but none of the providers can be installed
  - cannot install both openssl-libs-1:1.1.0b-4.fc26.x86_64 and openssl-libs-1:1.1.0c-1.fc26.x86_64
  - cannot install both openssl-libs-1:1.1.0b-4.fc26.x86_64 and openssl-libs-1:1.1.0c-1.fc26.x86_64
  - package openssl-devel-1:1.1.0b-4.fc26.x86_64 requires openssl-libs(x86-64) = 1:1.1.0b-4.fc26, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages)

but then I do:
[brain@brain python-serpy]$ testsolv -r debugdata/testcase.t 
downgrade openssl-1:1.1.0c-1.fc26.x86_64@@System openssl-1:1.1.0b-4.fc26.x86_64@@commandline
downgrade openssl-devel-1:1.1.0c-1.fc26.x86_64@@System openssl-devel-1:1.1.0b-4.fc26.x86_64@@commandline
downgrade openssl-libs-1:1.1.0c-1.fc26.x86_64@@System openssl-libs-1:1.1.0b-4.fc26.x86_64@@commandline

which is now able to find solution.
Comment 57 Harald Reindl 2016-11-14 11:44:07 EST
thanks for changing priority to high while i am not teriible happy with "24 -> rawhide" since that's the major reason i *must* use yum-deprecated in a lot of environments and the deprectaion warnings when i already call "yum-deprecated" by name making me angry for a long time now (especially since they spit into cron-mails)
Comment 58 Igor Gnatenko 2016-11-21 16:30:45 EST
*** Bug 1397108 has been marked as a duplicate of this bug. ***
Comment 59 Vít Ondruch 2016-11-22 03:20 EST
Created attachment 1222621 [details]
debugdata

Ok, I have simpler reproducer similar/related to bug 1397108:

1. $ mock -r fedora-rawhide-x86_64 --scrub all
2. $ mock -r fedora-rawhide-x86_64 --init
3. $ mock -r fedora-rawhide-x86_64 --chroot "rpm -q vim\* -a"
4. $ mock -r fedora-rawhide-x86_64 -i https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-X11-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-common-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-enhanced-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-filesystem-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-minimal-8.0.086-1.fc26.x86_64.rpm vim-commentary vim-taglist vim-fugitive vim-nerdtree sudo



This fails with this error:

```
Error: 
 Problem 1: conflicting requests
  - package vim-fugitive-2.2-5.fc25.noarch requires /usr/bin/vim, but none of the providers can be installed
  - package vim-fugitive-2.2-5.fc25.noarch requires /usr/bin/vim, but none of the providers can be installed
  - cannot install both vim-enhanced-2:8.0.086-1.fc26.x86_64 and vim-enhanced-2:8.0.086-1.fc26.x86_64
  - cannot install both vim-enhanced-2:8.0.086-1.fc26.x86_64 and vim-enhanced-2:8.0.094-1.fc26.x86_64
  - conflicting requests
 Problem 2: conflicting requests
  - package sudo-1.8.19-0.2.20161108git738c3cb.fc26.i686 requires /usr/bin/vi, but none of the providers can be installed
  - package sudo-1.8.19-0.2.20161108git738c3cb.fc26.x86_64 requires /usr/bin/vi, but none of the providers can be installed
  - package sudo-1.8.19-0.2.20161108git738c3cb.fc26.x86_64 requires /usr/bin/vi, but none of the providers can be installed
  - cannot install both vim-minimal-2:8.0.086-1.fc26.x86_64 and vim-minimal-2:8.0.086-1.fc26.x86_64
  - cannot install both vim-minimal-2:8.0.086-1.fc26.x86_64 and vim-minimal-2:8.0.094-1.fc26.x86_64
  - conflicting requests
```

What caught my attention is the mixture of vim-enhanced-2:8.0.086-1.fc26.x86_64 and vim-enhanced-2:8.0.094-1.fc26.x86_64. Ok, I tried to install rev 086, but the same mixture appears when I try to install rev 094. Please note that the repositories very likely contains both versions and I try to install explicitely 3rd version, which might be treated as separate version by DNF? It seems like it can't decide which version to install?

May be the good start would be if the error message said not just vim-minimal-2:8.0.094-1.fc26.x86_64 but something like vim-minimal-2:8.0.094-1.fc26.x86_64@commandline or vim-minimal-2:8.0.094-1.fc26.x86_64@fedora to make it clear where the package comes from actually.
Comment 60 Igor Gnatenko 2016-11-22 03:22:19 EST
If you will try to 'testsolv' test case from debugdata -- it will show no conflicts.
Comment 61 Vít Ondruch 2016-11-22 03:28:32 EST
(In reply to Igor Gnatenko from comment #60)
But that suggest to me that the "commandline" repo is not treated properly by DNF. I.e. not all the data are fed to the internal solver.
Comment 62 Igor Gnatenko 2016-11-22 03:30:44 EST
(In reply to Vít Ondruch from comment #61)
> (In reply to Igor Gnatenko from comment #60)
> But that suggest to me that the "commandline" repo is not treated properly
> by DNF. I.e. not all the data are fed to the internal solver.
Yes.
* Provides (probably local) are not loaded correctly
* Not all rpms loaded into pool.

I guess one of these options.
Comment 63 Harald Reindl 2016-11-29 05:24:57 EST
it makes me sick - how is a user supposed to work with that stuff and test updates when the package management is broken for a year now?

https://bugzilla.redhat.com/show_bug.cgi?id=1374925
https://bugzilla.redhat.com/show_bug.cgi?id=1398040


[root@testserver:/data]$ ls
total 160K
-rw-r----- 1 root root 49K 2016-11-29 11:19 pypolicyd-spf-1.3.2-4.fc26.noarch.rpm
-rw-r----- 1 root root 49K 2016-11-29 11:19 python2-pyspf-2.0.12-1.fc26.noarch.rpm
-rw-r----- 1 root root 53K 2016-11-29 11:19 python3-pyspf-2.0.12-1.fc26.noarch.rpm
[root@testserver:/data]$ dnf update *.rpm
Last metadata expiration check: 0:01:26 ago on Tue Nov 29 11:21:48 2016.
Package python2-pyspf not installed, cannot update it.
Package python3-pyspf not installed, cannot update it.
Error: nothing provides python3-pyspf needed by pypolicyd-spf-1.3.2-4.fc26.noarch
(try to add '--allowerasing' to command line to replace conflicting packages)
Comment 64 Harald Reindl 2016-11-29 05:28:25 EST
insteresting - "dnf install" seems to know much more about the packages

[root@testserver:/data]$ ls
total 160K
-rw-r----- 1 root root 49K 2016-11-29 11:19 pypolicyd-spf-1.3.2-4.fc26.noarch.rpm
-rw-r----- 1 root root 49K 2016-11-29 11:19 python2-pyspf-2.0.12-1.fc26.noarch.rpm
-rw-r----- 1 root root 53K 2016-11-29 11:19 python3-pyspf-2.0.12-1.fc26.noarch.rpm
[root@testserver:/data]$ dnf install *.rpm
Last metadata expiration check: 0:05:37 ago on Tue Nov 29 11:21:48 2016.
Dependencies resolved.
===================================================================================================================================================================================================================
 Package                                              Arch                                         Version                                                Repository                                          Size
===================================================================================================================================================================================================================
Installing:
 python2-pyspf                                        noarch                                       2.0.12-1.fc26                                          @commandline                                        48 k
     replacing  python-pyspf.noarch 2.0.11-4.fc24
 python3-py3dns                                       noarch                                       3.0.4-7.fc24                                           fedora                                              49 k
 python3-pyspf                                        noarch                                       2.0.12-1.fc26                                          @commandline                                        52 k
Upgrading:
 pypolicyd-spf                                        noarch                                       1.3.2-4.fc26                                           @commandline                                        48 k

Transaction Summary
===================================================================================================================================================================================================================
Install  3 Packages
Upgrade  1 Package

Total size: 198 k
Total download size: 49 k
Is this ok [y/N]:
Comment 65 Michael Schröder 2016-11-29 06:03:34 EST
I guess that hy_sack_add_cmdline_package should clear considered_uptodate, as a new package is added to the sack.

I think that the considered map is too small, leading to access to unallocated memory.
Comment 66 Jaroslav Mracek 2017-01-12 11:40:51 EST
Recently we refactored install and upgrade commands and package handling. Please can you try upstream version of dnf-2.0 from our testing repository ("dnf copr enable rpmsoftwaremanagement/dnf-nightly")? We will be very happy to hear your feedback. Thanks a lot
Comment 67 Harald Reindl 2017-01-12 11:47:25 EST
i fear that stuff is for F25+ - i did not change the fedora version to "rawhide" and there are no machines with F25 planned the next 2-3 months for several reasons

[root@srv-rhsoft:~]$ dnf copr enable rpmsoftwaremanagement/dnf-nightly
You are about to enable a Copr repository. Please note that this
repository is not part of the main Fedora distribution, and quality
may vary.

The Fedora Project does not exercise any power over the contents of
this repository beyond the rules outlined in the Copr FAQ at
<https://fedorahosted.org/copr/wiki/UserDocs#WhatIcanbuildinCopr>, and
packages are not held to any quality or security level.

Please do not file bug reports about these packages in Fedora
Bugzilla. In case of problems, contact the owner of this repository.

Do you want to continue? [y/N]: y
Error: This repository does not have any builds yet so you cannot enable it now.
Comment 68 Jaroslav Mracek 2017-01-12 12:10:33 EST
The repo supports Fc24+. Please try it again on Fc24+ system.
Comment 69 Harald Reindl 2017-01-12 12:20:18 EST
> Please try it again on Fc24+ system

what was unclear in "and there are no machines with F25 planned the next 2-3 months for several reasons" when this bug was initially reported for F22 and some smart guy thought it's cool to change it to rawhide?
Comment 70 Jaroslav Mracek 2017-01-12 12:31:01 EST
Please try it on fc24 system. In that repo there are available dnf packages as follows:

dnf-0:2.0.0_1-33gf0093d6.fc24.noarch
dnf-0:2.0.0_1-33gf0093d6.fc24.src
dnf-0:2.0.0_1-34g53fb86c.fc24.noarch
dnf-0:2.0.0_1-34g53fb86c.fc24.src
dnf-0:2.0.0_1-37g4cea33d.fc24.noarch
dnf-0:2.0.0_1-37g4cea33d.fc24.src
dnf-0:2.0.0_1-40gdb7f88b.fc24.noarch
dnf-0:2.0.0_1-40gdb7f88b.fc24.src
dnf-0:2.0.0_1-45ga03ea5a.fc24.noarch
dnf-0:2.0.0_1-45ga03ea5a.fc24.src
dnf-0:2.0.0_1-51g2148ca7.fc24.noarch
dnf-0:2.0.0_1-51g2148ca7.fc24.src
dnf-0:2.0.0_1-59gaa9ebc1.fc24.noarch
dnf-0:2.0.0_1-59gaa9ebc1.fc24.src

Last versions of DNF-2.0 contain unification of local package handling with packages from repo, therefore there shouldn't be any differences according to package source. Please try it on fc24 system that is the oldest supported fedora. Your experience with latest upstream version is critical for further dnf tuning and development. Thanks a lot for your time and feedback.
Comment 71 Harald Reindl 2017-01-12 13:33:57 EST
>  In that repo

well, you missed to mention "that" repo
Comment 72 Harald Reindl 2017-01-12 13:39:47 EST
and now it would be a good time to test something since dnf refuses to update the bind packages downloaded from koji while with "yum-deprecated" already deployed on the secondary production nameservers, primary follows tomorrow when there are no issues

[root@srv-rhsoft:/downloads]$ ls
total 3.7M
-rw-r----- 1 harry verwaltung 1.9M 2017-01-12 19:30 bind-9.10.4-3.P5.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung  91K 2017-01-12 19:30 bind-chroot-9.10.4-3.P5.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 152K 2017-01-12 19:30 bind-libs-9.10.4-3.P5.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung 1.1M 2017-01-12 19:30 bind-libs-lite-9.10.4-3.P5.fc24.x86_64.rpm
-rw-r----- 1 harry verwaltung  89K 2017-01-12 19:30 bind-license-9.10.4-3.P5.fc24.noarch.rpm
-rw-r----- 1 harry verwaltung 407K 2017-01-12 19:30 bind-utils-9.10.4-3.P5.fc24.x86_64.rpm


[root@srv-rhsoft:/downloads]$ dnf update *.rpm
rhsoft-repo for fedora                                                                                                                                                             8.1 MB/s | 244 kB     00:00
rhsoft-repo with generic rpms                                                                                                                                                      127 kB/s | 2.5 kB     00:00
Last metadata expiration check: 0:00:11 ago on Thu Jan 12 19:37:29 2017.
Error: nothing provides bind-libs(x86-64) = 32:9.10.4-3.P5.fc24 needed by bind-32:9.10.4-3.P5.fc24.x86_64.
package bind-libs-32:9.10.4-3.P5.fc24.x86_64 is not installable.
package bind-libs-lite-32:9.10.4-3.P5.fc24.x86_64 is not installable.
package bind-license-32:9.10.4-3.P5.fc24.noarch is not installable.
package bind-utils-32:9.10.4-3.P5.fc24.x86_64 is not installable.
nothing provides bind-libs(x86-64) = 32:9.10.4-3.P5.fc24 needed by bind-32:9.10.4-3.P5.fc24.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)
[root@srv-rhsoft:/downloads]$ dnf update *.rpm
Last metadata expiration check: 0:00:30 ago on Thu Jan 12 19:37:29 2017.
Error: nothing provides bind-libs(x86-64) = 32:9.10.4-3.P5.fc24 needed by bind-32:9.10.4-3.P5.fc24.x86_64.
package bind-libs-32:9.10.4-3.P5.fc24.x86_64 is not installable.
package bind-libs-lite-32:9.10.4-3.P5.fc24.x86_64 is not installable.
package bind-license-32:9.10.4-3.P5.fc24.noarch is not installable.
package bind-utils-32:9.10.4-3.P5.fc24.x86_64 is not installable.
nothing provides bind-libs(x86-64) = 32:9.10.4-3.P5.fc24 needed by bind-32:9.10.4-3.P5.fc24.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages)
Comment 73 Jaroslav Mracek 2017-01-12 15:43:21 EST
There is a pull-requested that represent solution recommended by Michael Schröder in commend 65 , but I still have a problem to reproduce original issue.
Comment 74 Harald Reindl 2017-01-12 16:11:36 EST
and what doe sthat mean in context of "Please try it on fc24 system. In that repo there are available dnf packages as follows" - *where* are the packages for F24?

"problem to reproduce original issue" - well, just get a F24 machine install the bind packages above in lower version, download the fresh builds from koji and try "dnf update *.rpm" - that don#t always happen in every combination and hence i am really annoyed by the unpreditability of the new proposed package manager for longer than a year while the old one just works fine as it did the past 10 years
Comment 75 Jaroslav Mracek 2017-01-13 03:49:33 EST
I am sorry, still I cannot reproduce your problem using your data. Please can you compare outputs and probably you can tell me difference. Thanks a lot.

$rpm -q bind bind-chroot bind-libs bind-libs-lite bind-license bind-utils rpm dnf libdnf
bind-9.10.4-1.P1.fc24.x86_64
bind-chroot-9.10.4-1.P1.fc24.x86_64
bind-libs-9.10.4-1.P1.fc24.x86_64
bind-libs-lite-9.10.4-1.P1.fc24.x86_64
bind-license-9.10.4-1.P1.fc24.noarch
bind-utils-9.10.4-1.P1.fc24.x86_64
rpm-4.13.0_alpha-443g979d52b.fc24.x86_64
dnf-2.0.0_1-59gaa9ebc1.fc24.noarch
libdnf-0.7.1-2gfe5a08b.fc24.x86_64

$ ls
bind-9.10.4-3.P5.fc24.x86_64.rpm
bind-chroot-9.10.4-3.P5.fc24.x86_64.rpm
bind-libs-9.10.4-3.P5.fc24.x86_64.rpm
bind-libs-lite-9.10.4-3.P5.fc24.x86_64.rpm
bind-license-9.10.4-3.P5.fc24.noarch.rpm
bind-utils-9.10.4-3.P5.fc24.x86_64.rpm

$ sudo dnf upgrade *.rpm
Last metadata expiration check: 0:46:20 ago on Fri Jan 13 08:59:12 2017 CET.
Dependencies resolved.
===========================================================================
 Package           Arch      Version                 Repository       Size
===========================================================================
Upgrading:
 bind              x86_64    32:9.10.4-3.P5.fc24     @commandline    1.9 M
 bind-chroot       x86_64    32:9.10.4-3.P5.fc24     @commandline     90 k
 bind-libs         x86_64    32:9.10.4-3.P5.fc24     @commandline    152 k
 bind-libs-lite    x86_64    32:9.10.4-3.P5.fc24     @commandline    1.0 M
 bind-license      noarch    32:9.10.4-3.P5.fc24     @commandline     89 k
 bind-utils        x86_64    32:9.10.4-3.P5.fc24     @commandline    406 k

Transaction Summary
===========================================================================
Upgrade  6 Packages

Total size: 3.7 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : bind-license-32:9.10.4-3.P5.fc24.noarch               1/12 
  Upgrading   : bind-libs-lite-32:9.10.4-3.P5.fc24.x86_64             2/12 
  Upgrading   : bind-libs-32:9.10.4-3.P5.fc24.x86_64                  3/12 
  Upgrading   : bind-32:9.10.4-3.P5.fc24.x86_64                       4/12 
  Upgrading   : bind-chroot-32:9.10.4-3.P5.fc24.x86_64                5/12 
  Upgrading   : bind-utils-32:9.10.4-3.P5.fc24.x86_64                 6/12 
  Cleanup     : bind-chroot-32:9.10.4-1.P1.fc24.x86_64                7/12 
  Cleanup     : bind-32:9.10.4-1.P1.fc24.x86_64                       8/12 
  Cleanup     : bind-utils-32:9.10.4-1.P1.fc24.x86_64                 9/12 
  Cleanup     : bind-libs-lite-32:9.10.4-1.P1.fc24.x86_64            10/12 
  Cleanup     : bind-libs-32:9.10.4-1.P1.fc24.x86_64                 11/12 
  Cleanup     : bind-license-32:9.10.4-1.P1.fc24.noarch              12/12 
  Verifying   : bind-32:9.10.4-3.P5.fc24.x86_64                       1/12 
  Verifying   : bind-libs-32:9.10.4-3.P5.fc24.x86_64                  2/12 
  Verifying   : bind-libs-lite-32:9.10.4-3.P5.fc24.x86_64             3/12 
  Verifying   : bind-license-32:9.10.4-3.P5.fc24.noarch               4/12 
  Verifying   : bind-chroot-32:9.10.4-3.P5.fc24.x86_64                5/12 
  Verifying   : bind-utils-32:9.10.4-3.P5.fc24.x86_64                 6/12 
  Verifying   : bind-32:9.10.4-1.P1.fc24.x86_64                       7/12 
  Verifying   : bind-chroot-32:9.10.4-1.P1.fc24.x86_64                8/12 
  Verifying   : bind-libs-32:9.10.4-1.P1.fc24.x86_64                  9/12 
  Verifying   : bind-libs-lite-32:9.10.4-1.P1.fc24.x86_64            10/12 
  Verifying   : bind-license-32:9.10.4-1.P1.fc24.noarch              11/12 
  Verifying   : bind-utils-32:9.10.4-1.P1.fc24.x86_64                12/12 

Upgraded:
  bind.x86_64 32:9.10.4-3.P5.fc24                                          
  bind-chroot.x86_64 32:9.10.4-3.P5.fc24                                   
  bind-libs.x86_64 32:9.10.4-3.P5.fc24                                     
  bind-libs-lite.x86_64 32:9.10.4-3.P5.fc24                                
  bind-license.noarch 32:9.10.4-3.P5.fc24                                  
  bind-utils.x86_64 32:9.10.4-3.P5.fc24                                    

Complete!

$ rpm -q bind bind-chroot bind-libs bind-libs-lite bind-license bind-utils rpm dnf libdnf
bind-9.10.4-3.P5.fc24.x86_64
bind-chroot-9.10.4-3.P5.fc24.x86_64
bind-libs-9.10.4-3.P5.fc24.x86_64
bind-libs-lite-9.10.4-3.P5.fc24.x86_64
bind-license-9.10.4-3.P5.fc24.noarch
bind-utils-9.10.4-3.P5.fc24.x86_64
rpm-4.13.0_alpha-443g979d52b.fc24.x86_64
dnf-2.0.0_1-59gaa9ebc1.fc24.noarch
libdnf-0.7.1-2gfe5a08b.fc24.x86_64
Comment 76 Harald Reindl 2017-01-13 04:13:20 EST
that's what "non deterministically" describes

however, would you please add the missing infos about which repo you are talking in https://bugzilla.redhat.com/show_bug.cgi?id=1263888#c70
Comment 77 Jaroslav Mracek 2017-01-13 04:37:53 EST
I am talking about this repo: dnf copr enable rpmsoftwaremanagement/dnf-nightly

.repo file contains:
[rpmsoftwaremanagement-dnf-nightly]
name=Copr repo for dnf-nightly owned by rpmsoftwaremanagement
baseurl=https://copr-be.cloud.fedoraproject.org/results/rpmsoftwaremanagement/dnf-nightly/fedora-$releasever-$basearch/
type=rpm-md
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/rpmsoftwaremanagement/dnf-nightly/pubkey.gpg
repo_gpgcheck=0
enabled=1
enabled_metadata=1



Additionally I tested it on VM with:
rpm-4.13.0_alpha-487gd1c988b.fc24.x86_64
dnf-2.0.0_1-59gaa9ebc1.fc24.noarch
libdnf-0.7.1-2gfe5a08b.fc24.x86_64
libsolv-0.6.24-15g50fc549.fc24.x86_64
python2-dnf-2.0.0_1-59gaa9ebc1.fc24.noarch
python3-dnf-2.0.0_1-59gaa9ebc1.fc24.noarch

It works like expected. I downgrade it as much as possible and it was working also. 

Probably can you try "dnf check" command?

Or --allowerasing option with upgrade command, just to see what happens. 

Or as attachment output from 'rpm -qa', or system specification, like free memory on that system.
Comment 78 Igor Gnatenko 2017-01-13 04:41:44 EST
(In reply to Jaroslav Mracek from comment #77)
> It works like expected. I downgrade it as much as possible and it was
> working also. 
I wasn't able to find some steps which would reproduce it in 100% of cases. Though I don't think it's related to DNF itself, I suppose libdnf.
> 
> Probably can you try "dnf check" command?
> 
> Or --allowerasing option with upgrade command, just to see what happens. 
Absolutely nothing, same results.
> 
> Or as attachment output from 'rpm -qa', or system specification, like free
> memory on that system.
That's not related.
Comment 79 Harald Reindl 2017-01-13 04:42 EST
Created attachment 1240283 [details]
rpm -qa

list of installed packages attached

memory can't be the problem
[harry@srv-rhsoft:~]$ free
              total        used        free      shared  buff/cache   available
Mem:            31G        4,2G        1,1G        324M         25G         26G
Swap:          1,1G        110M        1,0G

[root@srv-rhsoft:/downloads]$ dnf check
No such command: check. Please use /usr/bin/dnf --help
Comment 80 Jaroslav Mracek 2017-01-13 05:12:46 EST
You need to install dnf-2.0 from this repo: dnf copr enable rpmsoftwaremanagement/dnf-nightly

.repo file contains:
[rpmsoftwaremanagement-dnf-nightly]
name=Copr repo for dnf-nightly owned by rpmsoftwaremanagement
baseurl=https://copr-be.cloud.fedoraproject.org/results/rpmsoftwaremanagement/dnf-nightly/fedora-$releasever-$basearch/
type=rpm-md
skip_if_unavailable=True
gpgcheck=1
gpgkey=https://copr-be.cloud.fedoraproject.org/results/rpmsoftwaremanagement/dnf-nightly/pubkey.gpg
repo_gpgcheck=0
enabled=1
enabled_metadata=1

Then:
# dnf upgrade dnf
Or:
# dnf upgrade

And then perform tests again (dnf upgrade *.rpm), check command (dnf check) and so on.

Thanks a lot
Comment 81 Harald Reindl 2017-01-13 05:27:39 EST
as you can see at https://bugzilla.redhat.com/show_bug.cgi?id=1263888#c67 the command does not work, anyways, i created the repofile manually and once again you need yum-deprectated to get a useful output compared with the horrible mess "dnf --enablerepo dnf-nightly upgrade dnf" below

there are missing some Provides/Obsoletes "lounge-rhsoft-workstation" is nohting else than a meta-package defining dependencies so that i can safely remove anything listet by "dnf leaves"
_______________________________________________________

Error: Package: lounge-rhsoft-workstation-24.0-10.fc24.20161203.rh.noarch (installed)
           Requires: dnf-plugins-extras
           Removing: dnf-plugins-extras-0.0.12-3.fc24.noarch (installed)
               dnf-plugins-extras = 0.0.12-3.fc24
           Obsoleted By: dnf-plugins-extras-common-data-0.10.0_rc1-9g056b23c.fc24.noarch (dnf-nightly)
               Not found
           Updated By: dnf-plugins-extras-0.0.12-76gb69f9ca.fc24.noarch (dnf-nightly)
               dnf-plugins-extras = 0.0.12-76gb69f9ca.fc24
           Available: dnf-plugins-extras-0.0.12-2.fc24.noarch (fedora)
               dnf-plugins-extras = 0.0.12-2.fc24
_______________________________________________________

[root@srv-rhsoft:/etc/yum.repos.d]$ dnf --enablerepo dnf-nightly upgrade dnf
Copr repo for dnf-nightly owned by rpmsoftwaremanagement                                                                                                                           156 kB/s | 288 kB     00:01    
Last metadata expiration check: 0:00:11 ago on Fri Jan 13 11:12:50 2017.
Dependencies resolved.
===================================================================================================================================================================================================================
 Package                                                        Arch                           Version                                                               Repository                               Size
===================================================================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 at                                                             x86_64                         3.1.18-1.fc24                                                         fedora                                   71 k
 dnf                                                            noarch                         2.0.0_1-66ga24f756.fc24                                               dnf-nightly                             252 k
 dnf-conf                                                       noarch                         2.0.0_1-66ga24f756.fc24                                               dnf-nightly                              27 k
 dnf-plugins-core                                               noarch                         1.0.0_0.rc1.1-3g09133ec.fc24                                          dnf-nightly                              13 k
 dnf-plugins-extras-common-data                                 noarch                         0.10.0_rc1-9g056b23c.fc24                                             dnf-nightly                              68 k
 dnf-yum                                                        noarch                         2.0.0_1-66ga24f756.fc24                                               dnf-nightly                             9.2 k
 ed                                                             x86_64                         1.12-2.fc24                                                           fedora                                   77 k
 httrack                                                        x86_64                         3.48.22-1.fc24                                                        fedora                                  1.0 M
 libcomps                                                       x86_64                         0.1.8-3g01a4759.fc24                                                  dnf-nightly                              70 k
 libdnet                                                        x86_64                         1.12-17.fc24                                                          fedora                                   35 k
 libdnf                                                         x86_64                         0.7.1-2gfe5a08b.fc24                                                  dnf-nightly                             120 k
 libpng12                                                       x86_64                         1.2.56-2.fc24                                                         fedora                                  156 k
 librepo                                                        x86_64                         1.7.20-2ge1137cb.fc24                                                 dnf-nightly                              73 k
 lounge-arrakis                                                 noarch                         24.0-3.fc24.20161003.rh                                               rhsoft-fedora                           6.5 k
 lounge-multimedia                                              noarch                         24.0-1.fc24.20161003.rh                                               rhsoft-fedora                           5.8 k
 lounge-nameserver                                              noarch                         24.0-3.fc24.20161003.rh                                               rhsoft-fedora                           5.9 k
 mailgraph                                                      noarch                         1.14-27.fc24                                                          updates                                  32 k
 ncurses-compat-libs                                            x86_64                         6.0-6.20160709.fc24                                                   updates                                 302 k
 open-vm-tools                                                  x86_64                         10.0.5.3227872-3.fc24.20161003.rh                                     rhsoft-fedora                           586 k
 perl-Algorithm-Diff                                            noarch                         1.1903-4.fc24                                                         fedora                                   51 k
 perl-AppConfig                                                 noarch                         1.71-4.fc24                                                           fedora                                   86 k
 perl-Archive-Tar                                               noarch                         2.06-2.fc24                                                           updates                                  76 k
 perl-Archive-Zip                                               noarch                         1.58-1.fc24                                                           updates                                 106 k
 perl-B-Hooks-EndOfScope                                        noarch                         0.20-1.fc24                                                           fedora                                   40 k
 perl-B-Lint                                                    noarch                         1.20-6.fc24                                                           fedora                                   24 k
 perl-CPAN                                                      noarch                         2.11-350.fc24                                                         updates-testing                         548 k
 perl-CPAN-Meta                                                 noarch                         2.150005-3.fc24                                                       fedora                                  173 k
 perl-CPAN-Meta-Requirements                                    noarch                         2.140-2.fc24                                                          fedora                                   36 k
 perl-CPAN-Meta-YAML                                            noarch                         0.018-2.fc24                                                          fedora                                   32 k
 perl-Class-Accessor                                            noarch                         0.34-19.fc24                                                          fedora                                   32 k
 perl-Class-Accessor-Chained                                    noarch                         0.01-27.fc24                                                          fedora                                   17 k
 perl-Class-Factory-Util                                        noarch                         1.7-22.fc24                                                           fedora                                   22 k
 perl-Class-ISA                                                 noarch                         0.36-1017.fc24                                                        fedora                                   14 k
 perl-Class-Inspector                                           noarch                         1.31-2.fc24                                                           updates                                  34 k
 perl-Class-Load                                                noarch                         0.23-2.fc24                                                           fedora                                   35 k
 perl-Class-Singleton                                           noarch                         1.5-4.fc24                                                            fedora                                   22 k
 perl-Class-Std-Fast                                            noarch                         0.0.8-14.fc24.20161003.rh                                             rhsoft-fedora                            17 k
 perl-Compress-Bzip2                                            x86_64                         2.25-1.fc24                                                           updates                                  69 k
 perl-Convert-BinHex                                            noarch                         1.125-2.fc24                                                          fedora                                   48 k
 perl-Data-OptList                                              noarch                         0.110-1.fc24                                                          fedora                                   30 k
 perl-Data-Section                                              noarch                         0.200006-6.fc24                                                       fedora                                   28 k
 perl-Date-ISO8601                                              noarch                         0.004-13.fc24                                                         fedora                                   21 k
 perl-DateTime                                                  x86_64                         2:1.28-2.fc24                                                         updates                                 132 k
 perl-DateTime-Format-Builder                                   noarch                         0.8100-9.fc24                                                         fedora                                   82 k
 perl-DateTime-Format-ISO8601                                   noarch                         0.08-11.fc24                                                          fedora                                   31 k
 perl-DateTime-Format-Strptime                                  noarch                         1:1.68-1.fc24                                                         fedora                                   41 k
 perl-DateTime-Locale                                           noarch                         1.03-1.fc24                                                           fedora                                  2.1 M
 perl-DateTime-TimeZone                                         noarch                         2.01-6.fc24                                                           updates                                 410 k
 perl-DateTime-TimeZone-SystemV                                 noarch                         0.009-6.fc24                                                          fedora                                   25 k
 perl-DateTime-TimeZone-Tzfile                                  noarch                         0.010-4.fc24                                                          fedora                                   22 k
 perl-Devel-Size                                                x86_64                         0.80-4.fc24                                                           fedora                                   45 k
 perl-Dist-CheckConflicts                                       noarch                         0.11-6.fc24                                                           fedora                                   26 k
 perl-Email-Date-Format                                         noarch                         1.005-4.fc24                                                          fedora                                   21 k
 perl-Email-Valid                                               noarch                         1.200-1.fc24                                                          fedora                                   26 k
 perl-Env                                                       noarch                         1.04-347.fc24                                                         fedora                                   20 k
 perl-Exporter-Tiny                                             noarch                         0.042-5.fc24                                                          fedora                                   41 k
 perl-ExtUtils-CBuilder                                         noarch                         1:0.280224-2.fc24                                                     fedora                                   47 k
 perl-ExtUtils-Command                                          noarch                         7.10-5.fc24                                                           updates                                  17 k
 perl-ExtUtils-Install                                          noarch                         2.04-348.fc24                                                         fedora                                   45 k
 perl-ExtUtils-MM-Utils                                         noarch                         7.10-5.fc24                                                           updates                                  15 k
 perl-ExtUtils-MakeMaker                                        noarch                         7.10-5.fc24                                                           updates                                 279 k
 perl-ExtUtils-Manifest                                         noarch                         1.70-347.fc24                                                         fedora                                   36 k
 perl-ExtUtils-ParseXS                                          noarch                         1:3.30-3.fc24                                                         updates                                  81 k
 perl-File-CheckTree                                            noarch                         4.42-296.fc24                                                         fedora                                   22 k
 perl-File-HomeDir                                              noarch                         1.00-11.fc24                                                          fedora                                   61 k
 perl-File-Tail                                                 noarch                         1.3-2.fc24                                                            fedora                                   29 k
 perl-File-Which                                                noarch                         1.21-1.fc24                                                           fedora                                   23 k
 perl-IO-SessionData                                            noarch                         1.03-6.fc24                                                           fedora                                   13 k
 perl-IO-Zlib                                                   noarch                         1:1.10-365.fc24                                                       updates                                  67 k
 perl-IPC-Cmd                                                   noarch                         1:0.96-1.fc24                                                         updates                                  41 k
 perl-IPC-System-Simple                                         noarch                         1.25-8.fc24                                                           fedora                                   41 k
 perl-Image-Base                                                noarch                         1.17-5.fc24                                                           fedora                                   26 k
 perl-Image-Info                                                noarch                         1.38-6.fc24                                                           updates                                  86 k
 perl-Image-Xbm                                                 noarch                         1.09-2.fc24                                                           fedora                                   22 k
 perl-Image-Xpm                                                 noarch                         1.12-4.fc24                                                           fedora                                   23 k
 perl-LWP-Protocol-https                                        noarch                         6.06-7.fc24                                                           fedora                                   16 k
 perl-List-MoreUtils                                            x86_64                         0.415-1.fc24                                                          fedora                                   78 k
 perl-Locale-Codes                                              noarch                         3.42-1.fc24                                                           updates                                 300 k
 perl-Locale-Maketext                                           noarch                         1.26-349.fc24                                                         updates                                  95 k
 perl-Locale-Maketext-Simple                                    noarch                         1:0.21-365.fc24                                                       updates                                  66 k
 perl-MIME-Lite                                                 noarch                         3.030-6.fc24                                                          fedora                                  100 k
 perl-MIME-Types                                                noarch                         2.13-1.fc24                                                           fedora                                   69 k
 perl-MIME-tools                                                noarch                         5.507-3.fc24                                                          fedora                                  247 k
 perl-MRO-Compat                                                noarch                         0.12-10.fc24                                                          fedora                                   23 k
 perl-MailTools                                                 noarch                         2.18-1.fc24                                                           fedora                                  107 k
 perl-Module-Build                                              noarch                         2:0.42.18-1.fc24                                                      fedora                                  271 k
 perl-Module-CoreList                                           noarch                         1:5.20161220-1.fc24                                                   updates-testing                          77 k
 perl-Module-Implementation                                     noarch                         0.09-6.fc24                                                           fedora                                   22 k
 perl-Module-Load                                               noarch                         1:0.32-347.fc24                                                       fedora                                   18 k
 perl-Module-Load-Conditional                                   noarch                         0.68-1.fc24                                                           updates                                  24 k
 perl-Module-Metadata                                           noarch                         1.000027-4.fc24                                                       fedora                                   40 k
 perl-Module-Pluggable                                          noarch                         2:5.2-2.fc24                                                          fedora                                   33 k
 perl-Module-Runtime                                            noarch                         0.014-7.fc24                                                          fedora                                   24 k
 perl-Mozilla-CA                                                noarch                         20160104-2.fc24                                                       fedora                                   14 k
 perl-Net-DRI                                                   noarch                         0.96_09-3.fc24.20161003.rh                                            rhsoft-fedora                           516 k
 perl-Net-Ping                                                  noarch                         2.43-365.fc24                                                         updates                                  82 k
 perl-Net-SMTP-SSL                                              noarch                         1.03-2.fc24                                                           fedora                                   14 k
 perl-Package-DeprecationManager                                noarch                         0.16-1.fc24                                                           fedora                                   27 k
 perl-Package-Generator                                         noarch                         1.106-6.fc24                                                          fedora                                   26 k
 perl-Package-Stash                                             noarch                         0.37-4.fc24                                                           fedora                                   41 k
 perl-Package-Stash-XS                                          x86_64                         0.28-9.fc24                                                           fedora                                   36 k
 perl-Params-Check                                              noarch                         1:0.38-347.fc24                                                       fedora                                   22 k
 perl-Params-Classify                                           x86_64                         0.013-15.fc24                                                         fedora                                   32 k
 perl-Params-Util                                               x86_64                         1.07-15.fc24                                                          fedora                                   42 k
 perl-Params-Validate                                           x86_64                         1.26-1.fc24                                                           updates                                  75 k
 perl-Parse-CPAN-Meta                                           noarch                         1:1.4417-3.fc24                                                       fedora                                   30 k
 perl-Perl-OSType                                               noarch                         1.009-2.fc24                                                          fedora                                   27 k
 perl-Pod-Checker                                               noarch                         4:1.71-6.fc24                                                         fedora                                   31 k
 perl-Pod-Html                                                  noarch                         1.22-365.fc24                                                         updates                                  74 k
 perl-Pod-LaTeX                                                 noarch                         0.61-297.fc24                                                         fedora                                   40 k
 perl-Pod-POM                                                   noarch                         2.01-3.fc24                                                           fedora                                   97 k
 perl-Pod-Plainer                                               noarch                         1.04-2.fc24                                                           fedora                                   13 k
 perl-SOAP-Lite                                                 noarch                         1.20-1.fc24                                                           updates                                 290 k
 perl-SOAP-WSDL                                                 noarch                         3.003-2.fc24.20161003.rh                                              rhsoft-fedora                           182 k
 perl-Software-License                                          noarch                         0.103012-1.fc24                                                       fedora                                  129 k
 perl-Sub-Exporter                                              noarch                         0.987-8.fc24                                                          fedora                                   72 k
 perl-Sub-Exporter-Progressive                                  noarch                         0.001011-6.fc24                                                       fedora                                   17 k
 perl-Sub-Identify                                              x86_64                         0.12-2.fc24                                                           fedora                                   26 k
 perl-Sub-Install                                               noarch                         0.928-7.fc24                                                          fedora                                   26 k
 perl-Sub-Name                                                  x86_64                         0.15-1.fc24                                                           fedora                                   32 k
 perl-Template-Toolkit                                          x86_64                         2.26-4.fc24                                                           fedora                                  1.4 M
 perl-Test                                                      noarch                         1.26-365.fc24                                                         updates                                  76 k
 perl-Test-Harness                                              noarch                         3.36-3.fc24                                                           updates                                 276 k
 perl-Test-Simple                                               noarch                         1.001014-347.fc24                                                     fedora                                  203 k
 perl-Text-Diff                                                 noarch                         1.44-1.fc24                                                           fedora                                   44 k
 perl-Text-Glob                                                 noarch                         0.09-15.fc24                                                          fedora                                   16 k
 perl-Text-Template                                             noarch                         1.46-4.fc24                                                           fedora                                   67 k
 perl-Try-Tiny                                                  noarch                         0.24-2.fc24                                                           fedora                                   41 k
 perl-Variable-Magic                                            x86_64                         0.59-2.fc24                                                           fedora                                   56 k
 perl-XML-LibXML                                                x86_64                         1:2.0128-1.fc24                                                       updates                                 366 k
 perl-XML-Parser                                                x86_64                         2.44-4.fc24                                                           fedora                                  224 k
 perl-XML-SAX                                                   noarch                         0.99-16.fc24                                                          fedora                                   64 k
 perl-XML-Simple                                                noarch                         2.22-2.fc24                                                           fedora                                   85 k
 perl-XMLRPC-Lite                                               noarch                         0.717-6.fc24                                                          fedora                                   32 k
 perl-autodie                                                   noarch                         2.29-2.fc24                                                           fedora                                   97 k
 perl-inc-latest                                                noarch                         2:0.500-4.fc24                                                        fedora                                   24 k
 perl-local-lib                                                 noarch                         2.000018-2.fc24                                                       fedora                                   72 k
 perl-namespace-autoclean                                       noarch                         0.28-2.fc24                                                           fedora                                   30 k
 perl-namespace-clean                                           noarch                         0.26-2.fc24                                                           fedora                                   35 k
 perl-version                                                   x86_64                         5:0.99.17-1.fc24                                                      updates                                  96 k
 php-pdo                                                        x86_64                         7.1.1-1.0.fc24.20170110.1541.rh.sandybridge                           rhsoft-fedora                            91 k
 python3-dnf                                                    noarch                         2.0.0_1-66ga24f756.fc24                                               dnf-nightly                             405 k
 python3-dnf-plugins-core                                       noarch                         1.0.0_0.rc1.1-3g09133ec.fc24                                          dnf-nightly                              71 k
 python3-dnf-plugins-extras-common                              noarch                         0.10.0_rc1-9g056b23c.fc24                                             dnf-nightly                             9.7 k
 python3-dnf-plugins-extras-leaves                              noarch                         0.10.0_rc1-9g056b23c.fc24                                             dnf-nightly                              11 k
 python3-dnf-plugins-extras-repomanage                          noarch                         0.10.0_rc1-9g056b23c.fc24                                             dnf-nightly                              12 k
 python3-dnf-plugins-extras-show-leaves                         noarch                         0.10.0_rc1-9g056b23c.fc24                                             dnf-nightly                             9.7 k
 python3-hawkey                                                 x86_64                         0.7.1-2gfe5a08b.fc24                                                  dnf-nightly                              50 k
 python3-libcomps                                               x86_64                         0.1.8-3g01a4759.fc24                                                  dnf-nightly                              42 k
 python3-librepo                                                x86_64                         1.7.20-2ge1137cb.fc24                                                 dnf-nightly                              42 k
 qt3                                                            x86_64                         3.3.8b-67.fc24                                                        fedora                                  3.4 M
 redhat-lsb                                                     x86_64                         4.1-33.fc24                                                           updates                                  28 k
 redhat-lsb-core                                                x86_64                         4.1-33.fc24                                                           updates                                  42 k
 redhat-lsb-cxx                                                 x86_64                         4.1-33.fc24                                                           updates                                  20 k
 redhat-lsb-desktop                                             x86_64                         4.1-33.fc24                                                           updates                                  24 k
 redhat-lsb-languages                                           x86_64                         4.1-33.fc24                                                           updates                                  22 k
 redhat-lsb-printing                                            x86_64                         4.1-33.fc24                                                           updates                                  20 k
 redhat-lsb-submod-multimedia                                   x86_64                         4.1-33.fc24                                                           updates                                  19 k
 redhat-lsb-submod-security                                     x86_64                         4.1-33.fc24                                                           updates                                  19 k
 roundcubemail                                                  noarch                         2:1.2.3-2.fc24.20161129.rh                                            rhsoft-fedora                           3.4 M
 spax                                                           x86_64                         1.5.3-6.fc24                                                          fedora                                  213 k
 up-imapproxy                                                   x86_64                         1.2.8-6.fc24.20161012.rh                                              rhsoft-fedora                            37 k
 util-linux-user                                                x86_64                         2.28.2-1.fc24                                                         updates                                  90 k

Transaction Summary
===================================================================================================================================================================================================================
Skip  163 Packages

Nothing to do.
Complete!
Comment 82 Jaroslav Mracek 2017-01-13 07:58:14 EST
Ok, please try  'dnf  --allowerasing --enablerepo dnf-nightly upgrade dnf'
or
'dnf --allowerasing --best --enablerepo dnf-nightly upgrade dnf'

I am sure that you will like the dnf-2.0. Many fixes are there and only there including many new features.
Comment 83 Harald Reindl 2017-01-13 08:10:11 EST
"--allowerasing --best" would remove the metapackage which is luckily protected and stop, do you really think that i did not try that?

as said there are missing Provides/Obsoletes 

Error: Package: lounge-rhsoft-workstation-24.0-10.fc24.20161203.rh.noarch (installed)
           Requires: dnf-plugins-extras
           Removing: dnf-plugins-extras-0.0.12-3.fc24.noarch (installed)
               dnf-plugins-extras = 0.0.12-3.fc24
           Obsoleted By: dnf-plugins-extras-common-data-0.10.0_rc1-9g056b23c.fc24.noarch (dnf-nightly)
               Not found
           Updated By: dnf-plugins-extras-0.0.12-76gb69f9ca.fc24.noarch (dnf-nightly)
               dnf-plugins-extras = 0.0.12-76gb69f9ca.fc24
           Available: dnf-plugins-extras-0.0.12-2.fc24.noarch (fedora)
               dnf-plugins-extras = 0.0.12-2.fc24
Comment 84 Jaroslav Mracek 2017-01-13 09:41:14 EST
The problem with provides we are going to fix in pull-request: https://github.com/rpm-software-management/dnf-plugins-extras/pull/80
Comment 85 Jaroslav Mracek 2017-01-13 10:35 EST
Created attachment 1240376 [details]
dnf-extras that should be installable

Please can you try to update system with provided rpms of extras. It should help to overcome the problem with dnf-plugins-extras provides
Comment 86 Harald Reindl 2017-01-13 10:40:10 EST
that are F25 packages and i doubt that it works well update one piece manually and after that try to get the rest from the repo - that packages belong to the nightly repos in their F24 incarnation
Comment 87 Jaroslav Mracek 2017-01-13 11:13 EST
Created attachment 1240395 [details]
Fc24 extras

Sorry for previous build for Fc25. This one is for Fc24. The rest of related packages should be installed from repos as you mentioned. I try to get clue whats wrong as fast as it is possible.
Comment 88 Harald Reindl 2017-01-16 08:36:42 EST
frankly how do you imagine to solve that chicken-egg-problem installing packages from the attachment and what is the problem not be able to add them to the repo in the last few days?

[root@srv-rhsoft:/downloads/extras-fc24]$ rpm -Uvh python3-dnf-plugins-extras-show-leaves-0.10.0-1.git.283.dda3720.fc24.noarch.rpm python3-dnf-plugins-extras-common-0.10.0-1.git.283.dda3720.fc24.noarch.rpm python3-dnf-plugins-extras-repomanage-0.10.0-1.git.283.dda3720.fc24.noarch.rpm dnf-plugins-extras-common-data-0.10.0-1.git.283.dda3720.fc24.noarch.rpm python3-dnf-plugins-extras-leaves-0.10.0-1.git.283.dda3720.fc24.noarch.rpm
error: Failed dependencies:
        python3-dnf >= 2.0 is needed by python3-dnf-plugins-extras-common-0.10.0-1.git.283.dda3720.fc24.noarch
Comment 89 Harald Reindl 2017-01-16 08:40:10 EST
OK, using the old dnf was in that case able to solve the deps and it also looks like the new one was at least able to update the bind-packages from donwloads-folder

anyways, the repo should be complete!

dnf --enablerepo=dnf-nightly install python3-dnf-plugins-extras-show-leaves-0.10.0-1.git.283.dda3720.fc24.noarch.rpm python3-dnf-plugins-extras-common-0.10.0-1.git.283.dda3720.fc24.noarch.rpm python3-dnf-plugins-extras-repomanage-0.10.0-1.git.283.dda3720.fc24.noarch.rpm dnf-plugins-extras-common-data-0.10.0-1.git.283.dda3720.fc24.noarch.rpm python3-dnf-plugins-extras-leaves-0.10.0-1.git.283.dda3720.fc24.noarch.rpm
Comment 90 Harald Reindl 2017-01-16 08:43:15 EST
but it looks like it's better not leave the repo enabled since there are still broken deps including rpm-python3 and install a rpm-4.13.0_alpha-489g1949aaa.fc24 is scary

[root@srv-rhsoft:/downloads]$ dnf upgrade
Last metadata expiration check: 0:00:00 ago on Mon Jan 16 14:40:57 2017 CET.
[master f5d1a5f] saving uncommitted changes in /etc prior to yum run
 1 file changed, 1 insertion(+), 1 deletion(-)
Dependencies resolved.
===================================================================================================================================================================================================================
 Package                                                            Arch                               Version                                                   Repository                                   Size
===================================================================================================================================================================================================================
Upgrading:
 bind99-libs                                                        x86_64                             9.9.9-4.P5.fc24                                           updates-testing                             670 k
 bind99-license                                                     noarch                             9.9.9-4.P5.fc24                                           updates-testing                              12 k
 createrepo_c                                                       x86_64                             0.10.0-40g748891f.fc24                                    dnf-nightly                                  58 k
 createrepo_c-libs                                                  x86_64                             0.10.0-40g748891f.fc24                                    dnf-nightly                                  84 k
 libsolv                                                            x86_64                             0.6.24-15g50fc549.fc24                                    dnf-nightly                                 351 k
 rpm                                                                x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                 468 k
 rpm-build-libs                                                     x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                  81 k
 rpm-libs                                                           x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                 263 k
 rpm-plugin-selinux                                                 x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                  12 k
 rpm-plugin-systemd-inhibit                                         x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                  12 k
Installing dependencies:
 python2-rpm                                                        x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                  61 k
     replacing  rpm-python.x86_64 4.13.0-1.fc24
 python3-rpm                                                        x86_64                             4.13.0_alpha-489g1949aaa.fc24                             dnf-nightly                                  61 k
     replacing  rpm-python3.x86_64 4.13.0-1.fc24
Skipping packages with broken dependencies:
 dnf-plugins-extras-common-data                                     noarch                             0.10.0_rc1-9g056b23c.fc24                                 dnf-nightly                                  68 k
 python3-dnf-plugins-extras-common                                  noarch                             0.10.0_rc1-9g056b23c.fc24                                 dnf-nightly                                 9.7 k
 python3-dnf-plugins-extras-leaves                                  noarch                             0.10.0_rc1-9g056b23c.fc24                                 dnf-nightly                                  11 k
 python3-dnf-plugins-extras-repomanage                              noarch                             0.10.0_rc1-9g056b23c.fc24                                 dnf-nightly                                  12 k
 python3-dnf-plugins-extras-show-leaves                             noarch                             0.10.0_rc1-9g056b23c.fc24                                 dnf-nightly                                 9.7 k
 rpm-python                                                         x86_64                             4.13.0_alpha-253g9571218.fc24                             dnf-nightly                                  59 k
 rpm-python3                                                        x86_64                             4.13.0_alpha-253g9571218.fc24                             dnf-nightly                                  59 k

Transaction Summary
===================================================================================================================================================================================================================
Install   2 Packages
Upgrade  10 Packages
Skip      7 Packages

Total download size: 2.1 M
Is this ok [y/N]:
Comment 91 Harald Reindl 2017-01-16 08:57:19 EST
and it don't really work proper

first "dnf upgrade" on my second machien showed some updates in know they are there, solved deps and than spit out a ton of xml errors - after "rm -rf /var/cache/dnf/*" repeatly repos disabled and no mentioning why

dnf2 still don't report the reasons *why* dependencies can not be solved and only list affected packages - i want my times back where the package manager was a solid base on Fedora and talked clearly what are the problems

[root@rh:~]$ dnf upgrade
Last metadata expiration check: 0:00:13 ago on Mon Jan 16 14:54:29 2017 CET.
Failed to synchronize cache for repo 'fedora', disabling.
Failed to synchronize cache for repo 'updates-testing', disabling.
Failed to synchronize cache for repo 'updates', disabling.
Dependencies resolved.
Nothing to do.
Complete!
Comment 92 Harald Reindl 2017-01-16 08:59:59 EST
[root@srv-rhsoft:/downloads]$ dnf upgrade
Last metadata expiration check: 0:00:00 ago on Mon Jan 16 14:57:33 2017 CET.
Dependencies resolved.
===================================================================================================================================================================================================================
 Package                                             Arch                                        Version                                                Repository                                            Size
===================================================================================================================================================================================================================
Upgrading:
 bind99-libs                                         x86_64                                      9.9.9-4.P5.fc24                                        updates-testing                                      670 k
 bind99-license                                      noarch                                      9.9.9-4.P5.fc24                                        updates-testing                                       12 k

Transaction Summary
===================================================================================================================================================================================================================
Upgrade  2 Packages

Total download size: 682 k
Is this ok [y/N]: y
Downloading Packages:
[MIRROR] bind99-libs-9.9.9-4.P5.fc24.x86_64.rpm: Curl error (6): Couldn't resolve host name for http://<metalink version="3.0" xmlns="http://www.metalinker.org/" type="dynamic" pubdate="Mon, 16 Jan 2017 13:59:29 GMT" generator="mirrormanager" xmlns:mm0="http://fedorahosted.org/mirrormanager">/b/bind99-libs-9.9.9-4.P5.fc24.x86_64.rpm [Could not resolve host: <metalink version="3.0" xmlns="http]
[MIRROR] bind99-license-9.9.9-4.P5.fc24.noarch.rpm: Curl error (6): Couldn't resolve host name for http://<metalink version="3.0" xmlns="http://www.metalinker.org/" type="dynamic" pubdate="Mon, 16 Jan 2017 13:59:29 GMT" generator="mirrormanager" xmlns:mm0="http://fedorahosted.org/mirrormanager">/b/bind99-license-9.9.9-4.P5.fc24.noarch.rpm [Could not resolve host: <metalink version="3.0" xmlns="http]
[MIRROR] bind99-libs-9.9.9-4.P5.fc24.x86_64.rpm: Curl error (6): Couldn't resolve host name for http://<url protocol="http" type="http" location="CZ" preference="100" >http://mirror.karneval.cz/pub/linux/fedora/
Comment 93 Jaroslav Mracek 2017-01-17 10:07:03 EST
Thanks for the report. I am really sorry but due to problem to reproduce your problem I have to close the bug.
Comment 94 Jaroslav Mracek 2017-01-17 10:07:55 EST
Thanks for the report. I am really sorry but due to problem to reproduce your problem I have to close the bug.
Comment 95 Jaroslav Mracek 2017-01-17 10:08:15 EST
Thanks for the report. I am really sorry but due to problem to reproduce your problem I have to close the bug.
Comment 96 Harald Reindl 2017-01-17 10:17:25 EST
thank you for nothing - hopefully i can downgrade DNF to something working - my feelings for DNF2 and not "I am sure that you will like the dnf-2.0" are the opposite, when i disable all repos with --disablerepo=\* --enablerepo=myown it works, as usually DNF don't give any usefull output and so the "INSUFFICIENT_DATA" are because it works like a damned blackbox as it always did while YUM for so many years gave useful informations WHY things are going wrong which where alaways helpful to nail down issues with packages and dependencies

DNF is designed for a sunny world not overwhlem the ordianry user with informations while the developers don't get the the ordinary user is not the target the are developing for because the ordianry user typically don't use DNF or YUM at all
Comment 97 Vít Ondruch 2017-01-17 11:01:43 EST
This is the same reproducer as in comment 59, this time even without mock:


1. dnf --installroot /tmp/rhbz1263888 --releasever 26 --disableplugin=local --setopt=deltarpm=false install @buildsys-build -y

2. dnf --installroot /tmp/rhbz1263888 --releasever 26 --disableplugin=local --setopt=deltarpm=false install https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-X11-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-common-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-enhanced-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-filesystem-8.0.086-1.fc26.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/vim/8.0.086/1.fc26/x86_64/vim-minimal-8.0.086-1.fc26.x86_64.rpm vim-commentary vim-taglist vim-fugitive vim-nerdtree sudo


And it still fails the same way. This time using latest DNF:

$ rpm -q dnf
dnf-2.0.0_1-69gf8980f8.fc26.noarch
Comment 98 Jaroslav Mracek 2017-01-18 04:45:57 EST
The problem described in Comment 97 looks like that libsolv do not take correctly files provides from @commandline repo. I refactored repoquery to accept .rpm and with -l option it shows that vim-minimal-8.0.086-1.fc26.x86_64.rpm has /usr/bin/vi file.

I am creating libsolv issue.
Comment 99 Michael Schröder 2017-01-18 04:58:48 EST
(Don't bother, it's not a libsolv issue. commandline repos are not special to libsolv.)
Comment 100 Igor Gnatenko 2017-01-19 15:19:08 EST
*** Bug 1414961 has been marked as a duplicate of this bug. ***
Comment 101 Jaroslav Mracek 2017-01-20 09:38:27 EST
Probably I have found a solution for that: https://github.com/rpm-software-management/libdnf/pull/243.

Michael Schroeder was completely right, the problem was not in libsolv, but in libdnf. 

Hope that it will help for all cases.
Comment 102 Honza Silhan 2017-01-23 08:41:47 EST
(In reply to Harald Reindl from comment #83)
> "--allowerasing --best" would remove the metapackage which is luckily
> protected and stop, do you really think that i did not try that?
> 
> as said there are missing Provides/Obsoletes 
> 
> Error: Package: lounge-rhsoft-workstation-24.0-10.fc24.20161203.rh.noarch
> (installed)
>            Requires: dnf-plugins-extras
>            Removing: dnf-plugins-extras-0.0.12-3.fc24.noarch (installed)
>                dnf-plugins-extras = 0.0.12-3.fc24
>            Obsoleted By:
> dnf-plugins-extras-common-data-0.10.0_rc1-9g056b23c.fc24.noarch (dnf-nightly)
>                Not found
>            Updated By: dnf-plugins-extras-0.0.12-76gb69f9ca.fc24.noarch
> (dnf-nightly)
>                dnf-plugins-extras = 0.0.12-76gb69f9ca.fc24
>            Available: dnf-plugins-extras-0.0.12-2.fc24.noarch (fedora)
>                dnf-plugins-extras = 0.0.12-2.fc24

(In reply to Jaroslav Mracek from comment #84)
> The problem with provides we are going to fix in pull-request:
> https://github.com/rpm-software-management/dnf-plugins-extras/pull/80

FYI in this sub-issue no package currently provides `dnf-plugins-extras` and we will not introduce it again. Any package requiring plugins from extras should require the exact plugins. Please ask devs of such 3rd party packages to change the packaging if you encounter this wrong dependency requirement. Thanks.
Comment 103 Harald Reindl 2017-01-23 08:55:57 EST
I AM that 3rd party

so what are the *exact* replacements for that and how do you imagine making people happy when you permanently chnage packaging and options?

the same for rename options back to "includepkgs" and "excludepkgs"

 i told you guys that it is a bad idea as you renamed it to "exclude" and "include" for no good reason, but i was blamed with a larg eportion of arrogance to shutup and that you are NDF not YUM

now you change it again in the oother direction and each and every admin out tthere needs to revert a previous harmful change again - stop kidding users please
Comment 104 Harald Reindl 2017-01-23 08:58:02 EST
> we will not introduce it again

yeah because you are DNF

every other package in the Fedora world would just define a metapackage pulling *all* subpackages as a soft-dep which can be removed and then you could also remove un-needed subpackages without any downsides for the users and 3rd parties
Comment 105 Igor Gnatenko 2017-01-23 08:59:41 EST
(In reply to Harald Reindl from comment #104)
> > we will not introduce it again
> 
> yeah because you are DNF
> 
> every other package in the Fedora world would just define a metapackage
> pulling *all* subpackages as a soft-dep which can be removed and then you
> could also remove un-needed subpackages without any downsides for the users
> and 3rd parties
and 1) get it back after update 2) cause lots of problems, because e.g. you don't have FS/setup which supports snapshots (hi snapper plugin)

It doesn't make any sense to pull all plugins if 90% of them will just print errors and install ton of useless dependencies.
Comment 106 Harald Reindl 2017-01-23 09:14:45 EST
it also don't make sense introduce all the time arbitrary changes forth and back especially when the where flamewars in the past not to intrduce some of that changes from the begin and now after they got sucked and adopted by users change it back

where is the documentation what i need to change instead define "dnf-plugins-extras" als requirement to make sure all teh cureently installed features are unchanged present

it took long enough the get man yof the yum features back and something like "yum --security update" is still missing

another arbitrary change i saw the sohort tinmeframe with the broken DNF2.0 on 24 the script below was no longer quite and asked for something spitting a "Y" every day in a cron mail - in the past the same script with YUM used --security on production servers - viola cron mails only if there are new scurity updates, worked like a charm for years and since "yum-deprecated" even if called explicit warns about deprecation of yum no longer useable

[root@srv-rhsoft:~]$ cat /etc/cron.daily/check-updates.cron
#!/bin/bash
yum_output=`LANG=C; /usr/bin/dnf -q check-update`
echo $yum_output | xargs | sed 's/ updates//g' | tr -d '\n'
Comment 107 Vít Ondruch 2017-01-23 09:19:12 EST
(In reply to Harald Reindl from comment #106)
While you have my sympathy, could you please stick to the topic please?
Comment 108 Harald Reindl 2017-01-23 09:23:25 EST
back to topic?

give me a relieable package manager as it was before F22 NOW because it's long enough that we have to deal with the pre-alpha in GA releases
Comment 109 Honza Silhan 2017-01-23 09:23:51 EST
(In reply to Harald Reindl from comment #103)
> I AM that 3rd party
> 
> so what are the *exact* replacements for that

If you are calling plugins from bash then:
`Requires: dnf-command(<nameofplugincommand>)` [1]

If you require passive plugin (unlikely) then:
`Requires: dnf-plugins-extras-<nameofplugin>`

If it's calling Python API then:
`Requires: python[23]-dnf-plugins-extras-<nameofplugin>`

> and how do you imagine making
> people happy when you permanently chnage packaging and options?
> 
> the same for rename options back to "includepkgs" and "excludepkgs"
> ...
>  i told you guys that it is a bad idea as you renamed it to "exclude" and
> "include" for no good reason, but i was blamed with a larg eportion of
> arrogance to shutup and that you are NDF not YUM
> 
> now you change it again in the oother direction and each and every admin out
> tthere needs to revert a previous harmful change again - stop kidding users
> please

we have at least tried to make it as much as compatible as before in DNF-1 so `include` should still work. This all was part of bigger change in DNF-2.0. I am sorry for issues but these intentional changes were done for making DNF compatible with yum (when the compatibility was broken). It was done at once to don't change DNF behaviour or API in following years.

[1] http://dnf.readthedocs.io/en/latest/command_ref.html#description
Comment 110 Mike Goodwin 2017-02-24 13:26:18 EST
I'm reading this ticket because I came across this in the folloing manner trying to test a new build of chromium

At the date of this ticket, and on F25, the current chromium version is: 

  chromium.x86_64 55.0.2883.87-1.fc25

The advisory for the 56 update is: FEDORA-2017-583538ec31

  mkdir chromium56_update && cd chromium56_update
  bodhi -D chromium-56.0.2924.87-3.fc25
Comment 111 Mike Goodwin 2017-02-24 13:29:41 EST
I'm reading this ticket because I came across this in the folloing manner trying to test a new build of chromium

At the date of this ticket, and on F25, the current chromium version is: 

  chromium.x86_64 55.0.2883.87-1.fc25

The advisory for the 56 update is: FEDORA-2017-583538ec31

  mkdir chromium56_update && cd chromium56_update
  bodhi -D chromium-56.0.2924.87-3.fc25
  sudo dnf upgrade ./*.rpm 

Yeilds:

Last metadata expiration check: 2:42:53 ago on Fri Feb 24 10:23:36 2017.
Package chromedriver not installed, cannot update it.
Package chrome-remote-desktop not installed, cannot update it.
Package chromium-native_client not installed, cannot update it.
Error: package chromium-56.0.2924.87-3.fc25.x86_64 is disabled.
package chromium-libs-56.0.2924.87-3.fc25.x86_64 is disabled.
package chromium-libs-media-56.0.2924.87-3.fc25.x86_64 is disabled
(try to add '--allowerasing' to command line to replace conflicting packages)

Fallback is to install what you need with rpm instead

sudo rpm -Uvh chromium-56.0.2924.87-3.fc25.x86_64.rpm chromium-libs-*.rpm
Preparing...                          ################################# [100%]
Updating / installing...
   1:chromium-libs-media-56.0.2924.87-################################# [ 17%]
   2:chromium-libs-56.0.2924.87-3.fc25################################# [ 33%]
   3:chromium-56.0.2924.87-3.fc25     ################################# [ 50%]
Cleaning up / removing...
   4:chromium-55.0.2883.87-1.fc25     ################################# [ 67%]
   5:chromium-libs-55.0.2883.87-1.fc25################################# [ 83%]
   6:chromium-libs-media-55.0.2883.87-################################# [100%]


Which suceeds. If you then downgrade chromium back to what's currently in Fedora (55) and try the same process over again, it now resolves:

sudo dnf upgrade ./*.rpm
[sudo] password for xenith:
Last metadata expiration check: 0:01:40 ago on Fri Feb 24 13:25:24 2017.
Package chromedriver not installed, cannot update it.
Package chrome-remote-desktop not installed, cannot update it.
Package chromium-native_client not installed, cannot update it.
Dependencies resolved.
=================================================================================================================
 Package                        Arch              Version                          Repository               Size
=================================================================================================================
Upgrading:
 chromium                       x86_64            56.0.2924.87-3.fc25              @commandline             42 M
 chromium-libs                  x86_64            56.0.2924.87-3.fc25              @commandline             47 M
 chromium-libs-media            x86_64            56.0.2924.87-3.fc25              @commandline            1.5 M

Transaction Summary
=================================================================================================================
Upgrade  3 Packages

Total size: 90 M


wth?
Comment 112 Jaroslav Mracek 2017-02-24 14:05:25 EST
The command 'dnf upgrade' cannot be used for packages that are not installed. From your report we cannot see your version of dnf and libdnf and what behavior you expect. I also think that it is not related to the bug report. The problem in this bug was solved in libdnf and how to get upstream version can be found in Comment 66. So far from presented information I don't see the behavior as a bug.
Comment 113 Mike Goodwin 2017-02-24 14:08:15 EST
They were installed, sorry if I wasn't clear about that but I started off with Chromium 55 installed as normal. You can clearly see the difference in behavior between before the packages have been installed, and after they have been downgraded and the same command is run (i.e. It then resolves correctly.) Same command. 

It is a bug.
Comment 114 Mike Goodwin 2017-02-24 14:19:29 EST
Since nobody has Chromium 56 installed since it's not in testing yet, try it right now with an up-to-date system. You have until 56 makes it into stable, but to answer your question about me I'm fully up-to-date with -testing enabled.
Comment 115 Jaroslav Mracek 2017-02-24 14:36:42 EST
Mike, please try try dnf -2.1.0 from our repository and if any problem appear, please report it in new bug report with version of dnf, libdnf (or hawkey) and libsolv. Thanks a lot
Comment 116 Fedora End Of Life 2017-02-28 04:49:08 EST
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.
Comment 117 Jaroslav Mracek 2017-03-10 05:47:30 EST
The problem was fixed in libdnf-0.7.4 released into rawhide
Comment 118 Dominik 'Rathann' Mierzejewski 2017-03-10 06:45:00 EST
F25's dnf doesn't use libdnf, so F25 is still affected. Any chance of backporting?
Comment 119 Igor Gnatenko 2017-03-10 07:08:30 EST
(In reply to Dominik 'Rathann' Mierzejewski from comment #118)
> F25's dnf doesn't use libdnf, so F25 is still affected. Any chance of
> backporting?
F25's dnf uses hawkey. I think it's possible to backport, but DNF 1.x gets fixes for critical and security issues.

So, patches are welcomed.
Comment 120 Jaroslav Mracek 2017-03-10 08:13:29 EST
I create PR for hawkey (https://github.com/rpm-software-management/hawkey/pull/122), please can you Igor Gnatenko review it. Thanks a lot
Comment 121 Fedora Update System 2017-03-10 09:15:15 EST
hawkey-0.6.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ecb76c3686
Comment 122 Fedora Update System 2017-03-10 09:15:28 EST
hawkey-0.6.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-59dadb8261
Comment 123 Fedora Update System 2017-03-11 08:54:00 EST
hawkey-0.6.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ecb76c3686
Comment 124 Fedora Update System 2017-03-11 09:26:38 EST
hawkey-0.6.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-59dadb8261
Comment 125 Fedora Update System 2017-03-12 17:53:52 EDT
hawkey-0.6.4-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 126 Fedora Update System 2017-03-13 19:51:59 EDT
hawkey-0.6.4-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 127 Harald Reindl 2017-03-21 05:35:41 EDT
hawkey-0.6.4-1.fc25.x86_64
python3-hawkey-0.6.4-1.fc25.x86_64

nothing changed
Comment 128 Harald Reindl 2017-03-31 06:25:06 EDT
REMOVE THAT DAMEND WARNING WHEN I EXPLICIT CALL YUM-DEPRECATED I KNOW WHAT I AM DOING AND YOU HAVE NO BUSINESS TO SPIT AROUND IN CRON-MAILS

[root@rh:/downloads]$ yum-deprecated --disablerepo=\* upgrade *.rpm
Yum command has been deprecated, use dnf instead.
___________________________________

what about that idiotic "hawkey-0.6.4-1.fc24 has been pushed to the Fedora 24 stable repository" messages when nothing changes?

congratulations for DNF which is "have solution searching problem" when "yum-deprecated just works fine"

root@rh:/downloads]$ dnf --cacheonly upgrade *.rpm
Letzte Prüfung auf abgelaufene Metadaten: vor 2:11:46 am Fri Mar 31 10:09:12 2017.
Fehler: nothing provides libcli-smb-common-samba4.so(SAMBA_4.5.8)(64bit) needed by libsmbclient-2:4.5.8-0.fc25.x86_64.
nothing provides libreplace-samba4.so(SAMBA_4.5.8)(64bit) needed by libwbclient-2:4.5.8-0.fc25.x86_64.
package samba-2:4.5.8-0.fc25.x86_64 is disabled.
package samba-client-2:4.5.8-0.fc25.x86_64 is disabled.
package samba-client-libs-2:4.5.8-0.fc25.x86_64 is disabled.
package samba-common-2:4.5.8-0.fc25.noarch is disabled.
package samba-common-libs-2:4.5.8-0.fc25.x86_64 is disabled.
package samba-common-tools-2:4.5.8-0.fc25.x86_64 is disabled.
package samba-libs-2:4.5.8-0.fc25.x86_64 is disabled
(Fügen Sie »--allowerasing« zur Befehlszeile hinzu, um die problematischen Pakete zu ersetzen)

_____________________________


[root@rh:/downloads]$ yum-deprecated --disablerepo=\* upgrade *.rpm
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.                                                                                                                                                              
                                                                                                                                                                                                                   
Geladene Plugins: etckeeper                                                                                                                                                                                        
libsmbclient-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:libsmbclient-4.5.8-0.fc25.x86_64                                                                                                                           
libsmbclient-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:libsmbclient-4.5.7-0.fc25.x86_64 markiert                                                                                                  
libwbclient-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:libwbclient-4.5.8-0.fc25.x86_64                                                                                                                             
libwbclient-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:libwbclient-4.5.7-0.fc25.x86_64 markiert                                                                                                    
samba-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:samba-4.5.8-0.fc25.x86_64                                                                                                                                         
samba-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:samba-4.5.7-0.fc25.x86_64 markiert                                                                                                                
samba-client-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:samba-client-4.5.8-0.fc25.x86_64                                                                                                                           
samba-client-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:samba-client-4.5.7-0.fc25.x86_64 markiert                                                                                                  
samba-client-libs-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:samba-client-libs-4.5.8-0.fc25.x86_64                                                                                                                 
samba-client-libs-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:samba-client-libs-4.5.7-0.fc25.x86_64 markiert
samba-common-4.5.8-0.fc25.noarch.rpm wird untersucht: 2:samba-common-4.5.8-0.fc25.noarch
samba-common-4.5.8-0.fc25.noarch.rpm wird als eine Aktualisierung für 2:samba-common-4.5.7-0.fc25.noarch markiert
samba-common-libs-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:samba-common-libs-4.5.8-0.fc25.x86_64
samba-common-libs-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:samba-common-libs-4.5.7-0.fc25.x86_64 markiert
samba-common-tools-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:samba-common-tools-4.5.8-0.fc25.x86_64
samba-common-tools-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:samba-common-tools-4.5.7-0.fc25.x86_64 markiert
samba-libs-4.5.8-0.fc25.x86_64.rpm wird untersucht: 2:samba-libs-4.5.8-0.fc25.x86_64
samba-libs-4.5.8-0.fc25.x86_64.rpm wird als eine Aktualisierung für 2:samba-libs-4.5.7-0.fc25.x86_64 markiert
Abhängigkeiten werden aufgelöst
--> Transaktionsprüfung wird ausgeführt
---> Paket libsmbclient.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket libsmbclient.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket libwbclient.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket libwbclient.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba-client.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba-client.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba-client-libs.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba-client-libs.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba-common.noarch 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba-common.noarch 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba-common-libs.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba-common-libs.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba-common-tools.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba-common-tools.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
---> Paket samba-libs.x86_64 2:4.5.7-0.fc25 markiert, um aktualisiert zu werden
---> Paket samba-libs.x86_64 2:4.5.8-0.fc25 markiert, um eine Aktualisierung zu werden
--> Abhängigkeitsauflösung beendet
--> Finde nicht mehr benötigte Abhängigkeiten
Found and removing 0 unneeded dependencies


Aktualisiert:
  libsmbclient.x86_64 2:4.5.8-0.fc25    libwbclient.x86_64 2:4.5.8-0.fc25          samba.x86_64 2:4.5.8-0.fc25                 samba-client.x86_64 2:4.5.8-0.fc25    samba-client-libs.x86_64 2:4.5.8-0.fc25
  samba-common.noarch 2:4.5.8-0.fc25    samba-common-libs.x86_64 2:4.5.8-0.fc25    samba-common-tools.x86_64 2:4.5.8-0.fc25    samba-libs.x86_64 2:4.5.8-0.fc25

Komplett!

Note You need to log in before you can comment on or make changes to this bug.