Bug 139723 - megaraid not found in new kernel
megaraid not found in new kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 139876 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 14:02 EST by Thomas Gordon
Modified: 2015-01-04 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-27 01:02:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Gordon 2004-11-17 14:02:29 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
It seems the new kernel does not support megaraid and initrd creation 
fails.  Installing the kernel RPM fails. 
 
Version-Release number of selected component (if applicable): 
2.6.9-1.3_FC2smp 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. rpm -i newkernel or mkinitrd 
     
 
Actual Results:  No module megaraid found for kernel 
2.6.9-1.3_FC2smp, aborting. 
mkinitrd failed
Comment 1 Dave Jones 2004-11-18 17:48:18 EST
*** Bug 139876 has been marked as a duplicate of this bug. ***
Comment 2 Richard Lloyd 2004-11-18 19:41:57 EST
Just to confirm that this happened to me with a Dell PowerEdge running
an earlier FC2 kernel (2.6.6-1.435smp) that reports this with lspci:

04:03.0 RAID bus controller: Dell Computer Corporation PowerEdge
Expandable RAID controller 4 (rev 02)

"lsmod" indicates that the megaraid module is loaded with
2.6.6-1.435smp, but I get the same "No module megaraid found" error as
the reporter when I attempt an upgrade to 2.6.9-1.3_FC2smp.

Considering that Dell PowerEdges are hugely popular as Linux servers
and hardware RAID is almost a "given" with those servers, this is a
serious problem and stops the latest FC2 kernel being installed
without a lot of source-code "faffing" to incorporate the megaraid
code back into the kernel. Please can someone consider this a high
priority and issue a new FC2 kernel RPM with megaraid included?
Comment 3 James J. Moore 2004-11-21 14:07:59 EST
I've had the same problem getting Fedora Core 3 installed on a Dell
Poweredge 2450 with a PERC2/DC controller (AMI Megaraid 467).  It
appears that kernel RPMs with every version of the kernel before 2.6.9
will work with these cards, and every RPM I've found (FC2 or FC3) with
kernel version >= 2.6.9 will not.  The new kernel code appears to
include a built-in component that only works with newer LSI Megaraid
cards.  There is a module for the older cards, but you can't build the
old and mew modules into the same kernel.  In the standard kernel
configuration interfaces, you can't build the newer module without
first choosing to include built-in code to support it.  Once you
choose the built-in code, you can't choose to build the module for the
older cards.  All the kernel-2.6.9x RPMs include the newer module.  

I'm no kernel guru, so I have no idea why the newer LSI cards need
built-in code.  Did the kernel maintainers fall asleep at the wheel on
this one?  Is there a way to get around this either/or choice?  If
not, (how) can we get a pre-built kernel that includes support for the
older cards, and perhaps some guidance on getting that alternate
kernel loaded to start a Fedora Core 3 install?
Comment 4 Thomas Gordon 2004-11-22 19:12:04 EST
Seems to be resolved with the latest (1.6) revision of the 2.6.9
kernel for FC2.

[tom@ties2 tom]$ rpm -ql kernel-smp-2.6.9-1.6_FC2 |grep megaraid
/lib/modules/2.6.9-1.6_FC2smp/build/include/config/scsi/megaraid
/lib/modules/2.6.9-1.6_FC2smp/build/include/config/scsi/megaraid/module.h
/lib/modules/2.6.9-1.6_FC2smp/kernel/drivers/scsi/megaraid.ko
Comment 5 Steve 2004-11-23 03:49:44 EST
Yes, it seem ok to me too in 2.6.9-1.6

Note You need to log in before you can comment on or make changes to this bug.