Bug 1397307 - Gradle 3.3.0 is available
Summary: Gradle 3.3.0 is available
Keywords:
Status: CLOSED DUPLICATE of bug 1442391
Alias: None
Product: Fedora
Classification: Fedora
Component: gradle
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Michael Simacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1080923 1306798 1397524 1290790 1389985 1397462 1397498 1397510 1397536
Blocks: jmockit
TreeView+ depends on / blocked
 
Reported: 2016-11-22 09:26 UTC by ga25day
Modified: 2017-10-17 13:43 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-17 13:43:39 UTC


Attachments (Terms of Use)

Description ga25day 2016-11-22 09:26:10 UTC
Latest upstream version: 3.1
Current version in F24: 2.12.1
Current version in F25: 2.13

Comment 1 gil cattaneo 2016-11-22 15:30:53 UTC
NOTE: gradle 3.1 use scala 2.11.8

Comment 2 gil cattaneo 2016-11-22 15:32:47 UTC
NOTE: gradle 3.1 use zinc 0.3.7

Comment 3 ga25day 2016-11-22 15:34:14 UTC
The recent version of Gradle is 3.2. Sorry for the mistake above.

Comment 4 gil cattaneo 2016-11-22 16:11:41 UTC
(In reply to nextloop from comment #3)
> The recent version of Gradle is 3.2. Sorry for the mistake above.

No problems, thanks

Comment 5 gil cattaneo 2016-11-22 18:40:53 UTC
these BRs are still missing:
org.gradle:gradle-script-kotlin:0.4.0
https://github.com/gradle/gradle/blob/v3.2.1/build.gradle#L277

scala-xml:1.0.5

Comment 6 gil cattaneo 2016-11-29 18:38:27 UTC
NOTE: gradle 3.2.1 still use scala 2.11.8 and zinc 0.3.7

Comment 7 Solomon Peachy 2017-02-12 15:09:43 UTC
Just FYI, Gradle 3.3 is the current release, and 3.4's release is imminent.  

But the gradle release in F25 (2.13-5) is now too old to compile android applications -- 2.14 or newer is needed.

So, there's value in building 2.14 and getting it pushed out to Fedora users while getting the pre-requisites for 3.x packaged.

Comment 8 ga25day 2017-06-06 15:12:30 UTC
gradle-4.0.0-milestone-1 is available

Comment 9 Michael Simacek 2017-10-17 13:43:39 UTC

*** This bug has been marked as a duplicate of bug 1442391 ***


Note You need to log in before you can comment on or make changes to this bug.