Bug 1442391 - gradle-4.2.1 is available
Summary: gradle-4.2.1 is available
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gradle
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Simacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1397307 (view as bug list)
Depends On:
Blocks: jmockit
TreeView+ depends on / blocked
 
Reported: 2017-04-14 13:35 UTC by Upstream Release Monitoring
Modified: 2017-10-17 13:43 UTC (History)
5 users (show)

Fixed In Version: gradle-0:4.2.1-2.fc28.noarch
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-17 13:42:08 UTC
Type: ---


Attachments (Terms of Use)

Description Upstream Release Monitoring 2017-04-14 13:35:03 UTC
Latest upstream release: 3.5.0
Current version/release in rawhide: 2.13-7.fc26
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 1 Upstream Release Monitoring 2017-04-28 12:15:09 UTC
Latest upstream release: 4.0.0-milestone-1
Current version/release in rawhide: 2.13-8.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 2 Upstream Release Monitoring 2017-06-19 00:13:32 UTC
Latest upstream release: 4.0.0
Current version/release in rawhide: 2.13-8.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 3 Upstream Release Monitoring 2017-06-22 00:15:44 UTC
Latest upstream release: 4.1.0-milestone-1
Current version/release in rawhide: 2.13-8.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 4 Daniel Scott 2017-08-15 21:14:37 UTC
Any idea on when we can have a build of the latest version? I can help with this if necessary?

Comment 5 Upstream Release Monitoring 2017-09-08 00:14:30 UTC
Latest upstream release: 4.2.0-RC1
Current version/release in rawhide: 2.13-10.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 6 Upstream Release Monitoring 2017-09-15 00:16:06 UTC
Latest upstream release: 4.2.0-RC2
Current version/release in rawhide: 2.13-10.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 7 Mikolaj Izdebski 2017-09-15 11:45:15 UTC
(In reply to Daniel Scott from comment #4)
> Any idea on when we can have a build of the latest version? I can help with
> this if necessary?

Sorry, but currently I don't have time to update Gradle.
If you prepared updated package, that would help a lot.
Pull requests can be submitted at https://src.fedoraproject.org/rpms/gradle

Comment 8 Upstream Release Monitoring 2017-09-21 00:16:43 UTC
Latest upstream release: 4.2.0
Current version/release in rawhide: 2.13-10.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 9 Daniel Scott 2017-09-21 08:05:29 UTC
Does it need to be compiled from source? Or can I just build an RPM which uses the binaries from the gradle site?

https://gradle.org/releases/

Comment 10 Mikolaj Izdebski 2017-09-21 15:59:00 UTC
(In reply to Daniel Scott from comment #9)
> Does it need to be compiled from source? Or can I just build an RPM which
> uses the binaries from the gradle site?

It has to be built from source, see https://fedoraproject.org/wiki/Packaging:Guidelines#No_inclusion_of_pre-built_binaries_or_libraries

Comment 11 Upstream Release Monitoring 2017-10-03 00:14:31 UTC
Latest upstream release: 4.2.1
Current version/release in rawhide: 2.13-10.fc27
URL: http://www.gradle.org/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.

Based on the information from anitya:  https://release-monitoring.org/project/6088/

Comment 12 Michael Simacek 2017-10-17 13:43:39 UTC
*** Bug 1397307 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.