Bug 1397401 - [abrt] xorg-x11-server-Xwayland: Segmentation fault at address 0x10000034b: TAINTED
Summary: [abrt] xorg-x11-server-Xwayland: Segmentation fault at address 0x10000034b: T...
Keywords:
Status: CLOSED DUPLICATE of bug 1385258
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:53b3dfa24574f4dc5620e150e0e...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-22 12:57 UTC by Vít Ondruch
Modified: 2016-11-22 14:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-22 12:58:30 UTC
Type: ---


Attachments (Terms of Use)
File: Xorg.0.log (30.27 KB, text/plain)
2016-11-22 12:57 UTC, Vít Ondruch
no flags Details
File: backtrace (375 bytes, text/plain)
2016-11-22 12:57 UTC, Vít Ondruch
no flags Details
File: dmesg (89.22 KB, text/plain)
2016-11-22 12:57 UTC, Vít Ondruch
no flags Details
File: dso_list (258 bytes, text/plain)
2016-11-22 12:57 UTC, Vít Ondruch
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (347 bytes, application/octet-stream)
2016-11-22 12:57 UTC, Vít Ondruch
no flags Details
File: usr_share_xorg_conf_d.tar.gz (1.50 KB, application/octet-stream)
2016-11-22 12:57 UTC, Vít Ondruch
no flags Details

Description Vít Ondruch 2016-11-22 12:57:23 UTC
Version-Release number of selected component:
xorg-x11-server-Xwayland-1.19.0-0.8.rc2.2test.fc26

Additional info:
reporter:       libreport-2.8.0
executable:     /usr/bin/Xwayland
kernel:         4.8.6-300.fc25.x86_64
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: ? (?+0x56c347) [0xafc917]
1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7ff7d1afc52f]
2: /usr/bin/Xwayland (?+0x0) [0x474020]
3: /usr/bin/Xwayland (?+0x0) [0x46ff00]
4: /usr/bin/Xwayland (?+0x0) [0x5562d0]
5: /usr/bin/Xwayland (?+0x0) [0x55a1f0]
6: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7ff7d17444d1]
7: /usr/bin/Xwayland (?+0xf1) [0x423dc1]
8: ? (?+0xf1) [0xf1]

Potential duplicate: bug 1390018

Comment 1 Vít Ondruch 2016-11-22 12:57:27 UTC
Created attachment 1222722 [details]
File: Xorg.0.log

Comment 2 Vít Ondruch 2016-11-22 12:57:28 UTC
Created attachment 1222723 [details]
File: backtrace

Comment 3 Vít Ondruch 2016-11-22 12:57:30 UTC
Created attachment 1222724 [details]
File: dmesg

Comment 4 Vít Ondruch 2016-11-22 12:57:31 UTC
Created attachment 1222725 [details]
File: dso_list

Comment 5 Vít Ondruch 2016-11-22 12:57:33 UTC
Created attachment 1222726 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 6 Vít Ondruch 2016-11-22 12:57:34 UTC
Created attachment 1222727 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 7 Vít Ondruch 2016-11-22 12:58:30 UTC

*** This bug has been marked as a duplicate of bug 1385258 ***

Comment 8 Olivier Fourdan 2016-11-22 13:38:31 UTC
Are you sure it's a duplicate? The backtrace doesn't seem to match

Comment 9 Olivier Fourdan 2016-11-22 13:41:15 UTC
Also, can you do a "rpm -qa xorg-x11-server*" on your system?

Comment 10 Vít Ondruch 2016-11-22 13:54:22 UTC
(In reply to Olivier Fourdan from comment #8)
> Are you sure it's a duplicate? The backtrace doesn't seem to match

I am not sure :-P ... They just looked similar.


```
$ addr2line -fe /usr/lib/debug/usr/bin/Xwayland.debug 0x474020 0x46ff00 0x5562d0 0x55a1f0
dixGetPrivateAddr
/usr/src/debug/xorg-server-1.18.99.902/mi/../include/privates.h:122
mieqProcessDeviceEvent
/usr/src/debug/xorg-server-1.18.99.902/mi/mieq.c:446 (discriminator 1)
SendErrorToClient
/usr/src/debug/xorg-server-1.18.99.902/dix/dispatch.c:3713
InitFonts
/usr/src/debug/xorg-server-1.18.99.902/dix/dixfonts.c:2050
```

This ^^ would suggest they are different, at least from the mieqProcessDeviceEvent ... but they are definitely similar ...


(In reply to Olivier Fourdan from comment #9)
> Also, can you do a "rpm -qa xorg-x11-server*" on your system?

$ rpm -qa xorg-x11-server*
xorg-x11-server-utils-7.7-20.fc26.x86_64
xorg-x11-server-Xwayland-1.19.0-0.8.rc2.2test.fc26.x86_64
xorg-x11-server-common-1.19.0-0.8.rc2.2test.fc26.x86_64
xorg-x11-server-Xorg-1.19.0-0.8.rc2.2test.fc26.x86_64

BTW I just updated the packages, without restarting the system if that makes any difference. But I expect that every X app is running its own X server ... I hope I am not wrong ...

Comment 11 Olivier Fourdan 2016-11-22 14:20:32 UTC
(In reply to Vít Ondruch from comment #10)
> BTW I just updated the packages, without restarting the system if that makes
> any difference. But I expect that every X app is running its own X server
> ... I hope I am not wrong ...

Oh, nope, in Wayland there is only one Xserver which is Xwayland started by the Wayland compositor (mutter/gnome-shell in this casE), so if you haven't restarted the whole session, then you were running the old Xwayland with the new debuginfo.


Note You need to log in before you can comment on or make changes to this bug.