Bug 139779 - kernel-update, fails to boot: mkrootdev not found /1
kernel-update, fails to boot: mkrootdev not found /1
Status: CLOSED DUPLICATE of bug 139674
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 18:49 EST by Don Moore
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Moore 2004-11-17 18:49:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I've been running FC3 test1,2,3 and fresh install FC3 roughly Nov9.
yum update'd kernel-smp.i686 2.6.9-1.678_FC3, kernel.i686
2.6.9-1.678_FC3 . Reboot- failed with the following 
messages- 
mkrootdev /1 not found
switchroot mount failed
mount /initrd/dev failed
kernel panic not syncing  .. blah blah.
-- 

e2label verified the labels are correct :
# e2label /dev/sda1
/1
# e2label /dev/sda3
/usr/vice1
# e2label /dev/sda4
/var1
--

Meanwhile, I updated my laptop with fresh install of FC3
and updated it. kernel-2.6.9-1.678_FC3 boots fine and all
is well. 

In short, it the kernel update boogers up my GX280 -likely
because of SATA . Meanwhile- I am still running kernel-2.6.9-1.667
on the GX280. And- I adjusted /etc/sysconfig/kernel and
/boot/grub/grub.conf to select previous kernel .

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.678_FC3

How reproducible:
Always

Steps to Reproduce:
1. yum update 
2. reboot
3. boot- fails same for SMP vs non-SMP kernel
    

Actual Results:  Have to hit power-off button 

Expected Results:  should be no problem to boot as before

Additional info:

[root@zanbolar tmp]# lshw
zanbolar.utdallas.edu     
    description: Mini Tower Computer
    product: OptiPlex GX280
    vendor: Dell Inc.
    serial: xxxxx
    capabilities: smbios-2.3 dmi-2.3
    configuration: boot=normal chassis=mini-tower
uuid=44454C4C-4200-1043-8039-B5C04F583531
  *-core
       description: Motherboard
       product: 0G5611
       vendor: Dell Inc.
       physical id: 0
       serial: xxxxx
     *-firmware
          description: BIOS
          vendor: Dell Inc.
          physical id: 0
          version: A03 (09/17/2004)
          size: 64KB
          capacity: 448KB
          capabilities: pci pnp apm upgrade shadowing cdboot
bootselect edd int13floppytoshiba int5printscreen int9keyboard
int14serial int17printer acpi usb ls120boot biosbootspecification netboot
     *-cpu
          description: CPU
          product: Intel(R) Pentium(R) 4 CPU 3.20GHz
          vendor: Intel Corp.
          physical id: 400
          version: 15.3.4
          serial: 0000-0F34-0000-0000-0000-0000
          slot: Microprocessor
          size: 3200MHz
          capacity: 3600MHz
          clock: 800MHz
          capabilities: fpu fpu_exception wp vme de pse tsc msr pae
mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse
sse2 ss ht tm pbe pni monitor ds_cpl cid xtpr
 
-- snip
              *-cdrom
                   description: DVD reader
                   product: SAMSUNG CDRW/DVD SM-352F
                   physical id: 0
                   bus info: ide@0.0
                   logical name: /dev/hda
                   version: T902
                   capabilities: packet atapi cdrom removable
nonmagnetic dma lba iordy audio cd-r cd-rw dvd
                   configuration: mode=udma2
        *-ide:1
             description: IDE interface
             product: 82801FB/FW (ICH6/ICH6W) SATA Controller
             vendor: Intel Corp.
             physical id: 1f.2
             bus info: pci@00:1f.2
             version: 03
             clock: 66MHz
             capabilities: ide bus_master cap_list
             configuration: driver=ata_piix
             resources: ioport:fe00-fe07 ioport:fe10-fe13
ioport:fe20-fe27 ioport:fe30-fe33 ioport:fea0-feaf irq:217
        *-serial UNCLAIMED
             description: SMBus
             product: 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller
             vendor: Intel Corp.
             physical id: 1f.3
             bus info: pci@00:1f.3
             version: 03
             clock: 33MHz
             resources: ioport:e8a0-e8bf irq:177
Comment 1 Don Moore 2004-11-17 18:51:11 EST
Mostly- I'm just trying to alert you about this updated kernel.
I have not widely deployed FC3 at our site. I can snap a picture
of the screen tomorrow if - like.

best regards,
-/don
Comment 2 Bill Nottingham 2004-11-18 03:42:42 EST

*** This bug has been marked as a duplicate of 139674 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.