Bug 1397937 - [RFE] add specific error message to radosgw if pool creation fails due to 'osd pool default pg num' being smaller than 'osd pool default pgp num'
Summary: [RFE] add specific error message to radosgw if pool creation fails due to 'os...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 2.3
Assignee: Matt Benjamin (redhat)
QA Contact: Tejas
Erin Donnelly
URL:
Whiteboard:
Depends On:
Blocks: 1437916
TreeView+ depends on / blocked
 
Reported: 2016-11-23 15:40 UTC by Harald Klein
Modified: 2017-07-30 15:45 UTC (History)
11 users (show)

Fixed In Version: RHEL: ceph-10.2.7-8.el7cp Ubuntu: ceph_10.2.7-9redhat1
Doc Type: Enhancement
Doc Text:
.Improved error messaging in the Ceph Object Gateway Previously, when an invalid placement group configuration prevented the Ceph Object Gateway from creating any of its internal pools, the error message was insufficient, making it difficult to deduce the root cause of failure. The error message now suggests there might be an issue with the configuration such as an insufficient number of placement groups or inconsistent values set for the `pg_num` and `pgp_num` parameters, making it easier for the administrator to solve the problem.
Clone Of:
Environment:
Last Closed: 2017-06-19 13:27:53 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1497 normal SHIPPED_LIVE Red Hat Ceph Storage 2.3 bug fix and enhancement update 2017-06-19 17:24:11 UTC
Red Hat Knowledge Base (Solution) 2778161 None None None 2016-11-23 15:42:39 UTC

Description Harald Klein 2016-11-23 15:40:10 UTC
Description of problem:

When the default "pg num" and "pgp num" settings in ceph.conf are misconfigured (e.g. due to a typo), rados gw can't create the pools and will print this error:

2016-11-23 11:07:07.383664 7efef6e229c0  0 ERROR:  storing info for 40f94cf3-796e-494f-bcec-655b91a58cc1: (34) Numerical result out of range
2016-11-23 11:07:07.383695 7efef6e229c0  0 create_default: error in create_default  zone params: (34) Numerical result out of range
2016-11-23 11:07:07.383705 7efef6e229c0  0 failure in zonegroup create_default: ret -34 (34) Numerical result out of range
2016-11-23 11:07:07.385338 7efef6e229c0 -1 Couldn't init storage provider (RADOS)
Version-Release number of selected component (if applicable):

A more specific error messages would help our customers to quickly identify the problem.

How reproducible:

Put conflicting settings into ceph.conf:
osd pool default pg num = 33
osd pool default pgp num = 34

Steps to Reproduce:
1. misconfigure
2. try to startup rados gw
3. watch error

Actual results:

ret -34 (34) Numerical result out of range

Expected results:

Some nice error message to point the customer to his misconfiguration

Additional info:

n/a

Comment 23 errata-xmlrpc 2017-06-19 13:27:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1497


Note You need to log in before you can comment on or make changes to this bug.