Bug 139795 - kernel module chapter needs to cover rc.modules
kernel module chapter needs to cover rc.modules
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rhel-sag (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sandra Moore
: FutureFeature
Depends On:
Blocks: 123819
  Show dependency treegraph
 
Reported: 2004-11-17 21:00 EST by Richard Keech
Modified: 2014-08-04 18:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 14:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Keech 2004-11-17 21:00:59 EST
Module administration is covered in Chapter 40, however
it does not cover how to persistently load a module.

I suggest you add an item to the chapter on kernel modules as follows:

If you need to load a kernel module at boot, and its loading is
not provided through modprobe.conf, then Red Hat Enterprise Linux
provides for module loading commands to exist in a script called
/etc/rc.modules.  Eg, if module foo needs to be loaded at boot,
then the following actions will provide for this (assuming
module foo exists in the usual place):

echo modprobe foo >> /etc/rc.modules
chmod +x /etc/rc.modules
Comment 1 Andrius Benokraitis 2005-02-03 16:33:25 EST
Arjan, what do you think about this proposed addition?

http://www.redhat.com/docs/manuals/enterprise/RHEL-3-Manual/sysadmin-guide/ch-kernel-modules.html
Comment 2 Arjan van de Ven 2005-02-03 16:37:49 EST
it is slightly more complex than this; if it's a nic or scsi driver
there are better ways than this...


also the word "loaded" on that url should be replaced with "linked
into"... 
Comment 3 Andrius Benokraitis 2005-02-03 16:45:47 EST
Richard/Arjan,

Based on the increased complexity of this addition, may I suggest that
this become a feature, and be deferred/investigate for RHEL5
documentation? Will RHEL4 documentation be damaging without the
suggestion given by the author?

Thanks! :-)
Comment 4 Richard Keech 2005-02-03 19:16:56 EST
Andrius,

This is an important feature that is not complicated for the general
case.  This approach is not necessary nor nic and scsi because those
facilities have specific mechanisms.  rc.modules is something admins
need to know about for cases where the system doesn't provide a better
way.

Let me propose a wording of a new subsection:

40.2  Persistant Module Loading

Kernel modules are usually loaded directly by the facility that
requires them, given correct settings in /etc/modprobe.conf.  However
it is sometimes necessary to explicitly force the loading of a module
at boot time.  To do this Enterprise Linux checks for the existance of
/etc/rc.modules at boot time. This file should contain commands to
load modules.  rc.modules should be used, not rc.local because
rc.modules is executed early in the boot process.  A simple example of
loading the foo module at boot would be 

echo modprobe foo >> /etc/rc.modules
chmod +x /etc/rc.modules

Comment 5 Andrius Benokraitis 2005-02-07 12:17:44 EST
I'm find with adding any content as long as Arjan approves! :-) Arjan,
what do you think of Richard's proposed addition?
Comment 6 Arjan van de Ven 2005-02-08 05:22:44 EST
it looks fine to me, and indeed can be useful.
Comment 7 Andrius Benokraitis 2005-02-08 14:44:49 EST
Successfully added to /RHEL4/cgs/kernelmodules.sgml.

Thanks so much for creating the content for addition! :-)

Andrius.

Note You need to log in before you can comment on or make changes to this bug.