Bug 139834 - Evolution launched spamd is still running after evolution is exited
Evolution launched spamd is still running after evolution is exited
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 07:05 EST by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 14:39:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-11-18 07:05:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040804 Galeon/1.3.17

Description of problem:
A spamd daemon launched from Evolution 2 to do junk filtering does not
quit after the user has logged out.

Version-Release number of selected component (if applicable):
evolution-2.0.2-3

How reproducible:
Always

Steps to Reproduce:.
1. Start evolution
2. Start and fill in the first time wizard. During it setup up a
receving mail server and on the following "page" ensure that "Check
new messages for Junk contents" is ticked. Finish the rest of the wizard.
3. Send yourself a mail and then check your inbox.
4. Quit evolution.
5. Quit X.

Actual Results:
One "/usr/bin/spamd --port 7830 --local --daemonize" and five "spamd
child" processes are left running.

Expected Results:
spamd (and it's children) to quit when evolution is exited or at worse
when X is exited.

Additional info:
We are using FC3 in a multi user environment so the processes stack up
for each user who does this. It may also be worth noting that the
user's home directory is mounted on NFS and and older version of
spamassassin is already run on the incomming mail as it arrives on the
server.

The version of spamassassin on the desktop is spamassassin-3.0.0-3 .
Comment 1 Colin Stewart 2004-11-24 23:49:28 EST
I'm also seeing this using home directories that are on a local disk.

In addition to the spamd processes I also get:
 /usr/libexec/evolution-data-server-1.0
 /usr/bin/ssh-agent -s
 /usr/libexec/gam_server

all left behined.  These in turn keep /usr/libexec/gconfd-2 around,
but that will quit once the others are killed.
Comment 2 Sitsofe Wheeler 2004-11-25 05:13:30 EST
Colin - you beat me to it! I've slowly been building up these
"programs that keep running after logout" bugs.

ssh-agent is in bug 139372
artsd under GNOME is in bug 140262

A quick scan just now showed loads of ssh-agent, one lingering
evolution-data-server, several machines with multiple stray gam_server
and one left over esd. However there are not always clear steps for
reproducing some of these (I could not reliably reproduce left over
esd processes).
Comment 3 Colin Stewart 2004-11-25 11:40:11 EST
I may have made some possible progress with the evolution-data-server
(which I think is probably what is keeping the dspam processes
around).  I noticed I kept getting messages logged on my firewall at
exactly the same time I killed the evolution-data-server.  They are
all of the form:

IN=ppp0 OUT= MAC= SRC=17.250.248.38 DST=142.150.240.56 LEN=40 TOS=0x00
PREC=0x00 TTL=46 ID=12569 DF PROTO=TCP SPT=80 DPT=40563 WINDOW=0
RES=0x00 RST URGP=1

17.250.248.38 is ical.mac.com

Running netstat I see that evolution-data-server has the following
connections open right now (i.e when logged in):

tcp        1      0 user06.megabit.utoron:40774 homepage.mac.com:http
      CLOSE_WAIT  13652/evolution-dat
tcp        1      0 user06.megabit.utoron:40773 homepage.mac.com:http
      CLOSE_WAIT  13652/evolution-dat
tcp        1      0 user06.megabit.utoron:40771 ical.mac.com:http    
      CLOSE_WAIT  13652/evolution-dat
tcp        1      0 user06.megabit.utoron:40772 ical.mac.com:http    
      CLOSE_WAIT  13652/evolution-dat

My web calendars are only setup to check every 5 days, so I wouldn't
have expected any connections to be open at all, and certainly not for
them to be persistently in the CLOSE_WAIT state.  

Do you think this is related?
Comment 4 Sitsofe Wheeler 2004-11-25 18:27:06 EST
I'm not that convinced because a netstat --inet over here shows spamd
is still running even though evolution-data-server has gone and there
are no lingering network connections.

There was an old "evolution-data-server hangs around" bug a year ago
but I'd be surprised if this is the same one...
Comment 5 Sitsofe Wheeler 2004-11-25 18:28:04 EST
Oh and I've filed  gam_server keeps running as bug 140874
Comment 6 Sitsofe Wheeler 2004-12-01 06:16:40 EST
Undying evolution-data-server appears to be bug 134851 (it has a sibling for
bonobo-activation-server - bug 134849)
Comment 7 Sitsofe Wheeler 2006-05-26 11:55:20 EDT
This appears to have been fixed in FC5's evolution-2.6.1-1.fc5.2...
Comment 8 Sitsofe Wheeler 2006-06-06 14:39:28 EDT
Resolving fixed CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.