Bug 134849 - bonobo-activation-server has achieved immortality
bonobo-activation-server has achieved immortality
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libbonobo (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: SessionExit
  Show dependency treegraph
 
Reported: 2004-10-06 14:49 EDT by Chris Lee
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-17 14:01:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lee 2004-10-06 14:49:05 EDT
Description of problem: bonobo-activation-server fails to exit at the
end of the user's session.

Version-Release number of selected component (if applicable):
libbonobo-2.8.0-2

How reproducible: Always

Steps to Reproduce:
1. Log in to GNOME.
2. Log out.
3. Switch to a command-line with Ctrl-Alt-F[1-6] and log in as the
same user you logged in to GNOME as, and run 'ps x'
  
Actual results: bonobo-activation-server is still alive and well

Expected results: bonobo-activation-server should be dead and gone
Comment 1 Dave Malcolm 2004-10-15 17:22:03 EDT
I've done some testing with a rawhide nightly install 20041014: if I
login, do nothing and logout, b-a-s goes away correctly (as does e-d-s)

If I click on the panel clock (which should use evolution-data-server
to get your tasks/appointments), then logout, b-a-s and e-d-s also go
away correctly.

However, if I login, start Evolution, and close Evolution, then
logout, THEN b-a-s and e-d-s survive the session.

Do you see this behaviour?  Do you have to run Evolution to get b-a-s
and e-d-s to achieve immortality?
Comment 2 Dave Malcolm 2004-10-15 17:55:48 EDT
I've confirmed this on another machine; the b-a-s problem seems to be
related to e-d-s, when e-d-s is launched from evolution.
Comment 3 Dave Malcolm 2004-10-18 10:37:54 EDT
The e-d-s bug is bug #134851
Comment 4 Dave Malcolm 2004-10-20 03:04:46 EDT
The fix for the e-d-s bug fixes this
Comment 5 David Lehman 2004-11-01 17:38:35 EST
This appears to also happen with RHEL3. I can reproduce it easily just
by starting evolution then logging out.

Would you prefer I open a new bug since it's for RHEL3?
Comment 6 Dave Malcolm 2004-11-02 09:56:02 EST
Dave Lehman: yes, please do it for RHEL3 as a separate bug, since so
much of the code is different (and it can then appear in different
trackers, etc)
Comment 7 Dave Malcolm 2004-11-17 14:01:03 EST
OK, resolving this one as CURRENTRELEASE.

The not-yet-fixed RHEL3 bug (bug #134144) looks similar, but I believe
the exact underlying cause is different.
Comment 8 Sitsofe Wheeler 2004-12-01 06:09:17 EST
Sorry to ask but which version of libbonobo was this fixed in? I am still seeing
immortal /usr/libexec/bonobo-activation-server with libbonobo-2.4.0-1 (FC3 final)...
Comment 9 Dave Malcolm 2004-12-01 19:44:03 EST
From your comments on bug #139834 it sounds like your've discovered another way
to keep evolution-data-server from exiting, and it's that that keepds
bonobo-activation-server alive.  I believe the real problem you're seeing is
with e-d-s, not with b-a-s (although it's arguable that managing object
lifetimes based on distributed reference counting is an inherently broken design).

Note You need to log in before you can comment on or make changes to this bug.