Bug 1398725 - Can't add provider specific catalog items to global region
Summary: Can't add provider specific catalog items to global region
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.8.0
Assignee: Brandon Dunne
QA Contact: luke couzens
URL:
Whiteboard: distributed:service
: 1432237 (view as bug list)
Depends On:
Blocks: 1436236
TreeView+ depends on / blocked
 
Reported: 2016-11-25 17:04 UTC by luke couzens
Modified: 2017-05-31 14:24 UTC (History)
12 users (show)

Fixed In Version: 5.8.0.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1436236 (view as bug list)
Environment:
Last Closed: 2017-05-31 14:24:35 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:1367 normal SHIPPED_LIVE Moderate: CFME 5.8.0 security, bug, and enhancement update 2017-05-31 18:16:03 UTC

Description luke couzens 2016-11-25 17:04:11 UTC
Description of problem:Unable to add provider specific catalog item to global region with all required fields filled out, also no error message is presented in the ui.


Version-Release number of selected component (if applicable):5.7.0.12


How reproducible:100%


Steps to Reproduce:
1.provision appliances rr1 and rr99
2.setup replication
2.1.rr1 navigate to settings-configuration-settings-region-replication
2.2.set rr1 to remote, click save
2.3.rr9 navigate to settings-configuration-settings-region-replication
2.4.set rr99 to global
2.5.add subscription to rr1
3.add a provider to rr1 (check replication to rr99)
4.rr99 navigate to Services-catalogs-catalogs-configuration-add new catalog
5.fill out creating test catalog
6.navigate to catalog items-configuration-add new catalog item
7.select added provider from list
8.fill out all required fields and click add

Actual results:nothing happens and no error messages.


Expected results:catalog item added or error message with reason for not adding


Additional info: 
Adding the same catalog item to remote region works fine, I wonder whether this is because the provider is actually owned by the remote region and only replicated to the global, which some how stops the global adding catalog items against that provider for some reason. Regardless we should see an error message at the least. It could also be something to do with central admin being enabled, again we should still see some sort of error.

I also see this in evm.log 
[----] E, [2016-11-25T11:40:51.448462 #25489:baab80] ERROR -- : MIQ(InterRegionApiMethodRelay.api_client_connection_for_region) Region 2 is not configured for central administration

Comment 2 Nick Carboni 2016-12-19 14:47:08 UTC
Luke, 

Is there a backtrace that comes with that message in the log?
Could you post it if there is?

Thanks

Comment 3 luke couzens 2016-12-20 13:00:25 UTC
Nick,

I don't think there is any relevant backtrace that I can see.

I ran through this again on the latest build and I see the same error in the logs as before http://pastebin.test.redhat.com/440728

However after enabling central admin there is no errors shown in the logs but the same issue persists in the ui, no item added and no error shown.

Comment 4 Nick Carboni 2017-01-16 23:41:29 UTC
I was able to reproduce this. I can see that nothing happens when you try to create the catalog item.

The thing that concerns me more though is that when central admin is configured, attempting to save the catalog item actually starts the provision request in the remote region. The provision runs because MiqRequest.class_from_request_data is returning MiqProvisionRequest rather than MiqProvisionRequestTemplate when called from the API with the options we pass.

This type of thing is not supported; we intended the catalog, dialog, and item to be created in the remote region prior to ordering an item. Because of this I would think we would want to stop something like this from happening somewhere else in the workflow (maybe by not showing templates from remote regions?) rather than attempt to "fix" it by creating the request template in the remote region.

Thoughts?

Comment 5 Nick Carboni 2017-02-20 20:13:30 UTC
Hasn't been any movement on this in quite some time so I'm going to re-assign it to the provisioning component as they will probably be better able to fix this.

Comment 6 luke couzens 2017-03-10 10:04:55 UTC
Hi Greg,

Do we want a separate bz for the MiqProvisionRequest X MiqProvisionRequestTemplate stuff in Nicks comment.

I only ask as I am reproducing a similar issue on 5.8.0.4, the difference I see is the items are actually added on the global region now and at the same time they fire off a provision request to the remote region.

Thoughts?

Comment 8 CFME Bot 2017-03-24 21:16:31 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/548d782f7a71e381e7aad940fd79201375062bbf

commit 548d782f7a71e381e7aad940fd79201375062bbf
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Mar 22 18:09:33 2017 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Wed Mar 22 18:13:17 2017 -0400

    Add test for MiqProvisionVirtWorkflow#allowed_templates
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1398725

 spec/models/miq_provision_virt_workflow_spec.rb | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comment 9 CFME Bot 2017-03-24 21:16:38 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7853c6fe4ba9547df440630df97dcf47fcefa917

commit 7853c6fe4ba9547df440630df97dcf47fcefa917
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Mar 22 18:11:01 2017 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Wed Mar 22 18:13:17 2017 -0400

    Limit selectable template to the local region
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1398725

 app/models/miq_provision_virt_workflow.rb | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comment 10 Brandon Dunne 2017-03-24 22:28:33 UTC
*** Bug 1432237 has been marked as a duplicate of this bug. ***

Comment 12 luke couzens 2017-04-04 14:12:44 UTC
Verified in 5.8.0.8

Comment 14 errata-xmlrpc 2017-05-31 14:24:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:1367


Note You need to log in before you can comment on or make changes to this bug.