Bug 1399337 - Review Request: python3-requests - HTTP library, written in Python, for human beings
Summary: Review Request: python3-requests - HTTP library, written in Python, for human...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Orling
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1376940 1402456
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-28 19:12 UTC by Orion Poplawski
Modified: 2017-11-16 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-31 10:48:10 UTC
TicoTimo: fedora-review+


Attachments (Terms of Use)

Description Orion Poplawski 2016-11-28 19:12:51 UTC
Spec URL: https://www.cora.nwra.com/~orion/fedora/python3-requests.spec
SRPM URL: https://www.cora.nwra.com/~orion/fedora/python3-requests-2.12.1-1.el7.src.rpm
Description:
Most existing Python modules for sending HTTP requests are extremely verbose and
cumbersome. Python’s built-in urllib2 module provides most of the HTTP
capabilities you should need, but the API is thoroughly broken. This library is
designed to make HTTP requests easy for developers.

Fedora Account System Username: orion

This is an EPEL only package.

Comment 1 Tim Orling 2016-12-03 20:13:12 UTC
Missing dependency on python3-setuptools or...?

Koji EPEL7 build:
    http://koji.fedoraproject.org/koji/taskinfo?taskID=16727832

Koji EL6 build:
    http://koji.fedoraproject.org/koji/taskinfo?taskID=16727964

Comment 2 Orion Poplawski 2016-12-04 16:09:11 UTC
Yup.

Spec URL: https://www.cora.nwra.com/~orion/fedora/python3-requests.spec
SRPM URL: https://www.cora.nwra.com/~orion/fedora/python3-requests-2.12.1-2.el7.src.rpm

* Sun Dec 4 2016 Orion Poplwski <orion@cora.nwra.com> - 2.12.1-2
- Add missing BR on setuptools

Comment 3 Tim Orling 2016-12-04 20:34:59 UTC
Mockbuild failed to install: Runtime dependency on python34-idna cannot be met on EPEL7 (and no python*-idna package on EL6, FWIW).

Latest version is 2.12.3

Comment 4 Orion Poplawski 2016-12-04 21:08:42 UTC
Spec URL: https://www.cora.nwra.com/~orion/fedora/python3-requests.spec
SRPM URL: https://www.cora.nwra.com/~orion/fedora/python3-requests-2.12.3-1.el7.src.rpm

* Sun Dec 4 2016 Orion Poplwski <orion@cora.nwra.com> - 2.12.3-1
- Update to 2.12.3

python-idna update for EPEL7 - https://bodhi.fedoraproject.org/updates/python-idna-2.1-2.el7

Comment 5 Tim Orling 2016-12-09 03:36:08 UTC
So, do we need a python3-idna package in order to package python3-requests?

Not sure how to proceed. Cannot install (for mock build) without python34-idna.

Comment 6 Tim Orling 2016-12-14 22:23:46 UTC
Koji EPEL7 build:
    https://koji.fedoraproject.org/koji/taskinfo?taskID=16893444

Koji EL6 build:
    https://koji.fedoraproject.org/koji/taskinfo?taskID=16893627

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated


Issues:
=======
- Package contains BR: python2-devel or python3-devel
  => OK: python%{python3_pkgversion}-devel is used and is EPEL only package.

- Upstream updated again (today). This should not delay the review.
  Please address after package creation.

===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses
     found: "MIT/X11 (BSD like)", "LGPL (v2.1 or later)", "Unknown or
     generated", "*No copyright* LGPL (v2.1 or later)". 65 files have
     unknown license. Detailed output of licensecheck in
     /home/parallels/1399337-python3-requests/licensecheck.txt
     => OK: the extra licenses are for (un)bundled chardet, urllib3, etc.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory
     names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[x]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 61440 bytes in 3 files.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least
     one supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %license.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Dist tag is present.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package does not use a name that already exists.
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[x]: Python eggs must not download any dependencies during the build
     process.
[x]: A package which is used by another package via an egg interface should
     provide egg info.
[x]: Package meets the Packaging Guidelines::Python
[x]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate
     file from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Package functions as described.
[!]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise
     justified.
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed
     files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: python34-requests-2.12.3-1.el7.centos.noarch.rpm
          python3-requests-2.12.3-1.el7.centos.src.rpm
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/compat.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/models.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/compat.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/hooks.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/adapters.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/utils.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/api.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/utils.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/api.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/hooks.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/adapters.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/cookies.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/cookies.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/auth.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: W: dangling-relative-symlink /usr/lib/python3.4/site-packages/requests/packages/urllib3 ../../urllib3
python34-requests.noarch: W: dangling-relative-symlink /usr/lib/python3.4/site-packages/requests/packages/chardet ../../chardet
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/auth.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/structures.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/__init__.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/__init__.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/packages/__pycache__/__init__.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/models.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/structures.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/packages/__pycache__/__init__.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/sessions.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/_internal_utils.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/exceptions.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: non-executable-script /usr/lib/python3.4/site-packages/requests/certs.py 0644L /usr/bin/env
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/sessions.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/exceptions.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/status_codes.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/_internal_utils.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/status_codes.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/certs.cpython-34.pyo expected 3260 (3.4), found 3310 (unknown)
python34-requests.noarch: W: dangling-relative-symlink /usr/lib/python3.4/site-packages/requests/packages/idna ../../idna
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/certs.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
=> OK: errors are from a bug in rpmlint
       warnings are for symbolic links necessary to avoid bundling chardet, etc.
2 packages and 0 specfiles checked; 33 errors, 3 warnings.




Rpmlint (installed packages)
----------------------------
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/compat.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
<-- snip -->
python34-requests.noarch: E: python-bytecode-wrong-magic-value /usr/lib/python3.4/site-packages/requests/__pycache__/certs.cpython-34.pyc expected 3260 (3.4), found 3310 (unknown)
1 packages and 0 specfiles checked; 33 errors, 3 warnings.



Requires
--------
python34-requests (rpmlib, GLIBC filtered):
    python(abi)
    python34-chardet
    python34-idna
    python34-urllib3



Provides
--------
python34-requests:
    python34-requests



Source checksums
----------------
https://github.com/kennethreitz/requests/archive/v2.12.3/requests-2.12.3.tar.gz :
  CHECKSUM(SHA256) this package     : 8d47f177d02574d146c6845c9fa0881a610c2a3dd5e19f549b8d272a3eaa5d66
  CHECKSUM(SHA256) upstream package : 8d47f177d02574d146c6845c9fa0881a610c2a3dd5e19f549b8d272a3eaa5d66


Generated by fedora-review 0.5.3 (bcf15e3) last change: 2015-05-04
Command line :/usr/bin/fedora-review -b 1399337
Buildroot used: epel-7-x86_64
Active plugins: Python, Generic, Shell-api
Disabled plugins: Java, C/C++, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6


APPROVED

Comment 7 Gwyn Ciesla 2016-12-14 22:27:40 UTC
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/rpms/python3-requests

Comment 8 Fedora Update System 2016-12-14 22:53:29 UTC
python3-requests-2.12.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-937d666659

Comment 9 Fedora Update System 2016-12-14 22:53:35 UTC
python3-requests-2.12.3-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-74515808a7

Comment 10 Fedora Update System 2016-12-16 04:20:15 UTC
python3-requests-2.12.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-937d666659

Comment 11 Fedora Update System 2016-12-16 13:17:14 UTC
python3-requests-2.12.3-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-74515808a7

Comment 12 Fedora Update System 2016-12-31 10:48:10 UTC
python3-requests-2.12.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2017-11-16 16:52:34 UTC
python3-requests-2.12.3-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.