Bug 139964 - Team: Cannot change Keyword Subst (ASCII/Binary)
Team: Cannot change Keyword Subst (ASCII/Binary)
Status: CLOSED DUPLICATE of bug 139411
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 17:35 EST by Keith Seitz
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Seitz 2004-11-18 17:35:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Once a file is committed, the keyword substitution cannot be altered.

Version-Release number of selected component (if applicable):
eclipse-platform-3.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. Add :ext:tomato.toronto.redhat.com:/home/handcock/eclipse-test-cvsroot
2. Create new HelloWorld-type project
3. Create new HelloWorld class, add simple System.out.println call in main
4. Share project in cvs (Team->Share Project)
5. Add another System.out.println to HelloWorld
6. Create patch, saving into workspace, HelloWorld/test.patch.
7. Share this new file (Team->Add to Version Control)
8. Change to ASCII; right-click test.patch, Team->Change ASCII/Binary
Property
9. Choose "ASCII without keyword substitution (-ko)". Click next.
10. Select "Include files..."; next
11. Type in a comment; next
12. Click finish


Actual Results:  Get Error dialog:
Problems encountered setting keyword substitution
Reason: HelloWorld: cvs commit: Examining .


Expected Results:  Change keyword subst in cvs

Additional info:

Tried with BEA & IBM JVMs. Both fail.
This works fine as long as you add a new file, change it's keyword
subst, then commit. Command-line CVS does not have this limitation.
One can "cvs admin -ko FILE" to one's heart's content.
Comment 1 Ben Konrath 2004-11-18 17:51:25 EST

*** This bug has been marked as a duplicate of 139411 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.