Bug 139411 - Cannot view files from cvs repositories
Summary: Cannot view files from cvs repositories
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ben Konrath
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
: 139961 139964 139966 (view as bug list)
Depends On: 139761
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-15 21:14 UTC by Jeff Pound
Modified: 2007-04-18 17:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-26 18:38:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file (6.01 KB, text/plain)
2004-11-15 21:15 UTC, Jeff Pound
no flags Details

Description Jeff Pound 2004-11-15 21:14:19 UTC
Description of problem:
when attempting to open a file from a cvs repository, an error occurs.

Version-Release number of selected component (if applicable):
3.0.1-2

How reproducible:
always

Steps to Reproduce:
1. add a cvs repository (ext, extssh, or pserver)
2. select on a file
  
Actual results:
an error occurs

Expected results:
the file should open with the approprate editor

Comment 1 Jeff Pound 2004-11-15 21:15:17 UTC
Created attachment 106753 [details]
log file

log attatched

Comment 2 Ben Konrath 2004-11-15 22:28:51 UTC
This seems to be happening in a file touched by the cvs permissions
patch. I would like to remove the patch as it is a little hacky and
the problem solved upstream already (IIRC 3.1M4 has this fix). We
would not be regressing because this didn't go out with our intial 3.0
release.
Any thoughts?

Comment 3 Ben Konrath 2004-11-17 21:55:26 UTC
I'm going to investigate back porting the ResourceAttribute API from 3.1M3

Comment 4 Ben Konrath 2004-11-18 22:46:46 UTC
*** Bug 139966 has been marked as a duplicate of this bug. ***

Comment 5 Ben Konrath 2004-11-18 22:50:06 UTC
*** Bug 139961 has been marked as a duplicate of this bug. ***

Comment 6 Ben Konrath 2004-11-18 22:51:27 UTC
*** Bug 139964 has been marked as a duplicate of this bug. ***

Comment 7 Ben Konrath 2004-11-23 16:26:52 UTC
3.0.1-3 has the fix. I have tested the fix with all of the scenarios
that are in the duplicate bugs (and of course this one). 

Jeff:
Can you please test the new rpms and close the bug if it works.

Comment 8 Ben Konrath 2004-11-26 18:38:43 UTC
Aaron Luchko has confirmed that the fix works.


Note You need to log in before you can comment on or make changes to this bug.