Bug 139966 - Team: Cannot restore deleted file from repository
Summary: Team: Cannot restore deleted file from repository
Status: CLOSED DUPLICATE of bug 139411
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform   
(Show other bugs)
Version: 2.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tom Tromey
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-18 22:39 UTC by Keith Seitz
Modified: 2014-08-11 05:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file from session (4.35 KB, text/plain)
2004-11-18 22:41 UTC, Keith Seitz
no flags Details

Description Keith Seitz 2004-11-18 22:39:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Once a file under cvs control has been deleted (& the delete
committed), it cannot be restored.

Version-Release number of selected component (if applicable):
eclipse-platform-3.0.1-2

How reproducible:
Always

Steps to Reproduce:
1. Create new java project, HelloWorld.
2. Create new HelloWorld class. Save.
3. Right-click HelloWorld project, select Team->Share Project...
4. Select Commit All Changes... and commit everything.
5. Delete HelloWorld.java. Commit the change (Team->Commit...)
6. Try to restore by right-clicking project, select Team->Restore from
   Repository...
7. Click on HelloWorld.java in the pane, then version 1.1 (version
   before it was deleted).
8. (optional) Click Finish

Actual Results:  Get NPE printed to terminal for steps 7 & 8

Expected Results:  Should re-add the file to cvs & workspace

Additional info:

Tried with BEA & IBM JVMs. Both fail.
Log file attached. First NPE is from step 7; second is from step 8

Comment 1 Keith Seitz 2004-11-18 22:41:06 UTC
Created attachment 107002 [details]
log file from session

Comment 2 Ben Konrath 2004-11-18 22:46:44 UTC

*** This bug has been marked as a duplicate of 139411 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:07:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.